LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-21-2010, 06:09 AM   #1
Jack128
Member
 
Registered: Feb 2009
Location: Germany
Distribution: Slackware64 Current
Posts: 90

Rep: Reputation: 22
Can't compile umtsmon (0.9) on Slackware64-Current


Hello,
I've tried to build umtsmon with the slackbuild
script "http://slackbuilds.org/repository/13.1/network/umtsmon/".
I have installed the qt3- and kde3-compat libraries from /extra
out of the slackware64-current tree and it's ended up with:

Code:
src/base/SerialPort.cpp: In Elementfunktion »virtual bool SerialPort::openDev(const QString&, int, long int)«:
src/base/SerialPort.cpp:88:33: Fehler: »fstat« wurde in diesem Gültigkeitsbereich nicht definiert
src/base/SerialPort.cpp:94:33: Fehler: »S_ISCHR« wurde in diesem Gültigkeitsbereich nicht definiert
make: *** [.obj/SerialPort.o] Fehler 1
Environment variables are set:
Code:
CPLUS_INCLUDE_PATH=/opt/kde3/lib64/qt3/include
QTDIR=/opt/kde3/lib64/qt3
But it won't build.
Thanks for any kind of help.

Edit:
Comment out these error lines, it would build fine.
But a comgt/kppp setup looks better to me, now.

Regards,
Jack

Last edited by Jack128; 11-21-2010 at 01:46 PM.
 
Old 11-22-2010, 04:20 PM   #2
wargus
Member
 
Registered: Mar 2010
Location: Switzerland
Distribution: Slackware
Posts: 94

Rep: Reputation: 13
Hi

nice that you found your answer yourself, but next time try to reply to your opening post, as with this it will disappear from the Zero reply list

Schönen Abend

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot compile qjackctl from slackbuild on slackware64-current trumpet_tom Slackware 10 06-13-2011 12:57 PM
[SOLVED] Can't compile tolua++ in slackware64-current Daedra Slackware 1 03-23-2010 08:04 AM
How can I make PyQt4 slackbuild compile in Slackware64 <current>...? Alexvader Slackware 9 12-30-2009 07:45 AM
Updating from Slackware64-current to Slackware64 13. glore2002 Slackware 4 08-28-2009 06:50 PM
Slackware64-current on a second HD. glore2002 Slackware 7 08-23-2009 11:38 AM


All times are GMT -5. The time now is 01:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration