LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-20-2013, 12:23 AM   #1
MindGypsy
LQ Newbie
 
Registered: Sep 2009
Location: California
Posts: 4

Rep: Reputation: 0
Can't change my essid with iwconfig


I've used Slackware for quite awhile and only recently needed wireless and I'm having a huge mess. I can get my wireless to work in Ubuntu, Mint, Debian, even Arch Linux, so it shouldn't be a hardware issue.

Iwconfig puts out

lo no wireless extensions.

ra0 Ralink STA ESSID:"" Nickname:""
Mode:Auto Frequency=2.412 GHz Bit Rate:1 Mb/s
RTS thrff Fragment thrff
Encryption keyff
Link Quality=10/100 Signal level:0 dBm Noise level:0 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.


I try to change my essid with iwconfig ra0 essid "myessid" after of course I do ra0 up. When I try to change it, it stays exactly the same. Am I missing something or is there some other way I should try to get my wireless working?

Also when I do iwlist ra0 scan it comes up with all the wireless networks there should be and yes it shows mine as well.

I would really appreciate any help.
 
Old 08-20-2013, 02:40 AM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,041

Rep: Reputation: 977Reputation: 977Reputation: 977Reputation: 977Reputation: 977Reputation: 977Reputation: 977Reputation: 977
What puzzles me is that your output shows no access point. Hers is mine:
Code:
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:"Didier"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: A2:8D:36:18:D2:50   
          Bit Rate=1 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=61/70  Signal level=-49 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Other than that, IMO simplest way to get wireless working on Slackware-14.0 is to run as root 'netconfig' and when asked choose NetworkManager to auto-configure your network. Then, as a regular user, type 'nm-applet' to put a handy widget on your desktop.
 
1 members found this post helpful.
Old 08-20-2013, 04:58 AM   #3
jostber
Member
 
Registered: Jul 2001
Location: Skien, Norway
Distribution: Slackware 14.0 64-bit
Posts: 228

Rep: Reputation: 41
You can also install wicd, then run wicd-curses in a terminal and connect to your access point from there.
 
Old 08-20-2013, 06:11 AM   #4
MindGypsy
LQ Newbie
 
Registered: Sep 2009
Location: California
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks Didier I will try that.
Wicd for some reason does not jive with my wireless setup.
 
Old 08-20-2013, 06:25 AM   #5
jostber
Member
 
Registered: Jul 2001
Location: Skien, Norway
Distribution: Slackware 14.0 64-bit
Posts: 228

Rep: Reputation: 41
Some troubleshooting tips for Wicd here:

https://wiki.archlinux.org/index.php/Wicd
 
1 members found this post helpful.
Old 08-20-2013, 12:41 PM   #6
philanc
Member
 
Registered: Jan 2011
Posts: 60

Rep: Reputation: 21
Quote:
Originally Posted by MindGypsy View Post

Iwconfig puts out

Code:
lo        no wireless extensions.

ra0       Ralink STA  ESSID:""  Nickname:""
          Mode:Auto  Frequency=2.412 GHz  Bit Rate:1 Mb/s   
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Link Quality=10/100  Signal level:0 dBm  Noise level:0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.
(...)
I assume your access point is configured with WPA2 authentication. It looks like you didn't run wpa_supplicant.

As Didier suggested before, if your objective is just to have WiFi access working, your best bet is to use NetworkManager.

HTH

Phil
 
Old 08-20-2013, 06:59 PM   #7
the3dfxdude
Member
 
Registered: May 2007
Posts: 315

Rep: Reputation: 84
Quote:
Originally Posted by MindGypsy View Post
ra0 Ralink STA ESSID:"" Nickname:""
Ah, the ralink driver. It even went into kernel 'staging'. I had similar things happen with that driver, not playing well with userspace for setting things like ESSID, barely supported wpa_supplicant (they may have had their own hack for it), and it even had its own built in config file. Have you tried a maintained kernel driver, like rt2800pci? Maybe you need to update your kernel? Probably anything in Slack 13.37 or later will do, which is fine for me here, but I don't know which device you have.

Have you looked under this page for Ralink?
http://wireless.kernel.org/en/users/Drivers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot set ESSID using iwconfig nepeta Slackware 13 01-14-2013 12:09 PM
Cannot SET ESSID using IWCONFIG Fergatron Linux - Wireless Networking 11 04-03-2012 11:36 AM
Cannot set ESSID with iwconfig leapingfrog Linux - Wireless Networking 37 09-15-2008 03:54 AM
What's after connecting to an essid using iwconfig? rlee923 Linux - Wireless Networking 2 01-16-2007 07:31 AM
Cant change ESSID with iwconfig svenbox Linux - Hardware 1 04-27-2005 05:54 AM


All times are GMT -5. The time now is 02:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration