LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 12-17-2009, 06:09 AM   #1
portia
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 112

Rep: Reputation: 20
can't build texlive slackbuild


I'm running Slackware64-current and wanted to install texlive from slackbuilds (I'm using sbopkg)

That's what I get in the end:
Code:
../../../texk/web2c/pdftexdir/pdftoepdf.cc:993: warning: deprecated conversion from string constant to 'char*'
make[5]: *** [libpdftex_a-pdftoepdf.o] Error 1
make[5]: Leaving directory `/tmp/SBo/texlive-20091107-source/Work/texk/web2c'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/tmp/SBo/texlive-20091107-source/Work/texk/web2c'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/tmp/SBo/texlive-20091107-source/Work/texk/web2c'
make[2]: *** [subtexk] Error 1
make[2]: Leaving directory `/tmp/SBo/texlive-20091107-source/Work/texk'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/SBo/texlive-20091107-source/Work/texk'
make: *** [all-recursive] Error 1
Command exited with non-zero status 2
414.30user 89.81system 9:18.06elapsed 90%CPU (0avgtext+0avgdata 0maxresident)k
0inputs+0outputs (139major+21480136minor)pagefaults 0swaps
+ echo 2
find: `/tmp/SBo/texlive-20091107-source/inst': No such file or directory
./Build: Build failed, no executables under /tmp/SBo/texlive-20091107-source/inst/bin.
done Thu Dec 17 11:03:17 GMT 2009

texlive:
Would you like to continue processing the rest of the
build queue or would you like to abort?  If this failed
package is a dependency of another package in the queue
then it may not make sense to continue.

Press (Y)es to continue, (N)o to abort, (R)etry to try
to build the package again.
Can anyone help me with this? Do I need to download some additional things?

Thank you very much
 
Old 12-17-2009, 07:27 AM   #2
ChrisAbela
Member
 
Registered: Mar 2008
Location: Malta
Distribution: Slackware 14.1
Posts: 467

Rep: Reputation: 89
I would try running the Slackbuild directly if sbopkg failed. Read the HOWTO on www.slackbuilds.org if you need advise or post here for more questions.

Chris
 
Old 12-17-2009, 07:35 AM   #3
portia
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 112

Original Poster
Rep: Reputation: 20
I tried and got the error as well:
Code:
checking whether make sets $(MAKE)... yes
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... 
configure: error: in `/tmp/SBo/texlive-20091107-source/Work':
configure: error: C compiler cannot create executables
See `config.log' for more details.
Command exited with non-zero status 77
0.58user 0.69system 0:04.42elapsed 29%CPU (0avgtext+0avgdata 0maxresident)k
0inputs+0outputs (11major+84114minor)pagefaults 0swaps
+ echo 77
find: `/tmp/SBo/texlive-20091107-source/inst': No such file or directory
./Build: Build failed, no executables under /tmp/SBo/texlive-20091107-source/inst/bin.
Ok, it says slightly more, especially the bit about not being able to create executables, however, I've got the following packages installed:
Code:
bash-3.1# ls /var/log/packages/ | grep g++                   
gcc-g++-4.3.3-x86_64-4
bash-3.1# ls /var/log/packages/ | grep gcc
gcc-4.3.3-x86_64-4
gcc-g++-4.3.3-x86_64-4
gcc-gfortran-4.3.3-x86_64-4
gcc-gnat-4.3.3-x86_64-4
gcc-java-4.3.3-x86_64-4
gcc-objc-4.3.3-x86_64-4
gccmakedep-1.0.2-noarch-2
bash-3.1# ls /var/log/packages/ | grep glibc
glibc-2.9-x86_64-3
glibc-i18n-2.9-x86_64-3
glibc-profile-2.9-x86_64-3
glibc-solibs-2.9-x86_64-3
glibc-zoneinfo-2.9-noarch-3
bash-3.1# ls /var/log/packages/ | grep binutils
binutils-2.18.50.0.9-x86_64-2

That's config.log (btw, why does it mention a 486 build)

Code:
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by TeX Live configure 2009-10-10, which was
generated by GNU Autoconf 2.63.  Invocation command line was

  $ ../configure --prefix=/tmp/SBo/texlive-20091107-source/inst --datadir=/tmp/SBo/texlive-20091107-source/inst --with-tex-banner=TeX Live 2009 --disable-shared --disable-missing --disable-largefile --disable-threads --with-xdvi-x-toolkit=xaw --enable-multiplatform --with-tex-banner=TeX Live 2009/Slackware (unofficial) --disable-native-texlive-build --disable-static --enable-ipc --with-x --without-etex --disable-xindy --with-system-ncurses --with-system-zlib --with-system-pnglib --with-system-t1lib --with-system-gd --with-system-freetype2 --with-system-xpdf --build=i486-slackware-linux

## --------- ##
## Platform. ##
## --------- ##

hostname = slack64
uname -m = x86_64
uname -r = 2.6.29.6
uname -s = Linux
uname -v = #3 SMP Mon Dec 7 15:01:06 CST 2009

/usr/bin/uname -p = AMD Turion(tm) 64 X2 Mobile Technology TL-58
/bin/uname -X     = unknown

/bin/arch              = x86_64
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo      = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /sbin
PATH: /usr/sbin
PATH: /bin
PATH: /usr/bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:2384: checking build system type
configure:2402: result: i486-slackware-linux-gnu
configure:2424: checking host system type
configure:2439: result: i486-slackware-linux-gnu
configure:2553: Assuming `--enable-dialog=yes'
configure:2581: Assuming `--enable-pdfopen=yes'
configure:2596: Assuming `--enable-ps2eps=yes'
configure:2611: Assuming `--enable-psutils=yes'
configure:2626: Assuming `--enable-t1utils=yes'
configure:2641: Assuming `--enable-tpic2pdftex=yes'
configure:2656: Assuming `--enable-vlna=yes'
configure:2703: Assuming `--enable-web2c=yes'
configure:2878: Assuming `--enable-afm2pl=yes'
configure:2897: Assuming `--enable-bibtex8=yes'
configure:2916: Assuming `--enable-cjkutils=yes'
configure:2935: Assuming `--enable-detex=yes'
configure:2954: Assuming `--enable-devnag=yes'
configure:2969: Assuming `--enable-dtl=yes'
configure:2988: Assuming `--enable-dvi2tty=yes'
configure:3007: Assuming `--enable-dvidvi=yes'
configure:3026: Assuming `--enable-dviljk=yes'
configure:3045: Assuming `--enable-dvipdfmx=yes'
configure:3065: Assuming `--enable-dvipng=yes'
configure:3106: Assuming `--enable-dvipos=yes'
configure:3125: Assuming `--enable-dvipsk=yes'
configure:3144: Assuming `--enable-gsftopk=yes'
configure:3163: Assuming `--enable-lacheck=yes'
configure:3182: Assuming `--enable-lcdf-typetools=yes'
configure:3262: Assuming `--enable-makeindexk=yes'
configure:3281: Assuming `--enable-musixflx=yes'
configure:3296: Assuming `--enable-ps2pkm=yes'
configure:3315: Assuming `--enable-seetexk=yes'
configure:3334: Assuming `--enable-tex4htk=yes'
configure:3353: Assuming `--enable-ttf2pk=yes'
configure:3373: Assuming `--enable-ttfdump=yes'
configure:3392: Assuming `--enable-xdv2pdf=yes'
configure:3424: Assuming `--enable-xdvik=yes'
configure:3453: Assuming `--enable-xdvipdfmx=yes'
configure:3474: Assuming `--enable-tetex=yes'
configure:3489: Assuming `--enable-texlive=yes'
configure:3515: Assuming `kpathsea' headers and library from TL tree
configure:3620: Assuming `teckit' headers and library from TL tree
configure:3685: Assuming `graphite' headers and library from TL tree
configure:3726: Using installed `xpdf' headers and library
configure:3767: Using installed `gd' headers and library
configure:3779:   ->  installed `libpng' headers and library
configure:3824: Using installed `freetype2' headers and library
configure:3871: Assuming `freetype' headers and library from TL tree
configure:3922: Using installed `t1lib' headers and library
configure:3967: Using installed `libpng' headers and library
configure:4024: Using installed `zlib' headers and library
configure:4055: checking for a BSD-compatible install
configure:4123: result: /bin/ginstall -c
configure:4134: checking whether build environment is sane
configure:4194: result: yes
configure:4335: checking for a thread-safe mkdir -p
configure:4374: result: /bin/mkdir -p
configure:4387: checking for gawk
configure:4403: found /bin/gawk
configure:4414: result: gawk
configure:4425: checking whether make sets $(MAKE)
configure:4447: result: yes
configure:4502: checking for style of include used by make
configure:4530: result: GNU
configure:4600: checking for gcc
configure:4616: found /usr/bin/gcc
configure:4627: result: gcc
configure:4859: checking for C compiler version
configure:4867: gcc --version >&5
gcc (GCC) 4.3.3
Copyright (C) 2008 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:4871: $? = 0
configure:4878: gcc -v >&5
Reading specs from /usr/lib64/gcc/x86_64-slackware-linux/4.3.3/specs
Target: x86_64-slackware-linux
Configured with: ../gcc-4.3.3/configure --prefix=/usr --libdir=/usr/lib64 --enable-shared --enable-bootstrap --enable-languages=ada,c,c++,fortran,java,objc --enable-threads=posix --enable-checking=release --with-system-zlib --disable-libunwind-exceptions --enable-__cxa_atexit --enable-libssp --with-gnu-ld --verbose --disable-multilib --target=x86_64-slackware-linux --build=x86_64-slackware-linux --host=x86_64-slackware-linux
Thread model: posix
gcc version 4.3.3 (GCC) 
configure:4882: $? = 0
configure:4889: gcc -V >&5
gcc: '-V' option must have argument
configure:4893: $? = 1
configure:4916: checking for C compiler default output file name
configure:4938: gcc -O2 -march=i486 -mtune=i686   conftest.c  >&5
conftest.c:1: error: CPU you selected does not support x86-64 instruction set
configure:4942: $? = 1
configure:4980: result: 
configure: failed program was:
| /* confdefs.h.  */
| #define PACKAGE_NAME "TeX Live"
| #define PACKAGE_TARNAME "tex-live"
| #define PACKAGE_VERSION "2009-10-10"
| #define PACKAGE_STRING "TeX Live 2009-10-10"
| #define PACKAGE_BUGREPORT "tex-k@tug.org"
| /* end confdefs.h.  */
| 
| int
| main ()
| {
| 
|   ;
|   return 0;
| }
configure:4986: error: in `/tmp/SBo/texlive-20091107-source/Work':
configure:4989: error: C compiler cannot create executables
See `config.log' for more details.

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_build=i486-slackware-linux-gnu
ac_cv_env_CCC_set=
ac_cv_env_CCC_value=
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=set
ac_cv_env_CFLAGS_value='-O2 -march=i486 -mtune=i686'
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_CXXCPP_set=
ac_cv_env_CXXCPP_value=
ac_cv_env_CXXFLAGS_set=set
ac_cv_env_CXXFLAGS_value='-O2 -march=i486 -mtune=i686'
ac_cv_env_CXX_set=
ac_cv_env_CXX_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_LIBS_set=
ac_cv_env_LIBS_value=
ac_cv_env_XMKMF_set=
ac_cv_env_XMKMF_value=
ac_cv_env_build_alias_set=set
ac_cv_env_build_alias_value=i486-slackware-linux
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_host=i486-slackware-linux-gnu
ac_cv_path_install='/bin/ginstall -c'
ac_cv_path_mkdir=/bin/mkdir
ac_cv_prog_AWK=gawk
ac_cv_prog_ac_ct_CC=gcc
ac_cv_prog_make_make_set=yes

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL=''
AMDEPBACKSLASH='\'
AMDEP_FALSE='#'
AMDEP_TRUE=''
AMTAR=''
AR=''
AUTOCONF=''
AUTOHEADER=''
AUTOMAKE=''
AWK='gawk'
CC='gcc'
CCDEPMODE=''
CFLAGS='-O2 -march=i486 -mtune=i686'
CPP=''
CPPFLAGS=''
CXX=''
CXXCPP=''
CXXDEPMODE=''
CXXFLAGS='-O2 -march=i486 -mtune=i686'
CYGPATH_W=''
DEFS=''
DEPDIR='.deps'
DSYMUTIL=''
DUMPBIN=''
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP=''
EXEEXT=''
FGREP=''
FT2_CONFIG=''
GREP=''
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM='$(install_sh) -c -s'
LD=''
LDFLAGS=''
LIBOBJS=''
LIBS=''
LIBTOOL=''
LIPO=''
LN_S=''
LTLIBOBJS=''
MAINT=''
MAINTAINER_MODE_FALSE=''
MAINTAINER_MODE_TRUE=''
MAKEINFO=''
MKDIR_P='/bin/mkdir -p'
NM=''
NMEDIT=''
OBJDUMP=''
OBJEXT=''
OTOOL64=''
OTOOL=''
PACKAGE=''
PACKAGE_BUGREPORT='tex-k@tug.org'
PACKAGE_NAME='TeX Live'
PACKAGE_STRING='TeX Live 2009-10-10'
PACKAGE_TARNAME='tex-live'
PACKAGE_VERSION='2009-10-10'
PATH_SEPARATOR=':'
PKG_CONFIG=''
RANLIB=''
SED=''
SET_MAKE=''
SHELL='/bin/sh'
STRIP=''
VERSION=''
WARNING_CFLAGS=''
WARNING_CXXFLAGS=''
XMKMF=''
X_CFLAGS=''
X_EXTRA_LIBS=''
X_LIBS=''
X_PRE_LIBS=''
ac_ct_CC='gcc'
ac_ct_CXX=''
ac_ct_DUMPBIN=''
am__EXEEXT_FALSE=''
am__EXEEXT_TRUE=''
am__fastdepCC_FALSE=''
am__fastdepCC_TRUE=''
am__fastdepCXX_FALSE=''
am__fastdepCXX_TRUE=''
am__include='include'
am__isrc=''
am__leading_dot='.'
am__quote=''
am__tar=''
am__untar=''
bindir='${exec_prefix}/bin/i486-slackware-linux-gnu'
build='i486-slackware-linux-gnu'
build_alias='i486-slackware-linux'
build_cpu='i486'
build_kpathsea_FALSE=''
build_kpathsea_TRUE=''
build_os='linux-gnu'
build_vendor='slackware'
datadir='/tmp/SBo/texlive-20091107-source/inst'
datarootdir='${prefix}/share'
docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
dvidir='${docdir}'
exec_prefix='NONE'
host='i486-slackware-linux-gnu'
host_alias=''
host_cpu='i486'
host_os='linux-gnu'
host_vendor='slackware'
htmldir='${docdir}'
includedir='${prefix}/include'
infodir='${datarootdir}/info'
install_sh='${SHELL} /tmp/SBo/texlive-20091107-source/build-aux/install-sh'
libdir='${exec_prefix}/lib/i486-slackware-linux-gnu'
libexecdir='${exec_prefix}/libexec'
localedir='${datarootdir}/locale'
localstatedir='${prefix}/var'
lt_ECHO='echo'
mandir='${datarootdir}/man'
mkdir_p='/bin/mkdir -p'
oldincludedir='/usr/include'
pdfdir='${docdir}'
prefix='/tmp/SBo/texlive-20091107-source/inst'
program_transform_name='s,x,x,'
psdir='${docdir}'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
subdirs=''
sysconfdir='${prefix}/etc'
target_alias=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE_NAME "TeX Live"
#define PACKAGE_TARNAME "tex-live"
#define PACKAGE_VERSION "2009-10-10"
#define PACKAGE_STRING "TeX Live 2009-10-10"
#define PACKAGE_BUGREPORT "tex-k@tug.org"

configure: exit 77
btw, why does it mention 486 a few times?
Code:
configure:2402: result: i486-slackware-linux-gnu
configure:2424: checking host system type
configure:2439: result: i486-slackware-linux-gnu
thanks
 
Old 12-17-2009, 07:42 AM   #4
sahko
Senior Member
 
Registered: Sep 2008
Distribution: Slackware
Posts: 1,041

Rep: Reputation: Disabled
The configure: error: C compiler cannot create executables is related to http://slackbuilds.org/faq/#x86_64
 
Old 12-17-2009, 08:16 AM   #5
portia
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 112

Original Poster
Rep: Reputation: 20
Ok, thanks, it seems to be compiling ok now.
I did ARCH=x86_64 ./texlive.Slackbuild
Why couldn't it automatically adjust its parameters based on architecture recognition at the beginnig of the script? I've installed tens of slackbuilds on slackware64 without any arch-related tinkering. It's not a problem, but I'd expect that this slackbuild would be created in a similar way as other ones.

...still compiling..

right, again I've got this error:
Code:
../../../texk/web2c/pdftexdir/pdftoepdf.cc:708: error: 'class PDFDoc' has no member named 'getPDFVersion'
../../../texk/web2c/pdftexdir/pdftoepdf.cc: In function 'void write_epdf()':
../../../texk/web2c/pdftexdir/pdftoepdf.cc:979: warning: deprecated conversion from string constant to 'char*'
../../../texk/web2c/pdftexdir/pdftoepdf.cc:983: warning: deprecated conversion from string constant to 'char*'
../../../texk/web2c/pdftexdir/pdftoepdf.cc:988: warning: deprecated conversion from string constant to 'char*'
../../../texk/web2c/pdftexdir/pdftoepdf.cc:993: warning: deprecated conversion from string constant to 'char*'
make[5]: *** [libpdftex_a-pdftoepdf.o] Error 1
make[5]: Leaving directory `/tmp/SBo/texlive-20091107-source/Work/texk/web2c'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/tmp/SBo/texlive-20091107-source/Work/texk/web2c'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/tmp/SBo/texlive-20091107-source/Work/texk/web2c'
make[2]: *** [subtexk] Error 1
make[2]: Leaving directory `/tmp/SBo/texlive-20091107-source/Work/texk'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/SBo/texlive-20091107-source/Work/texk'
make: *** [all-recursive] Error 1
Command exited with non-zero status 2
418.31user 95.99system 10:00.13elapsed 85%CPU (0avgtext+0avgdata 0maxresident)k
0inputs+0outputs (37major+21491939minor)pagefaults 0swaps
+ echo 2
find: `/tmp/SBo/texlive-20091107-source/inst': No such file or directory
./Build: Build failed, no executables under /tmp/SBo/texlive-20091107-source/inst/bin.
done Thu Dec 17 13:08:21 GMT 2009
yes, /tmp/SBo/texlive-20091107-source/INST does not exist. I wonder why. The slackbuild is being run as root.
 
Old 12-17-2009, 08:49 AM   #6
ChrisAbela
Member
 
Registered: Mar 2008
Location: Malta
Distribution: Slackware 14.1
Posts: 467

Rep: Reputation: 89
Quote:
Why couldn't it automatically adjust its parameters based on architecture recognition at the beginnig of the script?
This question was raised in the slackbuilds mails, I do not agree that this should be automatically detected as it may be a limiting factor when using the scripts for other derivative distros. It simply does not fit well in the Slackware's philosophy, but then who am I?

The important fact is that slackbuilds do not check the ARCH. Just enter this once as root and forget it:

Quote:
echo "ARCH=x86_64" >> ~/.bash_profile
exit and log in again. You may check it out with

Quote:
echo $ARCH
As for the error, I cannot help you right now, hopefully someone else can.

Chris

Last edited by ChrisAbela; 12-17-2009 at 08:50 AM.
 
Old 12-17-2009, 09:15 AM   #7
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,974

Rep: Reputation: Disabled
Did you change the script in any way before trying to run it on -current?
If not, you should read the script. :-)

Before anyone comments about how reading the script should not be needed, might I remind you that the script is tested and verified on Slackware 13.0. If you plan to use it on -current or some other release, then you have an obligation to read the script and see if anything stands out as wrong or needing changes.
 
Old 12-17-2009, 09:18 AM   #8
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,974

Rep: Reputation: Disabled
Quote:
Originally Posted by portia View Post
Why couldn't it automatically adjust its parameters based on architecture recognition at the beginnig of the script?
Because Pat's scripts for 13.0 don't do that, and generally speaking, we don't try to introduce new stuff like that. We wrote usage instructions and an FAQ for a reason, and we expect our users to read and be familiar with them.

Quote:
I've installed tens of slackbuilds on slackware64 without any arch-related tinkering.
You might want to go back and check the packages you have installed then and verify that they are correct.

Quote:
It's not a problem, but I'd expect that this slackbuild would be created in a similar way as other ones.
It is.
 
Old 12-17-2009, 10:47 AM   #9
portia
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 112

Original Poster
Rep: Reputation: 20
Quote:
Did you change the script in any way before trying to run it on -current?
If not, you should read the script. :-)
No, I didn't change the script. I guess it would make sense to read the script first. I just did not bother as it's
the first slackbuild that I've had problems with.

Quote:
We wrote usage instructions and an FAQ for a reason, and we expect our users to read and be familiar with them.
Apologise for not appreciating your hard work writing documentation for us, LOL
I am going to read the script. I know that it's there to help me.
Quote:
You might want to go back and check the packages you have installed then and verify that they are correct.
Seriously, that's the first slackbuild I've had problems with (at least when it comes to applications). Whenever I install some application from slackbuilds I usually check it straight away.


I'll post anything that's unclear for me in the script.
 
Old 12-18-2009, 10:49 PM   #10
GooseYArd
Member
 
Registered: Jul 2009
Location: Reston, VA
Distribution: Slackware, Ubuntu, RHEL
Posts: 183

Rep: Reputation: 46
Quote:
Originally Posted by portia View Post

right, again I've got this error:
Code:
../../../texk/web2c/pdftexdir/pdftoepdf.cc:708: error: 'class PDFDoc' has no member named 'getPDFVersion'
../../../texk/web2c/pdftexdir/pdftoepdf.cc: In function 'void write_epdf()':
../../../texk/web2c/pdftexdir/pdftoepdf.cc:979: warning: deprecated conversion from string constant to 'char*'
../../../texk/web2c/pdftexdir/pdftoepdf.cc:983: warning: deprecated conversion from string constant to 'char*'
../../../texk/web2c/pdftexdir/pdftoepdf.cc:988: warning: deprecated conversion from string constant to 'char*'
../../../texk/web2c/pdftexdir/pdftoepdf.cc:993: warning: deprecated conversion from string constant to 'char*'
make[5]: *** [libpdftex_a-pdftoepdf.o] Error 1
make[5]: Leaving directory `/tmp/SBo/texlive-20091107-source/Work/texk/web2c'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/tmp/SBo/texlive-20091107-source/Work/texk/web2c'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/tmp/SBo/texlive-20091107-source/Work/texk/web2c'
make[2]: *** [subtexk] Error 1
make[2]: Leaving directory `/tmp/SBo/texlive-20091107-source/Work/texk'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/SBo/texlive-20091107-source/Work/texk'
make: *** [all-recursive] Error 1
Command exited with non-zero status 2
418.31user 95.99system 10:00.13elapsed 85%CPU (0avgtext+0avgdata 0maxresident)k
0inputs+0outputs (37major+21491939minor)pagefaults 0swaps
+ echo 2
find: `/tmp/SBo/texlive-20091107-source/inst': No such file or directory
./Build: Build failed, no executables under /tmp/SBo/texlive-20091107-source/inst/bin.
done Thu Dec 17 13:08:21 GMT 2009
yes, /tmp/SBo/texlive-20091107-source/INST does not exist. I wonder why. The slackbuild is being run as root.
I think I ran into this one a while back. The poppler update from 10.7 to 12.2 broke the texlive build for me. I temporarily reverted to the older poppler version and texlive builds.

I believe the texlive guys know about the issue, but when I looked into it a couple months ago, they didn't have a fix yet.

.andy
 
Old 12-18-2009, 11:24 PM   #11
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,974

Rep: Reputation: Disabled
Quote:
Originally Posted by GooseYArd View Post
I think I ran into this one a while back. The poppler update from 10.7 to 12.2 broke the texlive build for me. I temporarily reverted to the older poppler version and texlive builds.

I believe the texlive guys know about the issue, but when I looked into it a couple months ago, they didn't have a fix yet.
Somebody has patches available (ArchLinux iirc), but I just used the included xpdf library instead of the system xpdf. The biggest disadvantage of doing it that way is security updates of xpdf require the texlive folks to respin their sources and you to rebuild texlive. However, since xpdf, historically speaking, is going to break ABI anyway with their security updates, you'll have to rebuild texlive regardless.
 
Old 12-19-2009, 12:08 PM   #12
GooseYArd
Member
 
Registered: Jul 2009
Location: Reston, VA
Distribution: Slackware, Ubuntu, RHEL
Posts: 183

Rep: Reputation: 46
Quote:
Originally Posted by rworkman View Post
Somebody has patches available (ArchLinux iirc), but I just used the included xpdf library instead of the system xpdf. The biggest disadvantage of doing it that way is security updates of xpdf require the texlive folks to respin their sources and you to rebuild texlive. However, since xpdf, historically speaking, is going to break ABI anyway with their security updates, you'll have to rebuild texlive regardless.
oh duh, I couldn't figure out what you meant until I, you guessed it, read the script

Thanks!
 
Old 12-19-2009, 08:34 PM   #13
grissiom
Member
 
Registered: Apr 2008
Location: China, Beijing
Distribution: Slackware
Posts: 423

Rep: Reputation: 45
@rworkman Maybe the issue with poppler should be mentioned in README? That will be easier to catch the user I think...
 
Old 12-20-2009, 03:47 AM   #14
portia
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 112

Original Poster
Rep: Reputation: 20
I modified the script to include --without-system-xpdf. I also removed tetex and tetex-docs (as suggested in README), but it still fails to compile. Is there anything else to solve the problem?
Thank you

Code:
configure: Assuming `--enable-ps2pkm=yes'
configure: Assuming `--enable-seetexk=yes'
configure: Assuming `--enable-tex4htk=yes'
configure: Assuming `--enable-ttf2pk=yes'
configure: Assuming `--enable-ttfdump=yes'
configure: Assuming `--enable-xdv2pdf=yes'
configure: Assuming `--enable-xdvik=yes'
configure: Assuming `--enable-xdvipdfmx=yes'
configure: Assuming `--enable-tetex=yes'
configure: Assuming `--enable-texlive=yes'
configure: Assuming `kpathsea' headers and library from TL tree
configure: Assuming `teckit' headers and library from TL tree
configure: Assuming `graphite' headers and library from TL tree
configure: Using `xpdf' headers and library from TL tree
configure: Using installed `gd' headers and library
configure:   ->  installed `libpng' headers and library
configure: Using installed `freetype2' headers and library
configure: Assuming `freetype' headers and library from TL tree
configure: Using installed `t1lib' headers and library
configure: Using installed `libpng' headers and library
configure: Using installed `zlib' headers and library
checking for a BSD-compatible install... /bin/ginstall -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... 
configure: error: in `/tmp/SBo/texlive-20091107-source/Work':
configure: error: C compiler cannot create executables
See `config.log' for more details.
Command exited with non-zero status 77
0.23user 0.27system 0:02.69elapsed 18%CPU (0avgtext+0avgdata 0maxresident)k
0inputs+0outputs (1major+83808minor)pagefaults 0swaps
+ echo 77
find: `/tmp/SBo/texlive-20091107-source/inst': No such file or directory
./Build: Build failed, no executables under /tmp/SBo/texlive-20091107-source/inst/bin.
done Sun Dec 20 08:28:49 GMT 2009
config.log
Code:
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by TeX Live configure 2009-10-10, which was
generated by GNU Autoconf 2.63.  Invocation command line was

  $ ../configure --prefix=/tmp/SBo/texlive-20091107-source/inst --datadir=/tmp/SBo/texlive-20091107-source/inst --with-tex-banner=TeX Live 2009 --disable-shared --disable-missing --disable-largefile --disable-threads --with-xdvi-x-toolkit=xaw --enable-multiplatform --with-tex-banner=TeX Live 2009/Slackware (unofficial) --disable-native-texlive-build --disable-static --enable-ipc --with-x --without-etex --disable-xindy --with-system-ncurses --with-system-zlib --with-system-pnglib --with-system-t1lib --with-system-gd --with-system-freetype2 --without-system-xpdf --build=i486-slackware-linux

## --------- ##
## Platform. ##
## --------- ##

hostname = slack64
uname -m = x86_64
uname -r = 2.6.29.6
uname -s = Linux
uname -v = #3 SMP Mon Dec 7 15:01:06 CST 2009

/usr/bin/uname -p = AMD Turion(tm) 64 X2 Mobile Technology TL-58
/bin/uname -X     = unknown

/bin/arch              = x86_64
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo      = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /sbin
PATH: /usr/sbin
PATH: /bin
PATH: /usr/bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:2384: checking build system type
configure:2402: result: i486-slackware-linux-gnu
configure:2424: checking host system type
configure:2439: result: i486-slackware-linux-gnu
configure:2553: Assuming `--enable-dialog=yes'
configure:2581: Assuming `--enable-pdfopen=yes'
configure:2596: Assuming `--enable-ps2eps=yes'
configure:2611: Assuming `--enable-psutils=yes'
configure:2626: Assuming `--enable-t1utils=yes'
configure:2641: Assuming `--enable-tpic2pdftex=yes'
configure:2656: Assuming `--enable-vlna=yes'
configure:2703: Assuming `--enable-web2c=yes'
configure:2878: Assuming `--enable-afm2pl=yes'
configure:2897: Assuming `--enable-bibtex8=yes'
configure:2916: Assuming `--enable-cjkutils=yes'
configure:2935: Assuming `--enable-detex=yes'
configure:2954: Assuming `--enable-devnag=yes'
configure:2969: Assuming `--enable-dtl=yes'
configure:2988: Assuming `--enable-dvi2tty=yes'
configure:3007: Assuming `--enable-dvidvi=yes'
configure:3026: Assuming `--enable-dviljk=yes'
configure:3045: Assuming `--enable-dvipdfmx=yes'
configure:3065: Assuming `--enable-dvipng=yes'
configure:3106: Assuming `--enable-dvipos=yes'
configure:3125: Assuming `--enable-dvipsk=yes'
configure:3144: Assuming `--enable-gsftopk=yes'
configure:3163: Assuming `--enable-lacheck=yes'
configure:3182: Assuming `--enable-lcdf-typetools=yes'
configure:3262: Assuming `--enable-makeindexk=yes'
configure:3281: Assuming `--enable-musixflx=yes'
configure:3296: Assuming `--enable-ps2pkm=yes'
configure:3315: Assuming `--enable-seetexk=yes'
configure:3334: Assuming `--enable-tex4htk=yes'
configure:3353: Assuming `--enable-ttf2pk=yes'
configure:3373: Assuming `--enable-ttfdump=yes'
configure:3392: Assuming `--enable-xdv2pdf=yes'
configure:3424: Assuming `--enable-xdvik=yes'
configure:3453: Assuming `--enable-xdvipdfmx=yes'
configure:3474: Assuming `--enable-tetex=yes'
configure:3489: Assuming `--enable-texlive=yes'
configure:3515: Assuming `kpathsea' headers and library from TL tree
configure:3620: Assuming `teckit' headers and library from TL tree
configure:3685: Assuming `graphite' headers and library from TL tree
configure:3729: Using `xpdf' headers and library from TL tree
configure:3767: Using installed `gd' headers and library
configure:3779:   ->  installed `libpng' headers and library
configure:3824: Using installed `freetype2' headers and library
configure:3871: Assuming `freetype' headers and library from TL tree
configure:3922: Using installed `t1lib' headers and library
configure:3967: Using installed `libpng' headers and library
configure:4024: Using installed `zlib' headers and library
configure:4055: checking for a BSD-compatible install
configure:4123: result: /bin/ginstall -c
configure:4134: checking whether build environment is sane
configure:4194: result: yes
configure:4335: checking for a thread-safe mkdir -p
configure:4374: result: /bin/mkdir -p
configure:4387: checking for gawk
configure:4403: found /bin/gawk
configure:4414: result: gawk
configure:4425: checking whether make sets $(MAKE)
configure:4447: result: yes
configure:4502: checking for style of include used by make
configure:4530: result: GNU
configure:4600: checking for gcc
configure:4616: found /usr/bin/gcc
configure:4627: result: gcc
configure:4859: checking for C compiler version
configure:4867: gcc --version >&5
gcc (GCC) 4.3.3
Copyright (C) 2008 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:4871: $? = 0
configure:4878: gcc -v >&5
Reading specs from /usr/lib64/gcc/x86_64-slackware-linux/4.3.3/specs
Target: x86_64-slackware-linux
Configured with: ../gcc-4.3.3/configure --prefix=/usr --libdir=/usr/lib64 --enable-shared --enable-bootstrap --enable-languages=ada,c,c++,fortran,java,objc --enable-threads=posix --enable-checking=release --with-system-zlib --disable-libunwind-exceptions --enable-__cxa_atexit --enable-libssp --with-gnu-ld --verbose --disable-multilib --target=x86_64-slackware-linux --build=x86_64-slackware-linux --host=x86_64-slackware-linux
Thread model: posix
gcc version 4.3.3 (GCC) 
configure:4882: $? = 0
configure:4889: gcc -V >&5
gcc: '-V' option must have argument
configure:4893: $? = 1
configure:4916: checking for C compiler default output file name
configure:4938: gcc -O2 -march=i486 -mtune=i686   conftest.c  >&5
conftest.c:1: error: CPU you selected does not support x86-64 instruction set
configure:4942: $? = 1
configure:4980: result: 
configure: failed program was:
| /* confdefs.h.  */
| #define PACKAGE_NAME "TeX Live"
| #define PACKAGE_TARNAME "tex-live"
| #define PACKAGE_VERSION "2009-10-10"
| #define PACKAGE_STRING "TeX Live 2009-10-10"
| #define PACKAGE_BUGREPORT "tex-k@tug.org"
| /* end confdefs.h.  */
| 
| int
| main ()
| {
| 
|   ;
|   return 0;
| }
configure:4986: error: in `/tmp/SBo/texlive-20091107-source/Work':
configure:4989: error: C compiler cannot create executables
See `config.log' for more details.

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_build=i486-slackware-linux-gnu
ac_cv_env_CCC_set=
ac_cv_env_CCC_value=
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=set
ac_cv_env_CFLAGS_value='-O2 -march=i486 -mtune=i686'
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_CXXCPP_set=
ac_cv_env_CXXCPP_value=
ac_cv_env_CXXFLAGS_set=set
ac_cv_env_CXXFLAGS_value='-O2 -march=i486 -mtune=i686'
ac_cv_env_CXX_set=
ac_cv_env_CXX_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_LIBS_set=
ac_cv_env_LIBS_value=
ac_cv_env_XMKMF_set=
ac_cv_env_XMKMF_value=
ac_cv_env_build_alias_set=set
ac_cv_env_build_alias_value=i486-slackware-linux
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_host=i486-slackware-linux-gnu
ac_cv_path_install='/bin/ginstall -c'
ac_cv_path_mkdir=/bin/mkdir
ac_cv_prog_AWK=gawk
ac_cv_prog_ac_ct_CC=gcc
ac_cv_prog_make_make_set=yes

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL=''
AMDEPBACKSLASH='\'
AMDEP_FALSE='#'
AMDEP_TRUE=''
AMTAR=''
AR=''
AUTOCONF=''
AUTOHEADER=''
AUTOMAKE=''
AWK='gawk'
CC='gcc'
CCDEPMODE=''
CFLAGS='-O2 -march=i486 -mtune=i686'
CPP=''
CPPFLAGS=''
CXX=''
CXXCPP=''
CXXDEPMODE=''
CXXFLAGS='-O2 -march=i486 -mtune=i686'
CYGPATH_W=''
DEFS=''
DEPDIR='.deps'
DSYMUTIL=''
DUMPBIN=''
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP=''
EXEEXT=''
FGREP=''
FT2_CONFIG=''
GREP=''
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM='$(install_sh) -c -s'
LD=''
LDFLAGS=''
LIBOBJS=''
LIBS=''
LIBTOOL=''
LIPO=''
LN_S=''
LTLIBOBJS=''
MAINT=''
MAINTAINER_MODE_FALSE=''
MAINTAINER_MODE_TRUE=''
MAKEINFO=''
MKDIR_P='/bin/mkdir -p'
NM=''
NMEDIT=''
OBJDUMP=''
OBJEXT=''
OTOOL64=''
OTOOL=''
PACKAGE=''
PACKAGE_BUGREPORT='tex-k@tug.org'
PACKAGE_NAME='TeX Live'
PACKAGE_STRING='TeX Live 2009-10-10'
PACKAGE_TARNAME='tex-live'
PACKAGE_VERSION='2009-10-10'
PATH_SEPARATOR=':'
PKG_CONFIG=''
RANLIB=''
SED=''
SET_MAKE=''
SHELL='/bin/sh'
STRIP=''
VERSION=''
WARNING_CFLAGS=''
WARNING_CXXFLAGS=''
XMKMF=''
X_CFLAGS=''
X_EXTRA_LIBS=''
X_LIBS=''
X_PRE_LIBS=''
ac_ct_CC='gcc'
ac_ct_CXX=''
ac_ct_DUMPBIN=''
am__EXEEXT_FALSE=''
am__EXEEXT_TRUE=''
am__fastdepCC_FALSE=''
am__fastdepCC_TRUE=''
am__fastdepCXX_FALSE=''
am__fastdepCXX_TRUE=''
am__include='include'
am__isrc=''
am__leading_dot='.'
am__quote=''
am__tar=''
am__untar=''
bindir='${exec_prefix}/bin/i486-slackware-linux-gnu'
build='i486-slackware-linux-gnu'
build_alias='i486-slackware-linux'
build_cpu='i486'
build_kpathsea_FALSE=''
build_kpathsea_TRUE=''
build_os='linux-gnu'
build_vendor='slackware'
datadir='/tmp/SBo/texlive-20091107-source/inst'
datarootdir='${prefix}/share'
docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
dvidir='${docdir}'
exec_prefix='NONE'
host='i486-slackware-linux-gnu'
host_alias=''
host_cpu='i486'
host_os='linux-gnu'
host_vendor='slackware'
htmldir='${docdir}'
includedir='${prefix}/include'
infodir='${datarootdir}/info'
install_sh='${SHELL} /tmp/SBo/texlive-20091107-source/build-aux/install-sh'
libdir='${exec_prefix}/lib/i486-slackware-linux-gnu'
libexecdir='${exec_prefix}/libexec'
localedir='${datarootdir}/locale'
localstatedir='${prefix}/var'
lt_ECHO='echo'
mandir='${datarootdir}/man'
mkdir_p='/bin/mkdir -p'
oldincludedir='/usr/include'
pdfdir='${docdir}'
prefix='/tmp/SBo/texlive-20091107-source/inst'
program_transform_name='s,x,x,'
psdir='${docdir}'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
subdirs=''
sysconfdir='${prefix}/etc'
target_alias=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE_NAME "TeX Live"
#define PACKAGE_TARNAME "tex-live"
#define PACKAGE_VERSION "2009-10-10"
#define PACKAGE_STRING "TeX Live 2009-10-10"
#define PACKAGE_BUGREPORT "tex-k@tug.org"

configure: exit 77
 
Old 12-20-2009, 05:51 AM   #15
grissiom
Member
 
Registered: Apr 2008
Location: China, Beijing
Distribution: Slackware
Posts: 423

Rep: Reputation: 45
In your config.log, I found `--build=i486-slackware-linux` which is a sign of wrong ARCH. Try run `ARCH=x86_64 ./texlive.SlackBuild`.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TeXLive Build Script for Slackware rworkman Slackware 14 11-15-2009 05:47 AM
Help: Chinese support in TeXlive chp Linux - Software 0 09-26-2008 11:27 AM
SlackBuild.org nvidia kernel build script bug Woodsman Slackware 3 04-06-2008 08:48 PM
trouble with alien's slackbuild for freenx: cannot stat freenx/build/nomachine.id_dsa BCarey Slackware 2 03-12-2008 10:00 PM
TexLive ahallam Red Hat 1 11-09-2006 12:00 AM


All times are GMT -5. The time now is 07:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration