LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 05-28-2011, 09:17 AM   #1
sudeepkulkarni
Member
 
Registered: Mar 2011
Location: Sangli, Maharashtra, India
Distribution: Linux Mint 11 (Katya), Slackware 13.1, Slackware 13.37
Posts: 30

Rep: Reputation: 0
Exclamation Can't boot into Slackware 13.37 on my Dell XPS 15


When I installed Slackware 13.37 for the first time, there was no problem. Everything worked very well - as expected from this great distro.

But, the LILO won't detect Windows installation correctly. So I tried to edit it using liliconfig, where I wrongly entered the entry for Linux. So without further messing around with the system, I went for reinstalling the whole system.

Now when I chose 'Linux' in LILO menu, Some initial startup scripts ran correctly - like detecting and mounting the root and non-root file systems.

But then the suddenly screen went black. It happened so fast, then and again, that I couldn't take a look at what's wrong.

My best guess is that there's a problem with video driver. (The laptop has nVidia GeForce graphics card)
 
Old 05-28-2011, 10:49 AM   #2
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,087

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Sounds like KMS is kicking in and has issues with your video card or monitor. If you pass 'nomodeset' to the kernel, does the machine continue to come up?
 
Old 05-28-2011, 10:56 AM   #3
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,289

Rep: Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802
Does this Dell XPS 15 have Optimus technology and can you disable it in the BIOS?

[Edit] There is a thread at Ubuntu that may be applicable. http://ubuntuforums.org/showthread.php?t=1763271 [/Edit]

Last edited by allend; 05-28-2011 at 11:04 AM.
 
Old 05-28-2011, 10:26 PM   #4
psionl0
Member
 
Registered: Jan 2011
Distribution: slackware_64 14.0
Posts: 505
Blog Entries: 2

Rep: Reputation: 67
How do you "pass 'nomodeset' to the kernel"?
 
Old 05-29-2011, 01:05 AM   #5
sudeepkulkarni
Member
 
Registered: Mar 2011
Location: Sangli, Maharashtra, India
Distribution: Linux Mint 11 (Katya), Slackware 13.1, Slackware 13.37
Posts: 30

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by allend View Post
Does this Dell XPS 15 have Optimus technology and can you disable it in the BIOS?

[Edit] There is a thread at Ubuntu that may be applicable. http://ubuntuforums.org/showthread.php?t=1763271 [/Edit]

Yes, it does have Optimus technology. I don't want to disable it however. Isn't there any other way around? Because as I mentioned, everything worked smoothly for the first time.

I read the thread you posted. The problem is that those steps are to be done in terminal and need Internet connection. I am not reaching the login stage while booting, and even if I do, I won't be able to connect to Internet as I have USB modem that has to be configured later on using an installation script.
 
Old 05-29-2011, 01:07 AM   #6
sudeepkulkarni
Member
 
Registered: Mar 2011
Location: Sangli, Maharashtra, India
Distribution: Linux Mint 11 (Katya), Slackware 13.1, Slackware 13.37
Posts: 30

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by adamk75 View Post
Sounds like KMS is kicking in and has issues with your video card or monitor. If you pass 'nomodeset' to the kernel, does the machine continue to come up?
Do I have to do it while installing - at the point where the set-up asks whether you want to pass extra parameters while booting?
 
Old 05-29-2011, 03:49 AM   #7
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,222

Rep: Reputation: 285Reputation: 285Reputation: 285
Quote:
Originally Posted by sudeepkulkarni View Post
Do I have to do it while installing - at the point where the set-up asks whether you want to pass extra parameters while booting?
You can add nomodeset to the append line in /etc/lilo.conf. Then rerun lilo. You should be able to boot from the Slackware install DVD to do this if you can not boot the instaled system.
 
Old 05-29-2011, 05:56 AM   #8
xj25vm
Member
 
Registered: Jun 2008
Posts: 260

Rep: Reputation: 16
To use nomodeset during boot, I believe you press TAB when you see the lilo screen (there is a message on the screen actually), type in (or leave in, if it is already there) the name of the boot option you want (normally called Linux, unless you changed it in lilo.conf), type a space, then the word nomodeset. This is equivalent to going in lilo.conf and adding nomodeset to the append parameter - but as you can't even boot, you can pass nomodeset during boot.

It looks like I have the same problem, with an Intel integrated video chip, and at the moment I've switched to using nomodeset and the vesa Xorg driver - until I get to try a newer kernel. Here is the thread:

http://www.linuxquestions.org/questi...3-37-a-882680/

Sebastian

P.S. If you are using nomodeset, you will have to use the vesa driver in XOrg as well, until you get things sorted.
 
1 members found this post helpful.
Old 05-29-2011, 06:04 AM   #9
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,222

Rep: Reputation: 285Reputation: 285Reputation: 285
Quote:
Originally Posted by xj25vm View Post
To use nomodeset during boot, I believe you press TAB when you see the lilo screen ...
Thanks for postting that. I could not exactly remember how to pass options to lilo 'on the fly' like that using the TAB key.
Although I have been using Slackware for several years, I have been booting Slckware from Ubuntu's grub. So I have very little experience with lilo.

Last edited by tommcd; 05-30-2011 at 01:12 PM. Reason: correct a spelling typo. post content unchanged.
 
Old 05-30-2011, 03:32 AM   #10
sudeepkulkarni
Member
 
Registered: Mar 2011
Location: Sangli, Maharashtra, India
Distribution: Linux Mint 11 (Katya), Slackware 13.1, Slackware 13.37
Posts: 30

Original Poster
Rep: Reputation: 0
I tried using 'nomodeset' as described by xj25vm. It also doesn't work.

Now I see KDE initialization screen. But as soon as it completes, KDE crashes. there were many error messages. I believe following was important:

xprop: can't find display 0

As far as I know, this probably means my monitor is not recognized.

And what is the root of the problem anyway? nouveau should be working fine.
 
Old 05-30-2011, 04:38 AM   #11
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,087

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
KDE is likely crashing because it is trying to enable compositing. Does xfce4 work? If so, start up xfce4, launch KDE's systemsettings, and then disable compositing in KDE (under desktop effects).

Adam
 
1 members found this post helpful.
Old 05-31-2011, 03:12 AM   #12
xj25vm
Member
 
Registered: Jun 2008
Posts: 260

Rep: Reputation: 16
Well - if you get all the way to KDE - then 'nomodeset' actually works. Otherwise you wouldn't see anything on the screen after about the 12th second (on a slowish, Intel U2500, 1.2GHz machine) of the boot process.

On the other hand, I use Fluxbox, so not sure if there is a further problem with KDE.

Then again, maybe your problem is different then mine, as, without 'nomodeset' - my screen would go black before getting to mounting root volume.
 
1 members found this post helpful.
Old 05-31-2011, 06:09 AM   #13
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 10,888
Blog Entries: 1

Rep: Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307
Hi,

Quote:
Originally Posted by psionl0 View Post
How do you "pass 'nomodeset' to the kernel"?
If you use the Install DVD to boot then at the 'boot:' prompt;
Code:
boot: huge.s root=/dev/your_dev rdinit= ro nomodeset
Initial screen provides a sample of booting a kernel, then you can add parameters at the end of that input line to pass parameter(s) to the kernel. This way you do not need to modify the '/etc/lilo.conf' in order to pass parameters. If you decide later that parameters are necessary then place parameters in '/etc/lilo.conf' and then run 'lilo' to update your bootloader.
 
1 members found this post helpful.
Old 06-01-2011, 04:49 AM   #14
sudeepkulkarni
Member
 
Registered: Mar 2011
Location: Sangli, Maharashtra, India
Distribution: Linux Mint 11 (Katya), Slackware 13.1, Slackware 13.37
Posts: 30

Original Poster
Rep: Reputation: 0
Smile

Quote:
Originally Posted by adamk75 View Post
KDE is likely crashing because it is trying to enable compositing. Does xfce4 work? If so, start up xfce4, launch KDE's systemsettings, and then disable compositing in KDE (under desktop effects).

Adam
Thanks. That exactly was the problem. XFCE works fine. Guess I will use it as default
 
  


Reply

Tags
boot failure


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can Slackware Linux 12.2 be loaded on a Dell Studio XPS Laptop? Twilight_Bandit Linux - Laptop and Netbook 7 05-30-2009 04:06 AM
Slackware 12.1 /dev/dsp problems on Dell XPS M1530... tiedyedsoul Linux - Hardware 2 12-27-2008 04:06 PM
Slackware installation on dell xps m140 bijit1709 Slackware 9 06-08-2007 04:37 PM
New kernel won't boot on Dell XPS m1210 Zerathidune Linux - Laptop and Netbook 2 12-31-2006 11:52 AM
dell xps: linux won't boot now... only windows!! deiz92 Linux - Software 5 10-20-2006 04:22 PM


All times are GMT -5. The time now is 05:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration