LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 01-04-2004, 11:53 PM   #1
HyBriDJoKeR
Member
 
Registered: Jan 2004
Location: North Carolina
Distribution: Slackware
Posts: 31

Rep: Reputation: 15
Can't Start KDE, Only Boots To Console


When I boot Slackware 9.1, it boots to the console. I use the command 'startx' but I receive this error messege:

XIO: fatal IO error 104 (connetion reset by peer) on X server "0.0" after 0 requests (0 known processed) with 0 events remaining.
 
Old 01-05-2004, 12:20 AM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
HyBriDJoKeR,

What video card are you using? Sounds like something typical for a Nvidia card without the proper drivers. What video card are you running, and have you installed the drivers for it yet?

If you have all the information about your mouse, monitor, and video card - you can try running xf86config from that command line as a normal user.

Last edited by Bruce Hill; 01-05-2004 at 12:23 AM.
 
Old 01-05-2004, 12:22 AM   #3
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,724

Rep: Reputation: 449Reputation: 449Reputation: 449Reputation: 449Reputation: 449
You need to run xf86config in order to configure X. Don't worry about graphic memory size or about 'device indentifiers'. First backup /etc/X11/XF86Config. This is the file that xf86config will overwrite. A useful command: CTRL+ALT+BACKSPACE. This will kill X if you have problems such as mouse not working. After running xf86config then type startx. If you have installed other windowmanagers you can choose which one to use by running(from console) xwmconfig, then startx
You can set it up so that Slack boots to a graphic login by editing the file /etc/inittab and changing the line
id:3:initdefault
to
id:4:initdefault
However this is not really a good idea since if your X configuration isn't right or you ever have problems in X, this setting will put your box in a loop where you can't shutdown or login. If you decide to try this anyway, be sure you have a rescue disk around, like tomsrtbt, so you can boot, mount your partition and change this. It's not as elegant to have to type startx each time but it's MUCH safer.
Also don't use the other X configuration utilities such as xfree86setup or xf86cfg as they will create an incomplete XF86Config file which will cause the problems I described above (CTSL+ALT+BACKSPACE doesn't work in these case!)
The only times I have ever 'lost' a Slackware install is from having to crash it because of improper X configuration. If you are using ext2 file system, it may recover once or twice, but usually not three times. Reiser file system is much better at recovering itself.
Start with conservative settings for horizontal and vertical sync in xf86config unless you know your monitors capabilities.
 
Old 01-05-2004, 12:27 AM   #4
HyBriDJoKeR
Member
 
Registered: Jan 2004
Location: North Carolina
Distribution: Slackware
Posts: 31

Original Poster
Rep: Reputation: 15
Im using a GeForce 4 Ti 4200

Last edited by HyBriDJoKeR; 01-05-2004 at 12:29 AM.
 
Old 01-05-2004, 12:44 AM   #5
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Quote:
Originally posted by HyBriDJoKeR
Im using a GeForce 4 Ti 4200
Go to the Nvidia driver archives and get that driver. Print the README - Text Version file and follow the instructions.

There is a new driver but many people have had problems with it, and I would not recommend that one (NVIDIA-Linux-x86-1.0-5328-pkg1.run).
 
Old 01-05-2004, 09:26 AM   #6
jeempc
Member
 
Registered: Mar 2003
Location: Ann Arbor, MI
Distribution: Slackware 10.1
Posts: 119

Rep: Reputation: 15
You may just have to add a user first. This will create the home directory where X places its files.

user the adduser command as root.
 
Old 01-05-2004, 01:56 PM   #7
HyBriDJoKeR
Member
 
Registered: Jan 2004
Location: North Carolina
Distribution: Slackware
Posts: 31

Original Poster
Rep: Reputation: 15
Ok, I tried adding a new user and the Linux driver. Still no cigar
 
Old 01-05-2004, 05:02 PM   #8
HyBriDJoKeR
Member
 
Registered: Jan 2004
Location: North Carolina
Distribution: Slackware
Posts: 31

Original Poster
Rep: Reputation: 15
I got it working Now to get the sound to work...
 
Old 06-25-2004, 12:24 PM   #9
tar
LQ Newbie
 
Registered: Jun 2004
Posts: 1

Rep: Reputation: 0
how???

How did you get it working? I've got the same problem.
It worked until I added a new user, but then it just stopped...
 
Old 06-26-2004, 05:09 AM   #10
skog
Member
 
Registered: Sep 2003
Location: TX
Distribution: slackware
Posts: 301

Rep: Reputation: 30
you added a new user and now that user cant use it or it doesnt work for anyone?

if just that user cant use X then its a permission problem ... if it isnt working for anyone then you got something messed up. Try with root or even better the user you were using before you added a new user.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake boots console.... xennetwork Linux - Newbie 1 08-21-2005 07:07 AM
No console display when new kernel boots phollow Linux - Newbie 9 04-28-2005 05:31 PM
How do i get named to start when machine boots? abefroman Linux - Networking 1 03-15-2004 02:28 AM
Start KDE from console? Sn1PeR Red Hat 2 09-11-2003 11:59 PM
Start Apache when system boots up eweborg Linux - General 1 03-05-2002 12:37 AM


All times are GMT -5. The time now is 12:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration