-   Slackware (
-   -   can't replicate the slackware(14)-14.0 locally from certain mirrors (

nass 04-23-2013 09:45 AM

can't replicate the slackware(14)-14.0 locally from certain mirrors
Hello everyone,
I am using the command (and German mirror)
wget -r -np -nH --cut-dirs=4 -P slackware64-14.0/ -l 200 -R index.html*

but the same command run on different mirrors: #ITALY #GREECE

only downloads the robots.txt file and the index.html file (which it then deletes).

I firstly downloaded from the greek mirror which is closest to me and then tried the italian only only to face the same problem.
German one works OK though....

Any one else finds this behaviour? could it be something on my end?
I have already contacted the admin in the greek mirror, but after finding the same error in the Italian mirror it may not be a local fault.

ponce 04-23-2013 09:55 AM

maybe it's better for you to use rsync (with a mirror that supports it) or, better, alien bob's handy script (read it for instructions, still uses rsync).

nass 04-23-2013 10:00 AM

Hi ponce,
rsync is not enabled on the greek mirror.

The admin just replied and redirected to download from ftp://.
This works fine. It seems odd that the http:// does not though.

meh, I guess false alarm then.

ponce 04-23-2013 10:03 AM

you can use other mirrors that supports it, it's still the best way to replicate locally.

one that works is rsync:// (but there are many)

GazL 04-23-2013 10:09 AM

If you must use ftp you might find the mirror command of lftp to be a better choice than wgetting stuff, but I agree with ponce: rsync is the best option.

nass 04-24-2013 03:45 AM

Hi both,
truth is the download rates I get from the Greek mirror, I can not replicate from anywhere else.
otherwise, I agree, rsync is the way forward.

All times are GMT -5. The time now is 01:57 AM.