LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-17-2007, 06:06 PM   #1
rcellis
LQ Newbie
 
Registered: Jan 2007
Location: Central Kansas
Distribution: slackware
Posts: 9

Rep: Reputation: 0
Angry Can't mount usb drive under slackware 11


I've beat my head against this problem off and on for months - at this point I have everything but my usb printer unplugged from my machine and still no joy.

I try

mount /dev/sda /mnt/usbdrive -t vfat

and I get:

mount: wrong fs type, bad option, bad superblock on /dev/sda,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

I try

mount /dev/sda1 /mnt/usbdrive -t vfat

and get told that it's not a valid block device

I've tried every combination from sda1 through sdh9 - same story.

looking at /var/log/messages tells me that there is a usb drive there, but nowhere can I find a reference which tells me what the various numbers mean.

Running dmesg is similiarly cryptic.

Why is it that the internet is awash with people who are able to mount thumb drives all day long without problem, and my system refuses to do so.

This is mostly a vent, but I *REALLY* need a few pointers here. ARGH!!!!
 
Old 05-17-2007, 06:23 PM   #2
mokele
Member
 
Registered: Jan 2005
Location: Puerto Rico
Distribution: Slackware 13
Posts: 146

Rep: Reputation: 15
This is what I do:

Run command:
1) # tail -f /var/log/messages

2) Plug device and wait for output

Here is an example of output:
Code:
May 17 19:15:26 guayacan kernel: usb 1-6: new high speed USB device using ehci_hcd and address 2
May 17 19:15:26 guayacan kernel: usb 1-6: configuration #1 chosen from 1 choice
May 17 19:15:26 guayacan kernel: scsi4 : SCSI emulation for USB Mass Storage devices
May 17 19:15:26 guayacan kernel: usbcore: registered new interface driver ub
May 17 19:15:31 guayacan kernel: scsi 4:0:0:0: Direct-Access     TOSHIBA  TransMemory      5.00 PQ: 0 ANSI: 0 CCS
May 17 19:15:31 guayacan kernel: SCSI device sda: 2013184 512-byte hdwr sectors (1031 MB)
May 17 19:15:31 guayacan kernel: sda: Write Protect is off
May 17 19:15:31 guayacan kernel: SCSI device sda: 2013184 512-byte hdwr sectors (1031 MB)
May 17 19:15:31 guayacan kernel: sda: Write Protect is off 
May 17 19:15:31 guayacan kernel:  sda: sda1 
May 17 19:15:31 guayacan kernel: sd 4:0:0:0: Attached scsi removable disk sda
May 17 19:15:31 guayacan kernel: sd 4:0:0:0: Attached scsi generic sg0 type 0
My pendrive is `sda1'. So I mount it like this:

3) # mount /dev/sda1 /mnt/usb

Then go browse it.

Note that you need SCSI Disk support enabled in the kernel
and USB Support as well.

Good Luck

-W
 
Old 05-17-2007, 06:29 PM   #3
rcellis
LQ Newbie
 
Registered: Jan 2007
Location: Central Kansas
Distribution: slackware
Posts: 9

Original Poster
Rep: Reputation: 0
I must be missing a module or something. This is what I get when I follow your suggestion:

...
May 17 18:21:28 localhost kernel: hub.c: new USB device 00:1d.2-1, assigned address 26
May 17 18:21:42 localhost kernel: usb.c: USB disconnect on device 00:1d.2-1 address 26
May 17 18:21:56 localhost kernel: usb.c: USB disconnect on device 00:1d.1-1 address 22
May 17 18:22:28 localhost kernel: hub.c: new USB device 00:1d.1-1, assigned address 29
May 17 18:22:45 localhost kernel: usb.c: USB disconnect on device 00:1d.1-1 address 29

What modules might I need? Here's my lsmod output:

Module Size Used by Tainted: P
aes 31712 0 (unused)
nvidia 6429056 11
visor 11304 0
usbserial 19900 0 [visor]
snd-seq-oss 23104 0
snd-seq-midi-event 3208 0 [snd-seq-oss]
snd-seq 33552 2 [snd-seq-oss snd-seq-midi-event]
snd-seq-device 3716 0 [snd-seq-oss snd-seq]
snd-pcm-oss 28928 0
snd-mixer-oss 11928 0 [snd-pcm-oss]
usb-storage 63520 4
printer 7520 0
uhci 23804 0 (unused)
usbcore 56812 1 [visor usbserial usb-storage printer uhci]
snd-intel8x0 19188 1
snd-ac97-codec 68160 0 [snd-intel8x0]
snd-pcm 52804 0 [snd-pcm-oss snd-intel8x0 snd-ac97-codec]
snd-timer 13168 0 [snd-seq snd-pcm]
snd 34304 1 [snd-seq-oss snd-seq-midi-event snd-seq snd-seq-device snd-pcm-oss snd-mixer-oss snd-intel8x0 snd-ac97-codec snd-pcm snd-timer]
soundcore 3300 6 [snd]
snd-page-alloc 4980 0 [snd-seq-oss snd-seq snd-seq-device snd-mixer-oss snd-intel8x0 snd-pcm snd-timer snd]
i2c-core 12260 0 (autoclean) [nvidia]
ohci1394 23568 0 (unused)
ieee1394 41156 0 [ohci1394]
8139too 13672 1
mii 2304 0 [8139too]
crc32 2880 0 [8139too]
pcmcia_core 39492 0
ide-scsi 9392 0
agpgart 45092 3

Thanks, btw. Talking to myself hasn't been very productive...
 
Old 05-17-2007, 06:44 PM   #4
mokele
Member
 
Registered: Jan 2005
Location: Puerto Rico
Distribution: Slackware 13
Posts: 146

Rep: Reputation: 15
Have you ever compiled/re-compiled your kernel?

I suspect you don't have the necessary SCSI Support options
enabled in the kernel. I think they are `SCSI Disk Support'
and `SCSI Generic'

I don't have my kernel source copied on the HDD, so I can't
tell you specifically which options are, but a simple
Google search gave me this

-W
 
Old 05-17-2007, 07:40 PM   #5
Nem
Member
 
Registered: Mar 2007
Location: United States
Distribution: Slackware 11.0
Posts: 88

Rep: Reputation: 15
Okey rcellis,
The first thing you need to do is
open your konsole, get root permissions
by running
Code:
su
and put in your
root password. Then run this command
Code:
mcedit /etc/fstab
.Then you need to add this line
Code:
/dev/sda1        /mnt/memory      auto        users,rw         0   0
and save it.

For example here's my /etc/fstab file.
Code:
/dev/hda2        swap             swap        defaults         0   0
/dev/hda3        /                reiserfs    defaults         1   1
/dev/hda4        /home            reiserfs    defaults         1   2
/dev/hda1        /mnt/windows     ntfs        ro               1   0
/dev/sda1        /mnt/memory      auto        users,rw         0   0
/dev/cdrom       /mnt/cdrom       auto        noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
tmpfs            /dev/shm         tmpfs       defaults         0   0

Go to /mnt and look if you see a folder named memory or
usb.If your usb mount point is called differently like
let's say usb or whatever then go back to /etc/fstab
and replace /mnt/memory with /mnt/whatever your mount point is called.


Okey from here to mount your usb stick you can use
kdiskfree in kde to mount the stick, or just run cmd
Code:
mount /mnt/memory or /mnt/whatever your mount point is called
Then after you're done using the usb stick run cmd
Code:
umount /mnt/memory or /mnt/whatever your mount point is called
Good Luck and post back on how it went.
 
Old 05-17-2007, 07:57 PM   #6
rcellis
LQ Newbie
 
Registered: Jan 2007
Location: Central Kansas
Distribution: slackware
Posts: 9

Original Poster
Rep: Reputation: 0
I did a very minimalist rebuild of the kernel, primarily optimizing for my 686 processor.

My current fstab looks like this:

/dev/hda3 swap swap defaults 0 0
/dev/hda1 / reiserfs defaults 1 1
/dev/sda1 /mnt/sd auto defaults 1 0
/dev/sdb4 /zip vfat defaults 1 0
/dev/sdc1 /backupdrive ext2 defaults 1 0
/dev/sdd1 /mnt/compactflash auto defaults 1 0
/dev/sdg1 /mnt/player auto defaults 1 0
/dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

I had forgotten that I had associated the sda1 device with /mnt/sd - I created a new mount point called usbdrive, but that's the only difference.

I think I'll try a kernel rebuild.
 
Old 05-17-2007, 08:06 PM   #7
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
This is why many "regulars" will tell you to try the stock kernels. Generally speaking, most problems like this seem to be caused by bad kernel configs.
To go a bit further, the OpenBSD people will almost without exception refuse to even *attempt* to help you if you're running a custom kernel (unless there is some valid reason for it, you explain the reason, and you tell exactly what's different in the config file).
 
Old 05-17-2007, 08:16 PM   #8
rcellis
LQ Newbie
 
Registered: Jan 2007
Location: Central Kansas
Distribution: slackware
Posts: 9

Original Poster
Rep: Reputation: 0
Hum. I just checked. No rebuild on the 11.0 release. It's bone stock.
 
Old 05-17-2007, 08:47 PM   #9
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
Quote:
Originally Posted by rcellis
Hum. I just checked. No rebuild on the 11.0 release. It's bone stock.
Hmm, okay... That being the case, try one of the stock 2.6.17.13 kernels in /extra. I've seen reports on IRC that some usb drives won't work in 2.4.x kernels, but I can't confirm that for sure.
 
Old 05-17-2007, 09:05 PM   #10
rcellis
LQ Newbie
 
Registered: Jan 2007
Location: Central Kansas
Distribution: slackware
Posts: 9

Original Poster
Rep: Reputation: 0
Well, thanks for all the help - I mean that. If nothing else it calmed me down enough to try a few other things.

One of them was to leave the thumb drive in the usb port during a reboot - the system didn't like the auto file-type, and tried every other file system type until *something* was satisfied. Once I logged back in, the device wasn't mounted, but I was able to mount it as /dev/sda1 (letting fstab determine the mount point).

So. Not sure what that means in practical terms. Hate to think I have to reboot my system just to examine a usb thumb drive (oh, and apparently have nearly every other usb device unplugged - like my usb 4-way hub, a usb external hard drive I use for backups, my Treo palm phone and a usb zip drive).
 
Old 05-18-2007, 07:14 AM   #11
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
Ok. Firstly you do not have ehci_hcd (or ehci) module loaded, which should be loaded if you have usb 2.0 support. And what is this usbserial for (have never used myself)?
 
Old 05-18-2007, 09:42 AM   #12
rcellis
LQ Newbie
 
Registered: Jan 2007
Location: Central Kansas
Distribution: slackware
Posts: 9

Original Poster
Rep: Reputation: 0
modprobe can't find ehci_hd nor ehci. The usbserial is used in syncing PDAs such as my Palm Treo. I suppose it could be interfering with the usb storage device recognition.

I am strongly leaning toward installing a 2.6 kernel. If you don't hear back from me, it'll be because I can no longer boot my system.
 
Old 05-18-2007, 09:47 AM   #13
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
Not ehci_hd, but ehci or ehci_hcd (it should be loaded to work with usb 2.0) Check you have compiled it into the kernel or build as module. Installing Slackware 2.6 kernel most probably won't do any harm.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting Slackware 11 Dist. to Recognize / Mount ScanDisk USB Pen Drive p2pfire Linux - General 1 12-23-2006 11:05 PM
How to mount a usb flash drive on Slackware Slackware user Linux - Software 3 03-02-2006 07:59 AM
when i mount my USB Flash Drive A Messenge has come that mount: can't find /dev/sda/h feda82 Red Hat 1 12-24-2005 04:25 AM
when i mount my USB Flash Drive A Messenge has come that mount: can't find /dev/sda/h feda82 Red Hat 2 12-24-2005 02:15 AM
mount usb module then mount usb hard drive guanyu Linux - Hardware 1 10-08-2003 11:50 AM


All times are GMT -5. The time now is 01:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration