LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-22-2008, 10:02 PM   #1
cdale77
Member
 
Registered: Oct 2006
Location: Berekeley
Distribution: Slackware 11; 2.6.21.1
Posts: 48

Rep: Reputation: 15
Can't mount USB devices


I'm having some problems mounting USB devices. I have successfully mounted several USB devices on this box with Ubuntu, but I can't get anything to work with Slackware. I've spent hours trying to figure out what to do, but I simply do not know where to start. My system set up is below; I do not modify the installed mount points or HAL system in any way. My fstab is out-of-the-box except that I uncommented the cdrom line. My USB keyboard/mouse work great, and when I plug devices into the USB port they get power, but the system does not recognize or attempt to mount. I have added myself to plugdev and cdrom groups, and mounting cd/dvd roms works fine. Thanks in advance!

Slamd64 12.0
Kernel 2.6.23.14 (problem also occurs with the huge kernel)
AMD 64 X2
2GB RAM
 
Old 01-22-2008, 10:24 PM   #2
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,264

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Slam64 != Slackware, and I have no specific advice for you, but I know you don't need to uncomment the cdrom drive in /etc/fstab -- by doing this you're bypassing HAL when mounting cds and dvds, which is not necessary. What window manager are you using? Only certain window/desktop managers take advantage of HAL to perform automounting. KDE does this in a default Slackware setup (again, Slamd64 != Slackware, but I'm assuming this is set up identically). I believe Gnome (and XFCE?) will also do this properly (although since Gnome is not included in Slackware, it would depend on the Gnome package you are using). Fluxbox/Icewm/etc. do not automount using HAL -- if you would like automounting in these window managers (or using the console), you should look up ivman/pmount (search for those and HAL in this forum and maybe at the Slamd64 forums for help). You should also read through the long long HAL stickied thread at the top of these forums if you haven't done so already.

HAL is just a hardware abstraction layer -- it allows the system to control the hardware without directly interfacing with it (I think). It has nothing to do with automounting -- this is done through window managers or other external programs.
 
Old 01-22-2008, 11:40 PM   #3
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
The one million dollar question, can you mount it "manually" by using the mount command?
To do this, see which device file it's being assigned to using dmesg, and then mount it as root: mount /dev/sdXX /mnt/somewhere
If that works, then it's just some "problem" related to HAL/D-Bus and maybe your window manager.
I myself just use pmount as T3slider suggested, actually used ivman too, but It was just too automated for me. I made SlackBuild scripts for those programs and you can get them from http://www.slackbuilds.org , but I warn you, they're tested on Slackware 12, not Slamd 64.
 
Old 01-23-2008, 12:22 AM   #4
cdale77
Member
 
Registered: Oct 2006
Location: Berekeley
Distribution: Slackware 11; 2.6.21.1
Posts: 48

Original Poster
Rep: Reputation: 15
This is dmesg after plugging in my usb stick:

Quote:
Initializing USB Mass Storage driver...
scsi6 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 3
usb-storage: waiting for device to settle before scanning
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
I can't figure out what device node it's being assigned to.

I'm using KDE, and for some reason with this machine (but not my laptop) I have to uncomment the cdrom line in fstab to be able to mount anything in my cd/dvd drive.

Last edited by cdale77; 01-23-2008 at 12:23 AM.
 
Old 01-23-2008, 01:50 AM   #5
duryodhan
Senior Member
 
Registered: Oct 2006
Distribution: Slackware 12 Kernel 2.6.24 - probably upgraded by now
Posts: 1,054

Rep: Reputation: 46
wait for some more time ... something else has to come up ..
 
Old 01-23-2008, 07:31 AM   #6
mcnalu
Member
 
Registered: Dec 2006
Location: Glasgow, UK
Distribution: Slackware 13.37 and 13.1
Posts: 393

Rep: Reputation: 63
Apologies if I'm way of the mark here...

I had a similar problem on my setup (Slack 11 with my own
2.6.17.13 kernel). Like the above dmesg, mine didn't mention the crucial bit with /dev/sd*

I *think* the problem is that I turned off all "scsi" options when compiling my kernel
and so I'm missing a scsi module. Haven't had the time to investigate furhter. Will post back when
I do.
 
Old 01-23-2008, 01:27 PM   #7
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Usually if it recognizes a partition on there, running 'blkid' will show the USB stick with the standard 'vfat' filesystem.
 
Old 01-23-2008, 01:37 PM   #8
shadowsnipes
Senior Member
 
Registered: Sep 2005
Distribution: Slackware
Posts: 1,441

Rep: Reputation: 70
Quote:
Originally Posted by cdale77 View Post
This is dmesg after plugging in my usb stick:



I can't figure out what device node it's being assigned to.

I'm using KDE, and for some reason with this machine (but not my laptop) I have to uncomment the cdrom line in fstab to be able to mount anything in my cd/dvd drive.
More than likely the device is at /dev/sda1 unless something else is taking that place (I've seen SATA hard drives under /dev/sd*). Try mounting that, unless there's something under fstab that already uses sda1.

The easiest way to mount in KDE is to open up Konqueror or Dolphin and go to the Storage Media Section. Simply open the one that corresponds to your flash drive. You can umount it by right clicking on it and selecting the corresponding option. This is coming from a Slackware perspective mind you. I've never used Slamd64.
 
Old 01-23-2008, 02:12 PM   #9
cdale77
Member
 
Registered: Oct 2006
Location: Berekeley
Distribution: Slackware 11; 2.6.21.1
Posts: 48

Original Poster
Rep: Reputation: 15
Thanks for all the suggestions. blkid shows the stick mounted at /dev/sdb1 (my SATA drive is at /dev/sda)

Quote:
/dev/sdb1: SEC_TYPE="msdos" LABEL="USB DISK" UUID="FE1E-2BE0" TYPE="vfat"
So now I know where it is, but I'm not sure what to do next, as I don't see any automount window in KDE, nor do I see anything in the Storage Media window. I also looked in /media and /mnt and don't see anything that looks like a USB stick. Here's mtab with the usb stick plugged in:

Quote:
/dev/sda1 / ext3 rw,noatime 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
usbfs /proc/bus/usb usbfs rw 0 0
/dev/sda2 /practice ext3 rw,noatime 0 0
/dev/sda4 /home ext3 rw,noatime 0 0

It looks like it's mounted in /proc/bus/usb? Is that right? Should I create a mount point and add a line to /etc/fstab? I'm still fairly new to linux. . .

Last edited by cdale77; 01-23-2008 at 02:15 PM.
 
Old 01-23-2008, 04:28 PM   #10
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,264

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
I think /proc/bus/usb just corresponds to the actual USB hardware and not your USB device (I see that line too without anything plugged in). Nothing will ever be MOUNTED in /proc as far as I know -- it's a dynamic view of the hardware in your system (and not their mount points).

What kernel are you using? Did you compile your own, are you using the generic-smp, generic, huge-smp or huge kernel, etc.

Try creating a directory (/mnt/myusbthing for example) and type the following command (after plugging in your USB stick, and assuming it still comes up as /dev/sdb1):
Code:
mount /dev/sdb1 /mnt/myusbthing
If that doesn't work you may need to specify certain mount options. If that still doesn't work, there is most likely something wrong with your setup. If it DOES work, however, it's probably a configuration thing or something to do with your kernel, HAL, or something else (I'm no expert).
 
Old 01-23-2008, 06:29 PM   #11
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
The thing here, is that he's not using Slackware but Slamd 64, maybe things were compiled slightly differently on it (a little research would show that).
Usually automounting is a matter of HAL/D-Bus configuration and that your window manager supports it, as it was stated in another post, there's a sticky thread on this forum about that.
It also may relate, as I stated above, that the support for automounting (HAL/D-Bus) wasn't set on when compiling KDE or the other way round, KDE with support but no HAL/D-Bus on your system.
Your system is seeing the USB device as blkid showed you, altought, I find it weird that it didn't show up on dmesg.
If you can actually mount it as T3slider suggested then, I'd suggest you to try asking about this on Slamd or KDE forums.
 
Old 01-23-2008, 07:04 PM   #12
cdale77
Member
 
Registered: Oct 2006
Location: Berekeley
Distribution: Slackware 11; 2.6.21.1
Posts: 48

Original Poster
Rep: Reputation: 15
Thanks for all the help here. I'll try these tips and repost at the Slamd64 forum if I can't figure it out.

Thanks again!

EDIT-I am able to manually mount. I believe I have an issue with HAL and will check out the appropriate forums.

Last edited by cdale77; 01-24-2008 at 12:11 AM.
 
Old 01-24-2008, 12:52 PM   #13
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
If it's a HAL issue, you'll probably just need to add yourself to the appropriate groups like it says in the HAL sticky:
http://www.linuxquestions.org/questi...d-this-566862/
 
Old 01-26-2008, 12:28 PM   #14
cdale77
Member
 
Registered: Oct 2006
Location: Berekeley
Distribution: Slackware 11; 2.6.21.1
Posts: 48

Original Poster
Rep: Reputation: 15
Thanks for all the help. I am in the correct groups, and that is why this is so confusing. When I upgrade to Slack 12.0 I was using an Intel machine, and after reading these stickies and the changes and hints file, everything worked great. Now I'm on an AMD64 machine, and though I follow the exact same procedures that resulted in HAL working with Slack, it does not seem to be working with Slamd64 (although everything works in Ubuntu, so I don't think it's a hardware problem).
 
Old 01-26-2008, 03:18 PM   #15
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,264

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Did you try posting in their forums? Things may be compiled differently. Confusions like this are why I'm still using official Slackware 12.0 instead of Slamd64 (or other 64-bit ports) on my AMD64 machine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to mount multiple usb devices Azalar Linux - Hardware 6 03-14-2007 04:54 AM
Mount USB Devices in DSL buckdog Linux - Software 4 12-23-2006 02:14 PM
Can't mount my usb devices captain chaos Slackware 18 04-23-2006 08:35 AM
Problem mount USB devices. jonostew Linux - Hardware 4 08-20-2004 12:39 PM
How do you mount usb devices on RH9 barrys Red Hat 2 10-19-2003 07:27 AM


All times are GMT -5. The time now is 02:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration