LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-02-2003, 06:11 AM   #1
orjanp
LQ Newbie
 
Registered: Oct 2003
Location: Tromsoe, Norway
Distribution: Slackware 9.1
Posts: 16

Rep: Reputation: 0
Can't get my AltGr key to work with Norwegian keyboard layout


Does anyone have a clue on what the problem can be? Everything else works fine, just my AltGr button that does't work.

Is there a keymap switcher like it is in windows(alt + shift)?
Running Slackware 9.1 on a IbmThinkpad T30.

Last edited by orjanp; 11-02-2003 at 06:15 AM.
 
Old 11-02-2003, 06:25 AM   #2
Garfi
LQ Newbie
 
Registered: Mar 2003
Location: Denmark
Distribution: Slackware 8.1
Posts: 16

Rep: Reputation: 0
Is it working outside X? If yes, then please provide the setup of your keyboard from XF86Config.
 
Old 11-02-2003, 06:43 AM   #3
orjanp
LQ Newbie
 
Registered: Oct 2003
Location: Tromsoe, Norway
Distribution: Slackware 9.1
Posts: 16

Original Poster
Rep: Reputation: 0
My default layout is english, so outside X i don't use norwegian layout. How can I switch layout outside X to check if it works there?
 
Old 11-02-2003, 07:09 AM   #4
orjanp
LQ Newbie
 
Registered: Oct 2003
Location: Tromsoe, Norway
Distribution: Slackware 9.1
Posts: 16

Original Poster
Rep: Reputation: 0
Anyway the only thing I have in XF86Config is

Identifier "Keyboard1"
Driver "Keyboard"

Update:
It works fine in Opera 7.21. There I'm able to use the altgr key. It also works in C++BuilderX.
Not in shell, kate, kwrite. There is the altgr key dead.

Last edited by orjanp; 11-02-2003 at 07:17 AM.
 
Old 11-02-2003, 07:27 AM   #5
Garfi
LQ Newbie
 
Registered: Mar 2003
Location: Denmark
Distribution: Slackware 8.1
Posts: 16

Rep: Reputation: 0
You change the language in /etc/rc.d/rc.keymap
There should be something like:
if [ -x /usr/bin/loadkeys ]; then
/usr/bin/loadkeys xxxx.map
fi
Now I have no idea which one you should use for an Norwedian keyboard. My own is dk-latin1.map for danish

Concerning X, you should try running xf86config and choose the right keyboard layout , and choose the rigth country. I just tried running it you should choose 53 for norwegian.
At the variant option just press enter for default and enter on the XKB option as well.

After running xf86config your XF86Config file should contain something like this (With another language ofcourse )

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "AutoRepeat" "500 30"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105" //might be different
Option "XkbLayout" "dk" //Should be 'no' I think.
EndSection

Last edited by Garfi; 11-02-2003 at 07:30 AM.
 
Old 11-02-2003, 07:43 AM   #6
orjanp
LQ Newbie
 
Registered: Oct 2003
Location: Tromsoe, Norway
Distribution: Slackware 9.1
Posts: 16

Original Poster
Rep: Reputation: 0
There is no rc.keymap.
 
Old 11-02-2003, 07:49 AM   #7
Garfi
LQ Newbie
 
Registered: Mar 2003
Location: Denmark
Distribution: Slackware 8.1
Posts: 16

Rep: Reputation: 0
Well then make one =)

Here is one:
1 #!/bin/sh
2 # Load the keyboard map. More maps are in /usr/share/kbd/keymaps.
3 if [ -x /usr/bin/loadkeys ]; then
4 /usr/bin/loadkeys dk-latin1.map
5 fi

The rc.M should check if there is one in the rc.d library, and loads it if it exists. Just make sure it is executable.
 
Old 11-02-2003, 08:36 AM   #8
orjanp
LQ Newbie
 
Registered: Oct 2003
Location: Tromsoe, Norway
Distribution: Slackware 9.1
Posts: 16

Original Poster
Rep: Reputation: 0
The altgr works utside X. rc.keymap loads no-latin1.map. But in x altgr is still dead.
My XF86Config is now the same as the example you gave, with no instead of dk.

#showkey gives me keycode 100 for altgr, so it's not totally dead.
 
Old 11-02-2003, 08:53 AM   #9
orjanp
LQ Newbie
 
Registered: Oct 2003
Location: Tromsoe, Norway
Distribution: Slackware 9.1
Posts: 16

Original Poster
Rep: Reputation: 0
Well, if I use a different layout than us english as default, it some how works fine. So what i had to do is to use norwegian as default language and us english as secondary. So it is kind of a solution then. I'll buy that.


Does anyone knows why?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
keyboard layout (alternative key with mode_switch) super-momo Debian 2 02-12-2005 11:22 PM
Keyboard layout & win key in Core2 Travis S Fedora 11 10-06-2004 10:22 PM
AltGr key does not work OlegL Debian 5 09-17-2004 02:22 AM
AltGr key does not work OlegL Linux - Laptop and Netbook 2 08-30-2004 09:35 AM
Can't use the alt key on SUSE (personal) with a French Keyboard layout Red Alastor Linux - Newbie 2 05-22-2004 02:25 PM


All times are GMT -5. The time now is 12:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration