LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-17-2007, 03:02 PM   #1
V.K.
LQ Newbie
 
Registered: Nov 2007
Location: Belgrade, Serbia
Distribution: Slackware 12
Posts: 5

Rep: Reputation: 0
Can't get monitor refresh rate more than 60 Hz


Monitor Samsung 793df, nvidia gforce, slackware 12.
Should be 85,1024x768, but dunno how to make it.
Thx in advance!

xorg.conf:

Section "Monitor"

# HorizSync is in kHz unless units are specified.
# HorizSync may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY. REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.
# HorizSync 30-64 # multisync
# HorizSync 31.5, 35.2 # multiple fixed sync frequencies
# HorizSync 15-25, 30-50 # multiple ranges of sync frequencies
# VertRefresh is in Hz unless units are specified.
# VertRefresh may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY. REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.
Identifier "My Monitor"
HorizSync 30-100
VertRefresh 50-160
Option "DPMS"
Modeline "1024x768_85.00" 94.39 1024 1088 1200 1736 768 769 772 807 -HSync +Vsync
EndSection


Section "Device"

#VideoRam 4096
# Insert Clocks lines here if appropriate
Identifier "VESA Framebuffer"
Driver "nvidia"
EndSection

Section "Screen"

# If your card can handle it, a higher default color depth (like 24 or 32)
# is highly recommended.
# DefaultDepth 8
# DefaultDepth 16
# DefaultDepth 32
# "1024x768" is also a conservative usable default resolution. If you
# have a better monitor, feel free to try resolutions such as
# "1152x864", "1280x1024", "1600x1200", and "1800x1400" (or whatever your
# card/monitor can produce)
Identifier "Screen 1"
Device "VESA Framebuffer"
Monitor "My Monitor"
DefaultDepth 24
SubSection "Display"
Depth 8
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768_85" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Last edited by V.K.; 11-17-2007 at 03:05 PM.
 
Old 11-17-2007, 03:22 PM   #2
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 64
Quote:
Originally Posted by V.K. View Post
Monitor Samsung 793df, nvidia gforce, slackware 12.
Should be 85,1024x768, but dunno how to make it.
Thx in advance!

xorg.conf:

Section "Monitor"

# HorizSync is in kHz unless units are specified.
# HorizSync may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY. REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.
# HorizSync 30-64 # multisync
# HorizSync 31.5, 35.2 # multiple fixed sync frequencies
# HorizSync 15-25, 30-50 # multiple ranges of sync frequencies
# VertRefresh is in Hz unless units are specified.
# VertRefresh may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY. REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.
Identifier "My Monitor"
HorizSync 30-100
VertRefresh 50-160
Option "DPMS"
Modeline "1024x768_85.00" 94.39 1024 1088 1200 1736 768 769 772 807 -HSync +Vsync
EndSection


Section "Device"

#VideoRam 4096
# Insert Clocks lines here if appropriate
Identifier "VESA Framebuffer"
Driver "nvidia"
EndSection

Section "Screen"

# If your card can handle it, a higher default color depth (like 24 or 32)
# is highly recommended.
# DefaultDepth 8
# DefaultDepth 16
# DefaultDepth 32
# "1024x768" is also a conservative usable default resolution. If you
# have a better monitor, feel free to try resolutions such as
# "1152x864", "1280x1024", "1600x1200", and "1800x1400" (or whatever your
# card/monitor can produce)
Identifier "Screen 1"
Device "VESA Framebuffer"
Monitor "My Monitor"
DefaultDepth 24
SubSection "Display"
Depth 8
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768_85.00" "1280x1024" "1152x864" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

I believe it should be named exactly as you have it for the Modeline in the Modes section like I have changed it too above and it would need to be at the start of the line for it to be used as the default. But I doubt it may be needed just try the "1024x768" at the start of the Modes line X will usually pick the highest refresh rate for the resolution you have set for the default.
 
Old 11-17-2007, 04:00 PM   #3
V.K.
LQ Newbie
 
Registered: Nov 2007
Location: Belgrade, Serbia
Distribution: Slackware 12
Posts: 5

Original Poster
Rep: Reputation: 0
Tried with/without Modeline, tried to put 1024X768 at the start of the Modes line....nothing!

Quote:
Originally Posted by HappyTux View Post
I believe it should be named exactly as you have it for the Modeline in the Modes section like I have changed it too above and it would need to be at the start of the line for it to be used as the default. But I doubt it may be needed just try the "1024x768" at the start of the Modes line X will usually pick the highest refresh rate for the resolution you have set for the default.
 
Old 11-17-2007, 04:39 PM   #4
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 64
Quote:
Originally Posted by V.K. View Post
Tried with/without Modeline, tried to put 1024X768 at the start of the Modes line....nothing!

Nothing as in doesn't start doesn't give you the proper refresh rate/resolution .... details are important it is impossible to help guessing what you mean. Lets try this differently then what makes you believe that you are not running at 85hz when using the 1024x768 have you checked in the /var/log/Xorg.0.log to see what is selected when set to 1024x768? If you are relying on a GUI to see the correct refresh rate like in KDE then there is a good chance this is wrong as it is with my monitors. As well you can check using the menu button on most monitors it will tell you the refresh rate in there.
 
Old 11-17-2007, 05:17 PM   #5
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
What I would do is run 'xorgsetup' then change the "Driver" back to "nvidia", remove the "BusID" line, and finally add 'Modes "1024x768"' to the "Screen" section under "Depth 24". Something like:

Code:
Section "Device"
    Identifier     "Card0"
    Driver         "nvidia"
    VendorName     "nVidia Corporation"
    BoardName      "NV17 [GeForce4 420 Go]"
    Option         "nologo" "1"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Viewport    0 0
        Depth       1
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       4
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       8
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       15
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       16
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       24
        Modes      "1024x768"
    EndSubSection
 
Old 11-17-2007, 05:53 PM   #6
V.K.
LQ Newbie
 
Registered: Nov 2007
Location: Belgrade, Serbia
Distribution: Slackware 12
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by H_TeXMeX_H View Post
What I would do is run 'xorgsetup' then change the "Driver" back to "nvidia", remove the "BusID" line, and finally add 'Modes "1024x768"' to the "Screen" section under "Depth 24". Something like:

Code:
Section "Device"
    Identifier     "Card0"
    Driver         "nvidia"
    VendorName     "nVidia Corporation"
    BoardName      "NV17 [GeForce4 420 Go]"
    Option         "nologo" "1"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Viewport    0 0
        Depth       1
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       4
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       8
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       15
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       16
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       24
        Modes      "1024x768"
    EndSubSection
First I would like to thank you for helping me this way.

Here is what happend:

I have taken your advice and go with "xorgsetup" and added the line that you proposed. Restarted X again and everything was the same, even worse (50Hz), I checked the monitor menu and it was 50 also.
Then I get back to xorg.conf, added the Modeline "1024x756_85" and HorizSync/VertRefresh and edited the Modes (add _85 at the end) and IT WORKED!!!!
GUI still say that it is 50 (dunno why) but monitor (and my eyes) say its 85!
I've been solving this problem too all day and I'm sick of it (monitor fickering, not slack of course).

Thank you again, you'll have a beer if coming to Serbia!

Last edited by V.K.; 11-17-2007 at 07:00 PM.
 
Old 11-17-2007, 11:23 PM   #7
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,223

Rep: Reputation: 187Reputation: 187
The reason why KDE/Gnome will say that it is 50hz has to do with twin view. Check out this post @ nvnews, I did what it said and it fixed my problem with KDE reporting wrong frequencies http://www.nvnews.net/vbulletin/show...52#post1421852

Last edited by Daedra; 11-17-2007 at 11:25 PM.
 
Old 11-18-2007, 05:38 AM   #8
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
well, good thing it worked.
 
Old 11-20-2007, 09:56 AM   #9
V.K.
LQ Newbie
 
Registered: Nov 2007
Location: Belgrade, Serbia
Distribution: Slackware 12
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Daedra View Post
The reason why KDE/Gnome will say that it is 50hz has to do with twin view. Check out this post @ nvnews, I did what it said and it fixed my problem with KDE reporting wrong frequencies http://www.nvnews.net/vbulletin/show...52#post1421852
BINGO! Thx!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Monitor Refresh Rate vraidroit Linux - Hardware 15 08-15-2006 08:55 PM
Monitor Refresh Rate redmoon Ubuntu 4 06-19-2005 12:40 AM
Monitor Refresh Rate taichi Linux - Newbie 1 05-10-2005 03:54 PM
monitor refresh rate evrenulusoy Linux - Hardware 4 10-02-2004 12:41 PM
Monitor Refresh Rate Jehos Linux - Newbie 2 11-28-2003 11:51 AM


All times are GMT -5. The time now is 06:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration