LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-22-2009, 11:53 PM   #1
mothergoose729
Member
 
Registered: Aug 2008
Distribution: Ubuntu x64
Posts: 90

Rep: Reputation: 15
Can't get desktop effects to work outside of root user


I created a new user outside of root and am using it. I have the latest Nvidia drivers installed and working, only problem is I am not able to use fancy desktop effets, like shadowing and transparency. The options are simply not available under desktop settings, saying instead:

"Compositing is not supported on your system.
Required X extensions (XComposite and XDamage) are not available."

These are all enabled and working just fine under root. How do I enable this for all users?
 
Old 11-23-2009, 02:54 AM   #2
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Rep: Reputation: 129Reputation: 129
Can you post you xorg.conf?
 
Old 11-23-2009, 02:57 AM   #3
mothergoose729
Member
 
Registered: Aug 2008
Distribution: Ubuntu x64
Posts: 90

Original Poster
Rep: Reputation: 15
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder58)  Tue Oct 20 21:25:04 PDT 2009

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder58)  Tue Oct 20 21:26:01 PDT 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" Below "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "1"
EndSection

Section "Files"
    FontPath        "/usr/lib64/X11/fonts/misc/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/misc/"
    FontPath        "/usr/lib64/X11/fonts/Type1/"
    FontPath        "/usr/lib64/X11/fonts/Speedo/"
    FontPath        "/usr/lib64/X11/fonts/100dpi/"
    FontPath        "/usr/lib64/X11/fonts/75dpi/"
    FontPath        "/usr/lib64/X11/fonts/cyrillic/"
    FontPath        "/usr/lib64/X11/fonts/TTF/"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Arnos Instruments F-415"
    HorizSync       24.0 - 61.0
    VertRefresh     49.0 - 75.0
    Option         "DPMS"
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "Proview"
    HorizSync       0.0 - 0.0
    VertRefresh     0.0
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8800 GT"
    BusID          "PCI:5:0:0"
    Screen          0
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8800 GT"
    BusID          "PCI:5:0:0"
    Screen          1
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "CRT-0: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "CRT-1: 1280x1024 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
 
Old 11-23-2009, 03:20 AM   #4
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Rep: Reputation: 129Reputation: 129
Dunno if this will help but put this at the end:

Code:
Section "Extensions"
  Option "Composite" "Enable"
EndSection
 
Old 11-23-2009, 03:32 AM   #5
mothergoose729
Member
 
Registered: Aug 2008
Distribution: Ubuntu x64
Posts: 90

Original Poster
Rep: Reputation: 15
Nope . I have googled it a few times and I can't figure out what I need to do either.
 
Old 11-23-2009, 04:18 AM   #6
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Rep: Reputation: 129Reputation: 129
Did you add your newly created user to the extra groups? [users,video,audio,etc...]
 
Old 11-23-2009, 06:16 AM   #7
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
There is no way to get desktop effects working with that xorg.conf, either as root or any other user. Xinerama disables Composite. This is true for all video cards. If you had desktop effects working as root, then it was using a different xorg.conf file.

Since both monitors are attached to one video card, you should use twinview to combine them into one large screen, instead of xinerama.

Adam
 
Old 11-23-2009, 07:02 AM   #8
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,406

Rep: Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829
Just to add what adamk75 wrote, change this section of your xorg.conf
Code:
    Option         "Xinerama" "1"
EndSection
to
Code:
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection
Also, it would be worthwhile adding what ~sHyLoCk~ suggested.

I also have these lines in the "Screen" sections for each of my monitors with my nVidia 7300.
Code:
    Option         "DisableGLXRootClipping" "true"
    Option         "RenderAccel" "true"
    Option         "AllowGLXWithComposite" "true"
    Option         "AddARGBGLXVisuals" "true"
PS:- The "Files" section is probably redundant.
 
Old 11-23-2009, 09:04 AM   #9
BrZ
Member
 
Registered: Apr 2009
Distribution: Slackware
Posts: 492

Rep: Reputation: 80
Try adding:
Quote:
Section "Module"
# ...
Load "glx"
Load "dri"
# ...
EndSection
And:
Quote:
Section "DRI"
Mode 0666
EndSection
Or, to restrict to video group:
Quote:
Section "DRI"
Group "video"
Mode 0660
EndSection

Last edited by BrZ; 11-23-2009 at 09:07 AM.
 
Old 11-23-2009, 09:05 AM   #10
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Quote:
Originally Posted by BrZ View Post
Try adding:


Or, to restrict to video group:

That does not apply with the nvidia driver.

Adam
 
Old 11-23-2009, 09:17 AM   #11
BrZ
Member
 
Registered: Apr 2009
Distribution: Slackware
Posts: 492

Rep: Reputation: 80
Sorry pal...
 
Old 11-23-2009, 01:54 PM   #12
mothergoose729
Member
 
Registered: Aug 2008
Distribution: Ubuntu x64
Posts: 90

Original Poster
Rep: Reputation: 15
I have my monitors set up so that the 17 inch proview is on a KVM switch, and my F-415 is mounted on the wall above it. Separate desktops works better for me because they are not directly adjacent to one another. I don't think I am using a different Xorg.conf because it is located within a directory of my root. I only have one partition, all files are located in some directory of root.

When I boot up I am presented with an text login. If I choose root, then startx, I can get semi transparent backgrounds on my widgets, as well as some eye candy effects like shadowing, and desktop switching (sliding, or whatever).

I do however get the same message on top regardless of the user, as far as Xcomp not supported or whatever.. The difference is the options below are not greyed out under root. Under a regular user the options are shown as "checked" but I don't see them in effect, and they are all grey and cannot be changed. I assume I can only change them under root, I don't know why my desktop looks different though with the two user groups.

Last edited by mothergoose729; 11-23-2009 at 01:56 PM.
 
Old 11-23-2009, 01:59 PM   #13
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Based on that xorg.conf file, you are not using separate desktops. You have xinerama enabled, which combines separate screens into one screen.

Please pastebin your /var/log/Xorg.0.log file that is generated when you run 'startx' as root and one that is generated when you run 'startx' as your normal user.

Adam
 
Old 11-23-2009, 02:21 PM   #14
mothergoose729
Member
 
Registered: Aug 2008
Distribution: Ubuntu x64
Posts: 90

Original Poster
Rep: Reputation: 15
I disabled Xinerma and reconfigured it as twin view and I can now get both two screen working and all visual effects. The way I had it before the monitors were positioned "on top" of eachother, and now they are not, but I am sure I can figure out how to get that going again. Even if not it is a minor annoyance, thank you all for your help .
 
Old 11-23-2009, 05:52 PM   #15
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,406

Rep: Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829
Quote:
I don't think I am using a different Xorg.conf because it is located within a directory of my root.
The default location of xorg.conf is in /etc/X11.
Quote:
but I am sure I can figure out how to get that going again
Run 'nvidiasettings'.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dell Inspiron 1525 (Cant get desktop effects to work!?!?!?!) cornelp Linux - Newbie 3 07-30-2008 12:34 AM
screen reso for gutsy's desktop effects to work gonzolono Ubuntu 5 12-11-2007 03:31 PM
screen reso for gutsy's desktop effects to work gonzolono Linux - Newbie 0 12-03-2007 12:34 PM
Will Desktop Effects work with on a PIII 866, 32 Meg Nvidia card? toby50 Fedora - Installation 1 08-06-2007 12:59 PM
[FC6]Chipbench via Desktop Effects won't work gedanken Fedora 0 11-28-2006 10:17 AM


All times are GMT -5. The time now is 08:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration