LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 11-21-2011, 03:16 PM   #1
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,869

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
Can't get compiz to run on Slack 13.37 64 bit.


This is the last irritating problem I would like to resolve. However, I have been unsuccessful.

Some details.

Video card.
Quote:
VGA compatible controller: nVidia Corporation C61 [GeForce 6150SE nForce 430] (rev a2)
Video driver -
Quote:
275.28
This is the file I downloaded from Nvidia and installed.
Quote:
NVIDIA-Linux-x86_64-275.28.run
Video is normal, no known problems.

I installed compiz from Slackbuilds.org, 11 packages in the order specified. The only package I did not install was 'compiz-plugins-unsupported'. I used sbopkg to install the packages in the correct order.

CCSM comes up, I can view and modify the configuration. I changed the window decorator to 'emerald --replace'. If I run glxgears I get about 1680 FPS.

I also have Magia 1 installed, and compiz works fine on it.

If I start the fusion-icon, this is the output.

[QUOTE]fusion-icon
* Detected Session: kde
* Searching for installed applications...
* NVIDIA on Xorg detected, exporting: __GL_YIELD=NOTHING
* Using the GTK Interface
* KWin is already running
/usr/lib64/python2.6/site-packages/FusionIcon/interface_gtk/main.py:214: GtkWarning: GdkWindow 0x6c00003 unexpectedly destroyed
gtk.main()
The program 'fusion-icon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'RenderBadPicture (invalid Picture parameter)'.
(Details: serial 210 error_code 175 request_code 152 minor_code 7)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)/QUOTE]

I did some googling, and did not find a solution.

Kernel ;
Quote:
uname -a
Linux duelie 2.6.37.6=cliff1 #1 SMP Mon May 16 14:31:50 EDT 2011 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 5200+ AuthenticAMD GNU/Linux
I have multi-lib installed, it that could have anything to do with this problem.

Messages, each time I start fusion-icon I get this in messages:

Quote:
Nov 21 15:11:02 duelie kernel: [17151.119200] fusion-icon[20521]: segfault at 968 ip 00007f8700d380ea sp 00007ffff1370bc0 error 4 in libX$
I'm attaching Xorg.0.log. I have looked through it, and don't see anything that points me in the correct direction.

Suggestions?
Attached Files
File Type: log Xorg.0.log (14.3 KB, 5 views)
 
Old 11-21-2011, 03:33 PM   #2
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,226

Rep: Reputation: 187Reputation: 187
Quick question, are you running KDE? Nevermind I see your output.

try bypassing fusion-icon for now. Open up KDE>System Settings>Default Applications>Window Manager and change the default window manager to compiz and see if it starts.

Last edited by Daedra; 11-21-2011 at 03:34 PM.
 
Old 11-21-2011, 03:33 PM   #3
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
Let's see if the problem is just with fusion-icon or if it really is a bigger problem with compiz. First, what desktop environment or window manager are you using? If you are using either KDE or xfce (or even gnome), try running this from a terminal:

Code:
compiz --replace ccp &
If compiz fails to start, post the output here.

Adam
 
Old 11-21-2011, 04:08 PM   #4
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,869

Original Poster
Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
Daedra - I tried compiz wm, it gives strange results. When you start an app, the app shows a all white box, nothing is visible. I have set that back for kwin to start. FWIW, I use Xfce most of the time. The symptoms I described are the same in Xfce, as KDE. I did do a full install.

adamk75 -

Tried your suggestion. The window decorations disappear. The cube does not show up. This is the error I see in the konsole when I run the command.

Quote:
compiz --replace ccp &
[1] 22237
cliff@duelie:~$ compiz (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format

(emerald:22238): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT (object)' failed
compiz (cube) - Warn: Failed to load slide:
Thank-you both for your interest.
 
Old 11-21-2011, 04:14 PM   #5
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
That output is promising, actually. Start up ccsm and use it to enable the window decoration plugin, and put 'emerald' in the command field in that plugin. While in ccsm, you should also enable the other plugins you need/want: move, resize, put, place, desktop cube, rotate cube, etc.

Then try starting compiz again, the same way as before.
 
Old 11-21-2011, 04:20 PM   #6
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,869

Original Poster
Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
Switched desktops to Xfce. Clicked on the Fusion-icon, the System Tray abends. When I cleared the error message, the icon appears in the bar at the bottom. The window decorations are gone, and any open apps are all piled one on top of another.

I can switch WM's with the icon. When I select Xfwm4, the desktop works normally, no compiz.
 
Old 11-21-2011, 04:24 PM   #7
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
Again, enable those plugins... Unless you already have... In which case, run compiz from a terminal window and show us the output again.

Adam
 
Old 11-21-2011, 04:32 PM   #8
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,869

Original Poster
Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
I checked all the items Adam suggested, they are all enabled. I'm running Xfce right now.

The output...

Quote:
compiz --replace ccp &
[1] 22832
cliff@duelie:~$ compiz (core) - Warn: No GLXFBConfig for depth 32
compiz (core) - Warn: No GLXFBConfig for depth 32
compiz (core) - Warn: No GLXFBConfig for depth 32
All open apps are on one window, and I do not have window decorations.

Wobbely windows works when I move an app. Getting closer.

Last edited by camorri; 11-21-2011 at 04:33 PM.
 
Old 11-21-2011, 04:35 PM   #9
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
Try adding this to the Device section of your xorg.conf file:

Code:
Option "AddARGBGLXVisuals" "True"
I didn't think it was needed on recent nvidia drivers, but the latest error you are seeing was usually solved with that option or by setting the color depth to 24 (which you seem to be using already).

Out of curiosity, even without any window decoration, can you grab windows with alt+mouse1 and move them around?

Adam
 
Old 11-21-2011, 05:17 PM   #10
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,869

Original Poster
Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
Adam,

I had that line in xorg.conf. The only difference I could see, was, I had "true" instead of "True" ; the capitol T.

This is the device section, now.

Quote:
Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "AddARGBGLXVisuals" "True"
EndSection
I have tried ever combination of WM and window decorator. Nothing works as it should.

I can not get the cube rotate effect, however, I get wobbley windows. I can use Alt + button 1 to move windows. I can push an application almost off the visible screen. I used to do this before on Mandriva, and Magia, and the app pushes to the next desktop on the cube.

Any other things to try?
 
Old 11-21-2011, 05:20 PM   #11
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
Simply enabling the cube plugins may not be enough. Make sure both the ones I mentioned are enabled, then make sure that "Edge Flip Move" is enabled in the Rotate Cube plugin, too. You can always test the rotate cube plugin by using control+alt+right/left.

As for window decorations, try starting compiz like so:

Code:
compiz --replace --loose-binding ccp &
See if that makes a difference.

Adam
 
Old 11-21-2011, 07:26 PM   #12
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,226

Rep: Reputation: 187Reputation: 187
One thing I noticed is that you posted that your video driver is 275.28, but the newest driver for your card is 285.05.09. You can try downloading and installing the newest driver and see if that helps. Just make sure you when it prompts you to install the 32bit compatibility libraries you say yes since you are running multilib. http://www.nvidia.com/object/linux-d...09-driver.html
 
Old 11-21-2011, 07:32 PM   #13
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,869

Original Poster
Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
I will give that a try tomorrow. Interesting thing in Magia, I have a much older driver, and compiz works like a charm on it.

I'll post back...
 
Old 11-21-2011, 07:46 PM   #14
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,226

Rep: Reputation: 187Reputation: 187
Also when you installed the nvidia driver did you let the installer make your xorg.conf file for you?
 
Old 11-22-2011, 06:48 AM   #15
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,869

Original Poster
Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
Quote:
did you let the installer make your xorg.conf file for you?
Yes I did, is that the beat way to go?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CentOS 64 Bit Itanium - Need to run 32 bit application. HELP Squerl101 Linux - Server 2 11-02-2011 03:30 PM
run 32 bit software on 64 bit debian linux jokar.mohsen Linux - Software 4 07-07-2011 12:39 AM
LXer: How to Run 32-bit Apps in 64-bit Linux LXer Syndicated Linux News 0 08-11-2009 09:50 AM
how to run 32 bit apps on 64 bit red hat 5 unix1adm Red Hat 20 08-11-2009 01:22 AM
LXer: Check if Compiz will run well on your Linux Box with Compiz Check LXer Syndicated Linux News 0 05-05-2008 02:20 AM


All times are GMT -5. The time now is 03:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration