LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-23-2012, 03:53 PM   #16
J1NKL3
Member
 
Registered: Mar 2012
Distribution: Slackware64-current
Posts: 77

Original Poster
Rep: Reputation: Disabled

Quote:
Originally Posted by ReaperX7 View Post
Check your system and CMOS clocks and make sure they are set correctly.
CMOS was set in 2004 yikes... got b43-fwcutter installed and will give the firmware a shot when I get home from work tonight. Thanks so much!
 
Old 08-23-2012, 07:10 PM   #17
ahlr
LQ Newbie
 
Registered: Jun 2012
Posts: 12

Rep: Reputation: Disabled
Thumbs up

See this: http://wireless.kernel.org/en/users/...devicefirmware
Solved my problem!!!!
 
Old 08-23-2012, 10:51 PM   #18
allenlinux
LQ Newbie
 
Registered: Aug 2012
Posts: 14

Rep: Reputation: Disabled
Cross the hell with SLACKWARE.
enable WIRELESS CARD AND CONNECTION [SOLVED]
1.- log as root with this:

su -

2.- Your going to edit two files, then restart connection services.

nano /etc/rc.d/rc.inet1.conf

3.- Activate and uncomment the follow (just find the lines, forget it about the others, (NO NDISWRAPPER, DELETE IT AND FILL IT WITH wext)):

#DEFAULT GATEWAY IP ADDRESS

GATEWAY="192.168.0.1"

## Example config information for wlan0. Uncomment the lines you need and fill
## in your data. (You may not need all of these for your wireless network)

IFNAME="wlan0"
USE_DHCP[4]="yes"
WLAN_ESSID[4]="name of your router default wireless connection, or name of your wireless connection"
WLAN_WPA[4]="wpa_supplicant"
WLAN_WPADRIVER[4]="wext"

## Some examples of additional network parameters that you can use.
## Config information for wlan0:

IFNAME[4]="wlan0"
WLAN_ESSID[4]=name of your router default wireless connection, or name of your wireless connection

4.- save and exit
5.- at this point you set the service, now enable main source | EXAMPLE: "wpa_passphrase conection01 123$$marck" (no quotation)

wpa_passphrase wirelessname password

6.- copy the PSK=23432432o432432435465u6456656546k654 (copy your code not this, and NOT THE "PSK=")
7.- edit the supplicant and search for ssid and psk, if you see comment # just uncomment

nano /etc/wpa_supplicant.conf
SSID="your wireless name"
PSK=paste you PSK code

8.- save and exit
9.- hide key/password

chmod 640 /etc/wpa_supplicant.conf

10.- pre-activation (if you get error, just copy the example line at the end of error message and paste it, then enter)

wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf

11.- Wait to get "CTRL-EVENT-CONNECTED"
12.- open other root terminal

13.- ACTIVATE WIRELESS (thanks god...)

dhcpcd wlan0
dhclient wlan0

14.- YOU READY TO LIVE
15.- check and try to connect, open and web browser or something
16.- reboot your system or:

/etc/rc.d/rc.inet1.conf restart

|16| .- optional:

send a message to patrick volkerding saying that debian and debian distros are better and easier to configure.

allenlinux | grep head tail

Last edited by allenlinux; 08-23-2012 at 11:01 PM. Reason: mistakes deleted
 
1 members found this post helpful.
Old 08-24-2012, 05:19 AM   #19
J1NKL3
Member
 
Registered: Mar 2012
Distribution: Slackware64-current
Posts: 77

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by allenlinux View Post
Cross the hell with SLACKWARE.
enable WIRELESS CARD AND CONNECTION [SOLVED]
1.- log as root with this:

su -

2.- Your going to edit two files, then restart connection services.

nano /etc/rc.d/rc.inet1.conf

3.- Activate and uncomment the follow (just find the lines, forget it about the others, (NO NDISWRAPPER, DELETE IT AND FILL IT WITH wext)):

#DEFAULT GATEWAY IP ADDRESS

GATEWAY="192.168.0.1"

## Example config information for wlan0. Uncomment the lines you need and fill
## in your data. (You may not need all of these for your wireless network)

IFNAME="wlan0"
USE_DHCP[4]="yes"
WLAN_ESSID[4]="name of your router default wireless connection, or name of your wireless connection"
WLAN_WPA[4]="wpa_supplicant"
WLAN_WPADRIVER[4]="wext"

## Some examples of additional network parameters that you can use.
## Config information for wlan0:

IFNAME[4]="wlan0"
WLAN_ESSID[4]=name of your router default wireless connection, or name of your wireless connection

4.- save and exit
5.- at this point you set the service, now enable main source | EXAMPLE: "wpa_passphrase conection01 123$$marck" (no quotation)

wpa_passphrase wirelessname password

6.- copy the PSK=23432432o432432435465u6456656546k654 (copy your code not this, and NOT THE "PSK=")
7.- edit the supplicant and search for ssid and psk, if you see comment # just uncomment

nano /etc/wpa_supplicant.conf
SSID="your wireless name"
PSK=paste you PSK code

8.- save and exit
9.- hide key/password

chmod 640 /etc/wpa_supplicant.conf

10.- pre-activation (if you get error, just copy the example line at the end of error message and paste it, then enter)

wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf

11.- Wait to get "CTRL-EVENT-CONNECTED"
12.- open other root terminal

13.- ACTIVATE WIRELESS (thanks god...)

dhcpcd wlan0
dhclient wlan0

14.- YOU READY TO LIVE
15.- check and try to connect, open and web browser or something
16.- reboot your system or:

/etc/rc.d/rc.inet1.conf restart

|16| .- optional:

send a message to patrick volkerding saying that debian and debian distros are better and easier to configure.

allenlinux | grep head tail
Alight I got everything installed and got the internet working with this... how do I get it so I don't have to repeat steps 10 thru the end every time I reboot? Thanks for your VERY helpful post!
 
Old 08-24-2012, 07:43 AM   #20
J1NKL3
Member
 
Registered: Mar 2012
Distribution: Slackware64-current
Posts: 77

Original Poster
Rep: Reputation: Disabled
Also, wicd still doesn't show any connections, any help there?
 
Old 08-25-2012, 12:22 PM   #21
yuchankit
Member
 
Registered: Apr 2008
Distribution: Slackware 13.1 ,slackware-current
Posts: 143

Rep: Reputation: 22
Care to post output of iwconfig ?
 
Old 08-25-2012, 05:26 PM   #22
J1NKL3
Member
 
Registered: Mar 2012
Distribution: Slackware64-current
Posts: 77

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by yuchankit View Post
Care to post output of iwconfig ?
Code:
bash-4.1# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"qwest"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 20:76:00:13:74:C0   
          Bit Rate:1 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=68/70  Signal level=-42 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:3  Invalid misc:10   Missed beacon:0
 
Old 08-25-2012, 07:21 PM   #23
J1NKL3
Member
 
Registered: Mar 2012
Distribution: Slackware64-current
Posts: 77

Original Poster
Rep: Reputation: Disabled
Just need a way so that every time I start up I don't have to type:

wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf
dhcpcd
dhclient

Also, this method probably won't work if I try accessing a wireless other than my home
 
Old 08-25-2012, 11:11 PM   #24
yuchankit
Member
 
Registered: Apr 2008
Distribution: Slackware 13.1 ,slackware-current
Posts: 143

Rep: Reputation: 22
Have you tried fiddling with the wicd's preference section? Set the wireless interface to wlan0 and I think you should be good to go regardless of any other wireless router.
 
Old 08-26-2012, 12:10 AM   #25
J1NKL3
Member
 
Registered: Mar 2012
Distribution: Slackware64-current
Posts: 77

Original Poster
Rep: Reputation: Disabled
I feel pretty dumb right now... installed wicd from /extras and everything works fine now... thanks guys!
 
  


Reply

Tags
bcm4318, broadcom


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting Broadcom(4318) Wireless to work iLikeVanilla Linux - Networking 5 12-08-2008 11:34 AM
Making Broadcom wireless adapters work. pappy_mcfae Linux - Wireless Networking 20 04-10-2008 04:54 PM
cant get broadcom wireless to work crsn263 Linux - Newbie 2 11-19-2007 11:08 AM
Broadcom wireless card won't work chris.machen Linux - Newbie 12 11-17-2007 06:09 PM
has anyone got broadcom 4318 wireless to work? bailey239 Mandriva 3 07-23-2007 08:50 PM


All times are GMT -5. The time now is 03:55 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration