LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-27-2013, 06:32 AM   #76
clod89
Member
 
Registered: Jun 2012
Distribution: Slackware gentoo debian
Posts: 41

Rep: Reputation: Disabled

mate-screensaver doesn't lock the screen here too and ate-system-monitor does not require giomm as it's a library already provided by glibmm.

I've also noticed that the cpu frequency scaling monitor applet crashes when I try to add it and for some reason the clock doesn't display the weather of my set location although it works if I set the set the location each time I log in.
 
Old 03-27-2013, 07:09 AM   #77
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,546

Rep: Reputation: 419Reputation: 419Reputation: 419Reputation: 419Reputation: 419
I can confirm that cpu frequency scaling monitor did crashed here (never tried that before), but the weather applet works here. I can see the weather and also the temperature
 
Old 03-27-2013, 07:31 AM   #78
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,546

Rep: Reputation: 419Reputation: 419Reputation: 419Reputation: 419Reputation: 419
OK, i found the problem
in /etc/dbus-1/system.d/org.mate.CPUFreqSelector.conf, you will see this line
Code:
<busconfig>

  <!-- Only root can own the service -->
  <policy user="root">
    <allow own="org.mate.CPUFreqSelector"/>
    <allow send_interface="org.mate.CPUFreqSelector"/>
  </policy>

  <policy context="default">
    <allow send_interface="org.mate.CPUFreqSelector"/>
  </policy>

</busconfig>
as you can see, only root is allowed to do such changes and i think it's something common in most Linux system.

i searched for solutions and most of them are for Ubuntu-derivatives, such as LinuxMint, but they are not well suitable for Slackware.
 
Old 03-27-2013, 07:42 AM   #79
chess
Member
 
Registered: Mar 2002
Location: 127.0.0.1
Distribution: Slackware, OpenBSD, FreeBSD
Posts: 728

Original Poster
Rep: Reputation: 168Reputation: 168
I have been using MATE on a dual-monitor system on my Thinkpad X200s w/ Intel graphics -- laptop screen and external LCD -- and it's been working fine. I have routinely used the Monitors gui tool to switch back and forth between both monitors, just the laptop, and just the LCD without issue.

I have not yet tried the CPU scaling applet but @willysr I wonder if there is a way to create a polkit or dbus policy that will allow the user to modify the CPU settings. I'm not totally up on how to do that but I'll see what I can find.
 
Old 03-27-2013, 07:56 AM   #80
chess
Member
 
Registered: Mar 2002
Location: 127.0.0.1
Distribution: Slackware, OpenBSD, FreeBSD
Posts: 728

Original Poster
Rep: Reputation: 168Reputation: 168
Something like this in /etc/polkit-1/localauthority/50-local.d/30-mate-cpu-applet.pkla:

Code:
[Change MATE CPU Frequency Scaling Applet]
Identity=unix-group:power
Action=org.mate.CPUFreqSelector
ResultAny=no
ResultInactive=no
ResultActive=yes
/should/ work (assuming the user is in the power group) but I have not tested yet. Might need to log out and log back in again.

Last edited by chess; 03-27-2013 at 07:59 AM.
 
Old 03-27-2013, 07:58 AM   #81
clod89
Member
 
Registered: Jun 2012
Distribution: Slackware gentoo debian
Posts: 41

Rep: Reputation: Disabled
Quote:
Originally Posted by willysr View Post
I can confirm that cpu frequency scaling monitor did crashed here (never tried that before), but the weather applet works here. I can see the weather and also the temperature
The weather icon does show up and woks fine but it's as if it doesn't keep the location I've set as my home, also in order to set it (just click the set button right next to it) it asks for my root password to perform this action: "org.mate.settingsdaemon.datetimemechanism.settimezone" .
 
Old 03-27-2013, 08:04 AM   #82
chess
Member
 
Registered: Mar 2002
Location: 127.0.0.1
Distribution: Slackware, OpenBSD, FreeBSD
Posts: 728

Original Poster
Rep: Reputation: 168Reputation: 168
@clod89: try also creating /etc/polkit-1/localauthority/50-local.d/40-mate-clock-set.pkla with this:

Code:
[Set and change the clock applet]
Identity=unix-group:power
Action:org.mate.settingsdaemon.datetimemechanism.*
ResultActive=yes
Again, log out and log back in again and see if that works.
 
Old 03-27-2013, 08:39 AM   #83
clod89
Member
 
Registered: Jun 2012
Distribution: Slackware gentoo debian
Posts: 41

Rep: Reputation: Disabled
@chess

I've tried both but the problems still persist, I've also found out I can't set the default browser, I've tried modifying xdg-open as written here http://forums.mate-desktop.org/viewtopic.php?f=2&t=885 but that didn't work either :-/
 
Old 03-27-2013, 08:47 AM   #84
chess
Member
 
Registered: Mar 2002
Location: 127.0.0.1
Distribution: Slackware, OpenBSD, FreeBSD
Posts: 728

Original Poster
Rep: Reputation: 168Reputation: 168
Hmm, those pkla files should have worked. I will test them out as soon as I can. As to the default browser, I thought that worked for me but I'll check that as well.
 
Old 03-27-2013, 09:05 AM   #85
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,546

Rep: Reputation: 419Reputation: 419Reputation: 419Reputation: 419Reputation: 419
on my system, i set to firefox and it's working fine
 
Old 03-27-2013, 09:10 AM   #86
clod89
Member
 
Registered: Jun 2012
Distribution: Slackware gentoo debian
Posts: 41

Rep: Reputation: Disabled
Quote:
Originally Posted by willysr View Post
on my system, i set to firefox and it's working fine
Here I can't choose at all the option is greyed out.

btw I have firefox chromium and konqueror installed but and it chose to default to firefox

Last edited by clod89; 03-27-2013 at 09:12 AM.
 
Old 03-27-2013, 09:12 AM   #87
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,546

Rep: Reputation: 419Reputation: 419Reputation: 419Reputation: 419Reputation: 419
Quote:
Originally Posted by chess View Post
@clod89: try also creating /etc/polkit-1/localauthority/50-local.d/40-mate-clock-set.pkla with this:

Code:
[Set and change the clock applet]
Identity=unix-group:power
Action:org.mate.settingsdaemon.datetimemechanism.*
ResultActive=yes
Again, log out and log back in again and see if that works.
This one worked, but the CPU Freq did not

Do you want to add it to mate-applet or should i ?
 
Old 03-27-2013, 09:16 AM   #88
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,546

Rep: Reputation: 419Reputation: 419Reputation: 419Reputation: 419Reputation: 419
Quote:
Originally Posted by clod89 View Post
Here I can't choose at all the option is greyed out.

btw I have firefox chromium and konqueror installed but and it chose to default to firefox
i have Firefox (from Mozilla binary), Opera, and Chrome and they are all listed in Preferred Applications on my system
See screenshot below
prefered.jpg
 
Old 03-27-2013, 09:27 AM   #89
clod89
Member
 
Registered: Jun 2012
Distribution: Slackware gentoo debian
Posts: 41

Rep: Reputation: Disabled
Quote:
Originally Posted by willysr View Post
i have Firefox (from Mozilla binary), Opera, and Chrome and they are all listed in Preferred Applications on my system
See screenshot below
Attachment 12145
Here's what I see
Attached Images
File Type: jpg 2013-03-27-152522_1366x768_scrot.jpg (64.4 KB, 13 views)
 
Old 03-27-2013, 09:30 AM   #90
chess
Member
 
Registered: Mar 2002
Location: 127.0.0.1
Distribution: Slackware, OpenBSD, FreeBSD
Posts: 728

Original Poster
Rep: Reputation: 168Reputation: 168
I have a feeling these issues are all related, like the session manager or the settings daemon hasn't been started. @clod89 can you provide detail on the system -- -current or 14.0, which architecture, how you are starting MATE (from startx or KDM), is this a full install, etc.?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Ubuntu Precise Call For Testing Unity File Lens LXer Syndicated Linux News 0 03-09-2012 07:11 AM
Call for Testing: Xorg Updates (20100830) rworkman Slackware 213 02-01-2011 07:50 PM
[Call for testing] ibus SlackBuild grissiom Slackware 6 05-19-2009 10:39 AM
Use SlackBuilds.org or my own hosting to offer up SlackBuilds? hollywoodb Slackware 6 11-30-2006 08:56 PM
LXer: Call for testing/battering: sysjail LXer Syndicated Linux News 0 08-15-2006 03:03 PM


All times are GMT -5. The time now is 01:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration