LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 03-22-2013, 09:53 PM   #31
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,638

Rep: Reputation: 451Reputation: 451Reputation: 451Reputation: 451Reputation: 451

On my machine, it worked well, but it started a lot of file manager processes, causing the systray no room for other application and causing the machine to work on high load all the time until i logged out of the system.

any ideas on how to solve this problem?

i'm running -Current and i have all modules built fine here
 
Old 03-22-2013, 10:09 PM   #32
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,638

Rep: Reputation: 451Reputation: 451Reputation: 451Reputation: 451Reputation: 451
i traced the mate-file-manager and run it in KDE and it reported an error

Code:
willysr@desktop:~$ caja
Initializing caja-open-terminal extension
The program 'caja' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
  (Details: serial 7 error_code 9 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
however, when i ran caja --sync as suggested, it worked well...
now the problem is how to make caja is called with --sync parameter by default
 
Old 03-22-2013, 10:14 PM   #33
chess
Member
 
Registered: Mar 2002
Location: 127.0.0.1
Distribution: Slackware, OpenBSD, FreeBSD
Posts: 728

Original Poster
Rep: Reputation: 168Reputation: 168
Huh, I'm not seeing that at all. It's working nicely here, 136 processes total with no real load. How are you starting MATE - from KDM/login manager or via startx?
 
Old 03-23-2013, 03:45 AM   #34
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,638

Rep: Reputation: 451Reputation: 451Reputation: 451Reputation: 451Reputation: 451
Via startx after i changed the default DE into mate
 
Old 03-23-2013, 08:31 AM   #35
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,638

Rep: Reputation: 451Reputation: 451Reputation: 451Reputation: 451Reputation: 451
i solved it temporarily by removing mate-file-manager-open-terminal and mate-file-manager
 
Old 03-23-2013, 08:57 AM   #36
fskmh
Member
 
Registered: Jun 2002
Location: South Africa
Distribution: Customised Slackware64-14.1 with multilib
Posts: 237

Rep: Reputation: 55
Thumbs up

First off - thanks for your efforts with this Chess.

I did a git clone, ran base/mate-build-base.sh and it fell over when it got to gtk-engines with "
You must have automake 1.7.x installed to compile".

So I replaced ./autogen.sh in the SlackBuild with ./configure and it got through the configure process and built. I realise this is probably not as robust but I'm curious to see what Mate looks like.

I am building on slackware64-current (March 20) BTW.

The rest of base and extra was uneventful. I pushed my luck and went into testing as well, and I have a few comments:

(1) mate-screensaver - the SlackBuild needed the old -L/usr/lib64 trick in
Code:
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC -L/usr/lib64"
  LIBDIRSUFFIX="64"
(2) mate-system-monitor required me to first install libgtop.
(3) mate-text-editor required me to first install gtksourceview.

Just logged out of KDE and logged into Mate desktop without rebooting and everything seems to be working.

I spoke too soon. When I launch mate-terminal I get this:
Code:
fskmh@workstation:~> mate-terminal 

(mate-terminal:3356): GLib-GIO-ERROR **: Settings schema 'org.gnome.system.proxy.http' does not contain a key named 'use-http-proxy'
Trace/breakpoint trap
I am explicitly using a proxy (Squid). If I go into "Control Center" and then "Network Proxy" and change to "Direct internet connection", mate-terminal launches fine. Perhaps this is an upstream problem though, because there is no matching key in that schema:
Code:
fskmh@workstation:~> gsettings list-keys org.gnome.system.proxy.http
authentication-password
authentication-user
enabled
host
port
use-authentication
Tried the following and I can confirm that it does not work:
Code:
fskmh@workstation:~> gconftool-2 --set /system/http_proxy/use_http_proxy --type bool true
fskmh@workstation:~> gsettings set org.gnome.system.proxy.http host '127.0.0.1'
fskmh@workstation:~> gsettings set org.gnome.system.proxy.http port 3128       
fskmh@workstation:~> gsettings set org.gnome.system.proxy mode 'manual'
I suspect that something has to be recompiled with this key enabled.

Last edited by fskmh; 03-23-2013 at 10:53 AM.
 
2 members found this post helpful.
Old 03-23-2013, 11:57 AM   #37
chess
Member
 
Registered: Mar 2002
Location: 127.0.0.1
Distribution: Slackware, OpenBSD, FreeBSD
Posts: 728

Original Poster
Rep: Reputation: 168Reputation: 168
Quote:
Originally Posted by fskmh View Post
First off - thanks for your efforts with this Chess.
Thanks for testing!

Quote:
I did a git clone, ran base/mate-build-base.sh and it fell over when it got to gtk-engines with "
You must have automake 1.7.x installed to compile".
Yes, I have to assume that folks are building on a full install but thanks for letting me know how to proceed without automake.

Quote:
The rest of base and extra was uneventful. I pushed my luck and went into testing as well, and I have a few comments:

(1) mate-screensaver - the SlackBuild needed the old -L/usr/lib64 trick in
Code:
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC -L/usr/lib64"
  LIBDIRSUFFIX="64"
Hmm, thanks - I'll check into this.

Quote:
(2) mate-system-monitor required me to first install libgtop.
(3) mate-text-editor required me to first install gtksourceview.
Yes, those dependencies should already be listed in the READMEs. The stuff in /testing, BTW, is not supported -- that's why they are in /testing. :-) I might add those deps or might not.

Quote:
Just logged out of KDE and logged into Mate desktop without rebooting and everything seems to be working.

I spoke too soon. When I launch mate-terminal I get this:
Code:
fskmh@workstation:~> mate-terminal 

(mate-terminal:3356): GLib-GIO-ERROR **: Settings schema 'org.gnome.system.proxy.http' does not contain a key named 'use-http-proxy'
Trace/breakpoint trap
I am explicitly using a proxy (Squid). If I go into "Control Center" and then "Network Proxy" and change to "Direct internet connection", mate-terminal launches fine. Perhaps this is an upstream problem though, because there is no matching key in that schema:
Code:
fskmh@workstation:~> gsettings list-keys org.gnome.system.proxy.http
authentication-password
authentication-user
enabled
host
port
use-authentication
Tried the following and I can confirm that it does not work:
Code:
fskmh@workstation:~> gconftool-2 --set /system/http_proxy/use_http_proxy --type bool true
fskmh@workstation:~> gsettings set org.gnome.system.proxy.http host '127.0.0.1'
fskmh@workstation:~> gsettings set org.gnome.system.proxy.http port 3128       
fskmh@workstation:~> gsettings set org.gnome.system.proxy mode 'manual'
I suspect that something has to be recompiled with this key enabled.
Hmm, I have not seen these issues at all and I've now installed this on three separate systems, one running 64 bit current, but then again I don't use squid. Thanks for letting me about the fix in this particular use case.

I appreciate the testing and feedback!

Last edited by chess; 03-23-2013 at 12:01 PM.
 
Old 03-23-2013, 12:47 PM   #38
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,638

Rep: Reputation: 451Reputation: 451Reputation: 451Reputation: 451Reputation: 451
i can confirm that everything is working well on Slackware64-Current with only base packages installed (no extra and testing)
now testing in another Slackware-Current machine with only base package installed

if it's proven to be OK, then i guess one of the modules in extra/testing caused the problem i had with file-manager in base
 
Old 03-23-2013, 03:07 PM   #39
chess
Member
 
Registered: Mar 2002
Location: 127.0.0.1
Distribution: Slackware, OpenBSD, FreeBSD
Posts: 728

Original Poster
Rep: Reputation: 168Reputation: 168
Quote:
Originally Posted by fskmh View Post
F
(1) mate-screensaver - the SlackBuild needed the old -L/usr/lib64 trick in
Code:
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC -L/usr/lib64"
  LIBDIRSUFFIX="64"
Following up on this -- mate-screensaver built and installed fine on my slackware64-14.0 and slackware64-current systems and chroots without this change and I see that mate-screensaver.pc was correctly installed into /usr/lib64, so not sure why we would need to add this. What happened on your system when you tried to build it?
 
Old 03-23-2013, 04:23 PM   #40
fskmh
Member
 
Registered: Jun 2002
Location: South Africa
Distribution: Customised Slackware64-14.1 with multilib
Posts: 237

Rep: Reputation: 55
Here is what I get after running the build script in an "su -l" environment (without the -L/usr/lib64 kludge):
Code:
..
..
make[3]: Entering directory `/tmp/msb/mate-screensaver-1.5.2/src'
  CCLD     mate-screensaver-gl-helper
/usr/lib64/gcc/x86_64-slackware-linux/4.7.2/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/X11R6/lib/libbz2.so when searching for -lbz2
/usr/lib64/gcc/x86_64-slackware-linux/4.7.2/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/X11R6/lib/libbz2.a when searching for -lbz2
/usr/lib64/gcc/x86_64-slackware-linux/4.7.2/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/X11R6/lib/libz.so when searching for -lz
/usr/lib64/gcc/x86_64-slackware-linux/4.7.2/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/X11R6/lib/libz.a when searching for -lz
/usr/lib64/gcc/x86_64-slackware-linux/4.7.2/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/X11R6/lib/libresolv.so when searching for -lresolv
/usr/lib64/gcc/x86_64-slackware-linux/4.7.2/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/X11R6/lib/libresolv.a when searching for -lresolv
/usr/lib64/gcc/x86_64-slackware-linux/4.7.2/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/X11R6/lib/libpthread.so when searching for -lpthread
/usr/lib64/gcc/x86_64-slackware-linux/4.7.2/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/X11R6/lib/libpthread.a when searching for -lpthread
/usr/lib64/gcc/x86_64-slackware-linux/4.7.2/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/X11R6/lib/librt.so when searching for -lrt
/usr/lib64/gcc/x86_64-slackware-linux/4.7.2/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/X11R6/lib/librt.a when searching for -lrt
/usr/lib/libXext.so: could not read symbols: File in wrong format
collect2: error: ld returned 1 exit status
make[3]: *** [mate-screensaver-gl-helper] Error 1
make[3]: Leaving directory `/tmp/msb/mate-screensaver-1.5.2/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/tmp/msb/mate-screensaver-1.5.2/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/msb/mate-screensaver-1.5.2'
make: *** [all] Error 2
I have experienced the linker trying link a 32 bit library with the odd package I have compiled in the past so I usually just force it to use /usr/lib64 without batting an eyelid.

I must confess - this is on slack64-current with a truckload of extra packages (mostly from SBo).

P.S. I have updated the following packages in the meantime:
mate-calc-1.5.2
mate-control-center-1.5.5
mate-desktop-1.5.8
mate-icon-theme-faenza-1.5.1
mate-keyring-1.5.1
mate-media-1.5.2
mate-settings-daemon-1.5.7
mate-terminal-1.5.1
mate-themes-1.5.1
mate-window-manager-1.5.5

These I added myself:
mate-file-manager-gksu-1.5.0
mate-bluetooth-1.5.1
mate-sensors-applet-1.5.2
mate-netspeed-1.5.2

I've been using this desktop for most of the afternoon and nothing's fallen over so far. Pulseaudio also seems to work the same as it does in KDE.

Last edited by fskmh; 03-23-2013 at 04:26 PM.
 
1 members found this post helpful.
Old 03-23-2013, 04:30 PM   #41
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,504

Rep: Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912
Quote:
Originally Posted by fskmh View Post
I have experienced the linker trying link a 32 bit library with the odd package I have compiled in the past so I usually just force it to use /usr/lib64 without batting an eyelid.
this is because you are using a multilib environment, that usually is not supported by *.SlackBuild scripts.
 
1 members found this post helpful.
Old 03-23-2013, 04:37 PM   #42
fskmh
Member
 
Registered: Jun 2002
Location: South Africa
Distribution: Customised Slackware64-14.1 with multilib
Posts: 237

Rep: Reputation: 55
Ah, thanks ponce - I suspected as much.
 
Old 03-23-2013, 08:43 PM   #43
fskmh
Member
 
Registered: Jun 2002
Location: South Africa
Distribution: Customised Slackware64-14.1 with multilib
Posts: 237

Rep: Reputation: 55
Just experienced the same issue willysr mentioned in #31. I tailed ~/.xsession-errors and got a bunch of these:
Code:
** Message: Initializing gksu extension...
Initializing caja-open-terminal extension
The program 'caja' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
  (Details: serial 7 error_code 9 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
While I was fiddling around looking for more details it stopped by itself after about a minute. Looks like it stopped because X reached its limit on the number of client connections.

P.S. I am using runlevel 4 + KDM.

Last edited by fskmh; 03-23-2013 at 08:45 PM.
 
Old 03-23-2013, 08:48 PM   #44
chess
Member
 
Registered: Mar 2002
Location: 127.0.0.1
Distribution: Slackware, OpenBSD, FreeBSD
Posts: 728

Original Poster
Rep: Reputation: 168Reputation: 168
Try removing the mate-file-manager-open-terminal package and see if that helps. Willysr removed it and the problem cleared up apparently

I can't reproduce it here -- the file manager and the open-terminal extension work fine.

Last edited by chess; 03-23-2013 at 08:49 PM.
 
Old 03-23-2013, 09:03 PM   #45
fskmh
Member
 
Registered: Jun 2002
Location: South Africa
Distribution: Customised Slackware64-14.1 with multilib
Posts: 237

Rep: Reputation: 55
Quote:
Originally Posted by chess View Post
Try removing the mate-file-manager-open-terminal package and see if that helps. Willysr removed it and the problem cleared up apparently

I can't reproduce it here -- the file manager and the open-terminal extension work fine.
That was the first thing I tried - didn't help.
Tried disabling compositing as well, but that didn't help either.

What did help was editing /usr/share/applications/caja.desktop and changing "Exec=caja" to "Exec=caja --sync".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Ubuntu Precise Call For Testing Unity File Lens LXer Syndicated Linux News 0 03-09-2012 08:11 AM
Call for Testing: Xorg Updates (20100830) rworkman Slackware 213 02-01-2011 08:50 PM
[Call for testing] ibus SlackBuild grissiom Slackware 6 05-19-2009 11:39 AM
Use SlackBuilds.org or my own hosting to offer up SlackBuilds? hollywoodb Slackware 6 11-30-2006 09:56 PM
LXer: Call for testing/battering: sysjail LXer Syndicated Linux News 0 08-15-2006 04:03 PM


All times are GMT -5. The time now is 04:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration