LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-12-2017, 12:11 AM   #1
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,494

Rep: Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880
Talking Call for Testers: MATE 1.17


Hi Everyone

MATE 1.18 is just around the corners. In order to get the best release ever, please help on testing MATE 1.17 development snapshot. All the changes are now merged into master branch.

In short, there are some changes in the upcoming MATE 1.18 release:
- 6 new packages added: gtksourceview3, glade, libunique3, libpeas, mate-calc, and caja-actions
- 3 packages removed: galculator, gtksourceview, pygtksourceview
- It's all GTK+3 build, no more GTK+2/3 mix build
- HELP files are now provided, but yelp will not be included (due to webkit requirement which is takes too long to build). Users might want to install yelp via SBo project or via testing directory.

Please test them and let me know if there are some bugs or if you have suggestions for this project.

NOTE: The binary packages in http://slackware.uk/msb/current/1.17/ are not yet updated to the latest snapshots yet, but it should be usable for now.
 
Old 03-12-2017, 05:35 AM   #2
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2 on Lenovo Thinkpad W520
Posts: 7,164

Rep: Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272
Hi Willy,

Thanks for your work on that.

One question and one request:
1) In Slint pluma is the default text editor (version 1.16.0 from Salix repos at time of writing) and I have noted here that it needs gtksourceview and pygtksourceview. Does this change in 1.17?

2) Please let us know when http://slackware.uk/msb/current/1.17/ will be updated. I am a bit lazy and then testing Mate 1.17 in Slint-14.2 will hopefully be possible just adding the repo in slapt-getrc and running "slapt-get --install-set msb" or something like that.

Last edited by Didier Spaier; 03-12-2017 at 06:14 PM. Reason: s/1.17.0/1.17/
 
Old 03-12-2017, 05:57 AM   #3
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,494

Original Poster
Rep: Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880
Quote:
Originally Posted by Didier Spaier View Post
Hi Willy,

Thanks for your work on that.

One question and one request:
1) In Slint pluma is the default text editor (version 1.16.0 from Salix repos at time of writing) and I have noted here that it needs gtksourceview and pygtksourceview. Does this change in 1.17?

2) Please let us know when http://slackware.uk/msb/current/1.17/ will be updated. I am a bit lazy and then testing Mate 1.17.0 in Slint-14.2 will hopefully be possible just adding the repo in slapt-getrc and running "slapt-get --install-set msb" or something like that.
1. Yes, pluma will require gtksourceview3 since everything is now GTK+3 based and for the plugins, they are now migrated to libpeas so it was added in this cycle as well.

2. I will try to rebuilt all of them in the next 1-2 days. I will put a post on this thread when i have done it.

Thanks
 
1 members found this post helpful.
Old 03-12-2017, 11:16 AM   #4
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,494

Original Poster
Rep: Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880
@didier:
OK, it's now pushed
 
1 members found this post helpful.
Old 03-12-2017, 01:34 PM   #5
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2 on Lenovo Thinkpad W520
Posts: 7,164

Rep: Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272
So far, so good!

Thanks Willy, that was fast.

Here is what I did (in Slint64-14.2 with all patches applied and few additional packages):
  1. Add these lines to /etc/slapt-get/slapt-getrc:
    Code:
    # The msb current repository
    SOURCE=http://slackware.uk/msb/current/1.17/x86_64/:PREFERRED
  2. Run:
    Code:
    slapt-get -u
    slapt-get --add-keys
    slapt-get --install-set deps
    slapt-get --install-set base
    slapt-get --install-set extra
  3. logout (back to lxdm, in runlevel 4)
  4. In lxdm, start MATE
Please find attached a pic of Slint64-14.2 running your MATE 1.17 and a report about installed/upgraded packages.

It looks like you did it right, congrats!

Only caveat: opening a remote URL (non anonymous FTP) starts Audacious. Maybe a wrong default app setting? This not withstanding I could access the remote repo with Caja. EDIT: solved just changing:
System => Preferences => Personal => Preferred Applications => File Manager from Audacious to Caja. Although I tend to prefer PCManFM

This is just a first look, will play with it in the coming days. If you need specific tests, just ask.
Attached Thumbnails
Click image for larger version

Name:	mate.jpg
Views:	53
Size:	156.5 KB
ID:	24474  
Attached Files
File Type: txt install_msb_current.txt (4.6 KB, 5 views)

Last edited by Didier Spaier; 03-12-2017 at 06:38 PM. Reason: EDIT added.
 
Old 03-12-2017, 02:35 PM   #6
Desertwulf
LQ Newbie
 
Registered: Apr 2016
Distribution: Slackware
Posts: 15

Rep: Reputation: Disabled
installed it 2h ago, no compilation issues, no issues in using it so far. Will report back after a few more hours / days of usage.
Attached Thumbnails
Click image for larger version

Name:	ScreenshotMATE.jpg
Views:	35
Size:	201.2 KB
ID:	24484  

Last edited by Desertwulf; 03-12-2017 at 02:44 PM. Reason: added version pic
 
Old 03-12-2017, 06:52 PM   #7
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,494

Original Poster
Rep: Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880
Quote:
Originally Posted by Didier Spaier View Post
Thanks Willy, that was fast.

Here is what I did (in Slint64-14.2 with all patches applied and few additional packages):
  1. Add these lines to /etc/slapt-get/slapt-getrc:
    Code:
    # The msb current repository
    SOURCE=http://slackware.uk/msb/current/1.17/x86_64/:PREFERRED
  2. Run:
    Code:
    slapt-get -u
    slapt-get --add-keys
    slapt-get --install-set deps
    slapt-get --install-set base
    slapt-get --install-set extra
  3. logout (back to lxdm, in runlevel 4)
  4. In lxdm, start MATE
Please find attached a pic of Slint64-14.2 running your MATE 1.17 and a report about installed/upgraded packages.

It looks like you did it right, congrats!

Only caveat: opening a remote URL (non anonymous FTP) starts Audacious. Maybe a wrong default app setting? This not withstanding I could access the remote repo with Caja. EDIT: solved just changing:
System => Preferences => Personal => Preferred Applications => File Manager from Audacious to Caja. Although I tend to prefer PCManFM

This is just a first look, will play with it in the coming days. If you need specific tests, just ask.
Yes, the default setting for file-manager will be audacious, not caja
this is a known issue for some time. I will see if i can override this settings in gschema.

thanks for reminding me.
 
Old 03-12-2017, 08:04 PM   #8
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,494

Original Poster
Rep: Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880
@Didier:

I think i have fixed it here:
https://github.com/mateslackbuilds/m...3ce9c0e2c504f9

please note that it will only work with new user. Existing user will not be affected
 
Old 03-13-2017, 01:47 AM   #9
Desertwulf
LQ Newbie
 
Registered: Apr 2016
Distribution: Slackware
Posts: 15

Rep: Reputation: Disabled
2 issues so far:
- I am using dual monitor setup. Going to the Display Settings and moving the monitors to the correct layout yields graphical artifacts
- adding applications via right click to the panel (as shortcuts) makes the whole panel unresponsive (ctrl-alt-backspace and restart is ok, shortcuts are working after that)

btw File Manager preset on mine was not audacious. It was either empty or Caja, sorry I cannot remember.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_Displays.jpg
Views:	19
Size:	31.0 KB
ID:	24493  
 
Old 03-13-2017, 03:37 AM   #10
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,494

Original Poster
Rep: Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880
Quote:
Originally Posted by Desertwulf View Post
2 issues so far:
- I am using dual monitor setup. Going to the Display Settings and moving the monitors to the correct layout yields graphical artifacts
- adding applications via right click to the panel (as shortcuts) makes the whole panel unresponsive (ctrl-alt-backspace and restart is ok, shortcuts are working after that)

btw File Manager preset on mine was not audacious. It was either empty or Caja, sorry I cannot remember.
Hi Desertwulf
- Since i don't use dual monitor setup, i'm afraid it's up to upstream to fix. But i will help to report it to upstream.
- Your second issue was a known issue for some time: https://github.com/mate-desktop/mate-panel/issues/305

Last edited by willysr; 03-13-2017 at 03:39 AM.
 
Old 03-13-2017, 07:39 AM   #11
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2 on Lenovo Thinkpad W520
Posts: 7,164

Rep: Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272
Quote:
Originally Posted by willysr View Post
@Didier:

I think i have fixed it here:
https://github.com/mateslackbuilds/m...3ce9c0e2c504f9

please note that it will only work with new user. Existing user will not be affected
I cloned the repo, built, removed and installed anew mate-desktop. Works as expected by the specification, thanks.

Last edited by Didier Spaier; 03-13-2017 at 11:59 AM. Reason: Typo fix.
 
Old 03-13-2017, 09:26 AM   #12
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,494

Original Poster
Rep: Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880
Quote:
Originally Posted by Didier Spaier View Post
I cloned the repo, built, removed and installed anew mate-desktop. Works as expected by the specifiication, thanks.
Just FYI, i have rebuilt the mate-desktop package (but i didn't bump the build number) and uploaded the binary package to the usual repository so that next Slackware Live ISO will use the updated build that have that fix.
 
Old 03-13-2017, 09:00 PM   #13
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,494

Original Poster
Rep: Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880
MATE 1.18.0 is now out.
Github/GitLab sources are up to date and i will rebuilt binary packages as soon as possible.
 
Old 03-14-2017, 03:49 PM   #14
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.2 64-bit with multilib
Posts: 2,310

Rep: Reputation: 613Reputation: 613Reputation: 613Reputation: 613Reputation: 613Reputation: 613
Quote:
Originally Posted by willysr View Post
MATE 1.18.0 is now out.
Github/GitLab sources are up to date and i will rebuilt binary packages as soon as possible.
I was just about to say that - I skipped 1.17 to test on my Slackware VM because of that.
 
Old 03-14-2017, 04:07 PM   #15
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2 on Lenovo Thinkpad W520
Posts: 7,164

Rep: Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272Reputation: 2272
FYI a blog post with a video by Frederic Bezies (in french): http://frederic.bezies.free.fr/blog/?p=15829

Last edited by Didier Spaier; 03-14-2017 at 04:09 PM.
 
  


Reply

Tags
mate, msb


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Call for Testers: MATE 1.16 for Slackware 14.2 willysr Slackware 39 12-03-2016 12:00 AM
[SOLVED] Call for Testers: MATE 1.14 for -Current willysr Slackware 13 05-27-2016 08:08 AM
Call for Testers: Comparison of MATE 1.14 (mix build vs fully GTK+3 build) willysr Slackware 33 05-10-2016 03:40 PM
Call for Testers: MATE 1.8 willysr Slackware 137 08-06-2014 01:50 AM


All times are GMT -5. The time now is 03:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration