LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-09-2014, 09:02 AM   #16
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,530
Blog Entries: 3

Rep: Reputation: 209Reputation: 209Reputation: 209

on the 64 bit build it is placing these directories in /usr/lib
Quote:
cinnamon-desktop-editor cinnamon-looking-glass cinnamon-screensaver-lock-dialog cinnamon-settings-users
cinnamon-json-makepot cinnamon-menu-editor cinnamon-settings
 
Old 04-09-2014, 09:05 AM   #17
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,548

Original Poster
Rep: Reputation: 422Reputation: 422Reputation: 422Reputation: 422Reputation: 422
Quote:
Originally Posted by 01micko View Post
Yep, I confirmed that
Did you reinstall NetworkManager and startup-notification and install bash-completions before building?
 
Old 04-09-2014, 09:10 AM   #18
01micko
Member
 
Registered: Mar 2009
Location: Gold Coast, Queensland, Australia
Distribution: Puppy, Slackware
Posts: 77

Rep: Reputation: 7
Quote:
Originally Posted by willysr View Post
Did you reinstall NetworkManager and startup-notification and install bash-completions before building?
Yes. I was tempted not to bother with NetworkManager and startup-notification but I didn't want hassles so took the advice.
 
Old 04-09-2014, 09:13 AM   #19
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,530
Blog Entries: 3

Rep: Reputation: 209Reputation: 209Reputation: 209
works fine playing with it now reinstalled my nvidia I have to for h264 reasons and the other multimedia. after building it. Composite works good. going to add the gst1-plugins-bad and ugly for other reasons

Last edited by Drakeo; 04-09-2014 at 09:14 AM.
 
Old 04-09-2014, 09:29 AM   #20
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,530
Blog Entries: 3

Rep: Reputation: 209Reputation: 209Reputation: 209
open a terminal in nemo is not working for me?
 
Old 04-09-2014, 09:35 AM   #21
solarfields
Member
 
Registered: Feb 2006
Location: Outer Shpongolia
Distribution: Slackware
Posts: 466

Rep: Reputation: 118Reputation: 118
Willy, you rock dude
 
Old 04-09-2014, 09:42 AM   #22
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,548

Original Poster
Rep: Reputation: 422Reputation: 422Reputation: 422Reputation: 422Reputation: 422
Quote:
Originally Posted by Drakeo View Post
open a terminal in nemo is not working for me?
try reinstalling qt
i don't know why, but somehow some libraries needs to be reinstalled in order for Cinnamon to work correctly
 
Old 04-09-2014, 10:14 AM   #23
Nh3xus
Member
 
Registered: Jan 2013
Location: France
Distribution: Slackware 14.1 32 bits
Posts: 140

Rep: Reputation: 34
So, pulseaudio is now required...

Is there any tweak to do on the initrd or in the rc.S startup script in order to disable Alsa ?

I'm pretty sure that having 2 audio stack running at the same time is not a good idea.
 
Old 04-09-2014, 10:25 AM   #24
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,530
Blog Entries: 3

Rep: Reputation: 209Reputation: 209Reputation: 209
I see it broke a few things . Well it is a start. dolphin open a terminal works fine. how I got it to build in 64 bit mutilib with nivida libvdpau installed.
was to reinstall mesa. rename /usr/lib to /usr/lib~ build it then move the
Quote:
cinnamon-desktop-editor cinnamon-looking-glass cinnamon-screensaver-lock-dialog cinnamon-settings-users
cinnamon-json-makepot cinnamon-menu-editor cinnamon-settings
to /usr/lib~ rename /usr/lib~ to /usr/lib . Other wise I could not get it to build on multi lib. I am sure this is not an issue with a none multi arch.
seems to run fine. but it did break some of my media stuff wait till I have time to figure out what works and what needs to be reconfigured with pulse.
I been dealing with pulse audio layer a long time.
sure much of this has to do with /usr/lib/pkgconfig

Last edited by Drakeo; 04-09-2014 at 10:30 AM. Reason: pkgconfig
 
Old 04-09-2014, 10:28 AM   #25
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,548

Original Poster
Rep: Reputation: 422Reputation: 422Reputation: 422Reputation: 422Reputation: 422
Quote:
Originally Posted by Nh3xus View Post
So, pulseaudio is now required...

Is there any tweak to do on the initrd or in the rc.S startup script in order to disable Alsa ?

I'm pretty sure that having 2 audio stack running at the same time is not a good idea.
Yes, have a look on /etc/rc.d/rc.M

or, simply chmod -x /etc/rc.d/rc.alsa
 
Old 04-09-2014, 10:31 AM   #26
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,548

Original Poster
Rep: Reputation: 422Reputation: 422Reputation: 422Reputation: 422Reputation: 422
Quote:
Originally Posted by Drakeo View Post
I see it broke a few things . Well it is a start. dolphin open a terminal works fine. how I got it to build in 64 bit mutilib with nivida libvdpau installed.
was to reinstall mesa. rename /usr/lib to /usr/lib~ build it then move the to /usr/lib~ rename /usr/lib~ to /usr/lib . Other wise I could not get it to build on multi lib. I am sure this is not an issue with a none multi arch.
seems to run fine. but it did break some of my media stuff wait till I have time to figure out what works and what needs to be reconfigured with pulse.
I been dealing with pulse audio layer a long time.
Yes, somehow some of the libraries got broken after compiling some of the packages.
That's why reinstalling some of the libraries are now the only solution, but i will try to keep tracking the root cause of this.

About the entry in /usr/lib for x86_64, i can confirm it and still on my TODO list.
Thanks for reporting that one.
I wonder if simply moving it to /usr/lib64 should be OK?
 
Old 04-09-2014, 10:46 AM   #27
Nh3xus
Member
 
Registered: Jan 2013
Location: France
Distribution: Slackware 14.1 32 bits
Posts: 140

Rep: Reputation: 34
Ok.

Thanks you for the info willysr.
 
Old 04-09-2014, 10:57 AM   #28
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,548

Original Poster
Rep: Reputation: 422Reputation: 422Reputation: 422Reputation: 422Reputation: 422
Quote:
Originally Posted by Drakeo View Post
on the 64 bit build it is placing these directories in /usr/lib
Should be fixed now
please run git pull and rebuilt Cinnamon package only
 
Old 04-09-2014, 11:08 AM   #29
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,548

Original Poster
Rep: Reputation: 422Reputation: 422Reputation: 422Reputation: 422Reputation: 422
Quote:
Originally Posted by Drakeo View Post
going to add the gst1-plugins-bad and ugly for other reasons
This is OK as long as you do not redistribute the resulting binary (for gst1-plugins-ugly)
That's why Slackware did not provide this package for gstreamer-0.10.x as well
I also did not provide those on csb, since it would be a problem if someday i would have to provide binary packages as well
 
Old 04-10-2014, 01:38 AM   #30
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,548

Original Poster
Rep: Reputation: 422Reputation: 422Reputation: 422Reputation: 422Reputation: 422
Good news
I just managed to fix the problem with non-working cinnamon-settings in the system tray or in the menu (Preferences > system settings)
please run git pull and rebuild python-pam
 
1 members found this post helpful.
  


Reply

Tags
cinnamon, csb


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Call for Testers: MATE 1.8 willysr Slackware 137 08-06-2014 01:50 AM
Call for testing - MATE SlackBuilds chess Slackware 298 12-21-2013 09:17 PM
[SOLVED] [TESTERS WANTED] Slint installers for Slackware 14.1 => LAST CALL Didier Spaier Slackware 11 11-22-2013 06:22 AM
Teslagrad Linux alpha: call for testers kabamaru Linux - Games 1 07-10-2013 01:48 PM
Business Apps on Slackware - TinyERP: Call for testers ppr:kut Slackware 0 06-10-2008 05:15 AM


All times are GMT -5. The time now is 06:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration