LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Calibre 0.8.18 (http://www.linuxquestions.org/questions/slackware-14/calibre-0-8-18-a-902468/)

interndan 09-11-2011 03:04 PM

Calibre 0.8.18
 
I'm trying to modify the slackbuild script from sbo to use the latest version of calibre. I get the following errors:
Code:

patching file src/calibre/linux.py
Hunk #1 FAILED at 288.
Hunk #2 FAILED at 304.
2 out of 2 hunks FAILED -- saving rejects to file src/calibre/linux.py.rej
patching file src/calibre/utils/help2man.py
Hunk #1 FAILED at 4.
Hunk #2 FAILED at 58.
2 out of 2 hunks FAILED -- saving rejects to file src/calibre/utils/help2man.py.rej

any ideas how to fix this?

Thanks Dan...

Snark1994 09-11-2011 03:16 PM

It sounds like the patch file you're using wasn't created using the file which you're trying to patch - it can't find the bits of code it needs to change. Where did you get the source and the patch from?

dive 09-11-2011 03:19 PM

Quote:

Originally Posted by interndan (Post 4469084)
any ideas how to fix this?

You either need the correct patch for the correct source version, or take a look to see what the patch changes and try to make one yourself.

sinic 09-11-2011 03:57 PM

You could also take AlienBOB's package (that has been updated today), instead of compiling it yourself.

interndan 09-11-2011 04:32 PM

I got the source from calibre home page. I didn't see anything about a patch of any kind.

I'll give AlienBob's package a try.

Thanks.
Dan

Alien Bob 09-11-2011 05:08 PM

The SlackBuild script at SBo is useless for any recent version of Calibre. Slackware ships python 2.6 and Calibre requires python 2.7.
My own SlackBuild script adds an internal python 2.7 compiler plus several python modules to circumvent this problem. That is why the package is so big.

Eric

interndan 09-12-2011 11:03 AM

Well, I tried your package and it doesn't run. Something else must have changed on my system. Perhaps when I installed LXDE. I also tried recompiling the version I was running, and it also fails. I've got to search through the dependencies list and see what else has changed.

Thanks
Dan

Alien Bob 09-12-2011 01:16 PM

I see that I forgot to update my "slack-required" file which lists the dependencies. I have fixed that right away.

What you need apart from my calibre package are podofo and icu4c.
And a full installation of Slackware 13.37 of course :-)

If you are uncertain why calibre does not work, try starting it in a terminal so that you can observe it's standard and error output.

Eric

interndan 09-12-2011 01:20 PM

I'm not at home right now, but I will check when I get there. Thanks much for the advice.

Dan

interndan 09-14-2011 08:07 PM

I apologize for the delay (my granddaughter's softball games interfered with computer work). I installed the other two packages, and calibre still does not run. This is the error when trying to start from terminal:
Code:

Traceback (most recent call last):
  File "/usr/bin/calibre", line 18, in <module>
    from calibre.gui2.main import main
  File "/usr/lib64/calibre/calibre/gui2/__init__.py", line 7, in <module>
    from PyQt4.Qt import (QVariant, QFileInfo, QObject, SIGNAL, QBuffer, Qt,
ImportError: cannot import name QVariant

Thanks
Dan

Alien Bob 09-15-2011 07:18 AM

What release of Slacwkare are you running? I can see that it is a 64bit version.
The error is related to the PyQt package, a full installation of Slackware 13.37 should fullfill all requirements.
You are not installing my Slackware 13.37 calibre package on an older Slackware release are you?

Eric

interndan 09-15-2011 07:14 PM

Yeah that seems to be the problem. I thought I had upgraded this system, apparently I'm still running 13.1

interndan 09-15-2011 07:48 PM

I installed your 13.1 packages and Calibre is running now. Thanks for the help. Can I upgrade to Calibre 0.8.18 with Slack 13.1 ?

Dan

Hyonane 09-15-2011 09:19 PM

I did the same that Dan tried some months ago, work around the slackbuilds script trying to make a package for the new Calibre, and because of the python requirement it obviously didnt work. Im just curious, Bob, why ICU4C and PODOFO werent build inside ur package, as all the others requirements like Beautifulsoup, lxml, setuptools and those others i cant really remenber?

I was studying how to build packages and those things, and since Slackware dont check for dependencies, i was wondering how can i decide if i include dependencies compiled inside the package. Im not talking just about the size of the package , im thinking about stability and how, for example, Calibre, in this example, behaves if Beautifulsoup was in the system when i installed it(calibre) and remove it(beautifulsoup) later from the system. I never had this kinda of problem in Slackware, that i know of.

Funny that while i was thinking about another example i realized its exactly the thing KDE-Developers did with 4.7. They splited the packages in more packages.

I dont want to drag this post too much, but im building Gnome 2.32.1, Enlightement , PCSX2-devel, PCSX2-release, and others, all to slackware, and was havind these toughts about package building. I will create another topic about these builds.

Hyonane 09-15-2011 09:28 PM

Dan, there is a package in the build folder (calibre_pythondeps-13.1.0-x86_64.tar.bz2) that should handle everything if u try to build the Calibre 0.8.18 yourself, but u shouldnt upgrade ur 64b with a 32b.

If that was not the question , and u just asking if u can run the newest Calibre in Slackware-13.1, after another Calibre-0.8 worked, im pretty sure u can.


All times are GMT -5. The time now is 01:31 AM.