LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-07-2011, 08:48 AM   #1
firekage
Member
 
Registered: May 2011
Location: Poland
Distribution: Slackware, Ubuntu, Arch
Posts: 272

Rep: Reputation: 7
Cairo dock starts twice


As mentioned above, i have problem with Cairo dock on Slackware 13.37.


Does anybody know why it start twice at boot? In K-system settings-system start and stop in session menager i choosed start blank session at startup, also i entered below cairo-dock -o in programs excluded form session menager and with it, and without it cairo starts twice.

Help :|
 
Old 11-08-2011, 12:23 AM   #2
fukawi1
Member
 
Registered: Apr 2009
Location: Melbourne
Distribution: Fedora & CentOS
Posts: 854

Rep: Reputation: 189Reputation: 189
I have had similar problems with FC15 XFCE and cairo dock..

The xfce application autostart configuration was set to start both cairo-dock, and GLX-Dock.

I also seem to recall the "auto start" option in cairo dock, wouldn't show up in the xfce startup app's. So if both were enabled, I would get two instances...

I dont know much about KDE so this may be irrelevant. But can you remove it from the autostart applications in KDE, and see if it starts just one instance?
 
Old 11-08-2011, 12:47 PM   #3
firekage
Member
 
Registered: May 2011
Location: Poland
Distribution: Slackware, Ubuntu, Arch
Posts: 272

Original Poster
Rep: Reputation: 7
There is something like this:

http://imageshack.us/f/259/cairodockautostart.jpg/

But i think that when i switch off it from the autostart than it won't start at all. In Cairo there is no option that is responsible for autostart.
 
Old 11-08-2011, 01:17 PM   #4
trademark91
Member
 
Registered: Sep 2009
Distribution: Slackware -current x64
Posts: 372

Rep: Reputation: 72
you could try manually adding the command to your .xinitrc instead of the kde autostart, so it starts with X instead of kde.

put a sleep function so kde's stuff starts first, so something like:
Code:
sleep 30 && glx-dock &
 
Old 11-09-2011, 09:24 AM   #5
firekage
Member
 
Registered: May 2011
Location: Poland
Distribution: Slackware, Ubuntu, Arch
Posts: 272

Original Poster
Rep: Reputation: 7
Quote:
Originally Posted by trademark91 View Post
you could try manually adding the command to your .xinitrc instead of the kde autostart, so it starts with X instead of kde.

put a sleep function so kde's stuff starts first, so something like:
Code:
sleep 30 && glx-dock &
1.I don't understand. Why start X instead KDE? (i use qt-graphicssystem.sh from qt libraries for switching to Raster from default X11/Renderer.
2. If i put sleep what would it do? First would start kde stuff than kde?


BTW - as i said earlier, if i switched off Cairo from K-system settings-system start and off-session menager, than cairo doesen't start at all.

3. Where to put thing in tag code, here is my .xinitrc

Code:
#!/bin/sh
# $XConsortium: xinitrc.cpp,v 1.4 91/08/22 11:41:34 rws Exp $

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then
    xrdb -merge $sysresources
fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f $userresources ]; then
    xrdb -merge $userresources
fi

if [ -f $usermodmap ]; then
    xmodmap $usermodmap
fi

# Start the window manager:
if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
    ck-launch-session startkde
else
    startkde
fi

Last edited by firekage; 11-09-2011 at 09:27 AM.
 
Old 11-12-2011, 06:03 AM   #6
firekage
Member
 
Registered: May 2011
Location: Poland
Distribution: Slackware, Ubuntu, Arch
Posts: 272

Original Poster
Rep: Reputation: 7
I tried several things, all of them didn't bring any solution.

When i switch off autostart from KDE settings, and log in with old session than Cairo must be run from KDE apps, and of course starts twice.

When i enable autostart in KDE, choose blank session and restart computer than Cairo starts with system...but twice.


I don't have any new ideas. I tried to delete cache, delete cairo settings from ~/.config/autostart but it didn't help at all.


It always start twice. Can Yopu help me?
 
Old 11-12-2011, 08:54 AM   #7
R3V0LV3R
Member
 
Registered: Nov 2011
Posts: 78

Rep: Reputation: 11
Don't select the option to launch Cairo Dock at startup.

If you open it and just don't quit Cairo Dock when shutting down/rebooting/logging out, it will start up automatically.... and only once.

At least that's the case here.
 
Old 11-12-2011, 11:20 AM   #8
firekage
Member
 
Registered: May 2011
Location: Poland
Distribution: Slackware, Ubuntu, Arch
Posts: 272

Original Poster
Rep: Reputation: 7
Quote:
Originally Posted by R3V0LV3R View Post
Don't select the option to launch Cairo Dock at startup.

If you open it and just don't quit Cairo Dock when shutting down/rebooting/logging out, it will start up automatically.... and only once.

At least that's the case here.

No, it won't. If i don't select the option to launch Cairo at startup (in KDE system settings), it won't start at next reeboot even when it was actually running. At next boot i have to start up it manually (when there is no selected auto launch at startup) ...but again it starts twice.

Last edited by firekage; 11-12-2011 at 11:21 AM.
 
Old 02-16-2013, 01:42 AM   #9
stamvas
LQ Newbie
 
Registered: Feb 2013
Posts: 1

Rep: Reputation: Disabled
two instances of cairo dock in xubuntu 12.04

how I solved it in my occasion
although in settings the save session was disabled in settings editor under the category xfce4-session>general the save on exit option was =true. So it has to be disabled.
so what I did was to:
1. leave one instance of cairo dock
2. make sure that the autosave save session on (session & start) up was UNchecked
3. run in terminal
Code:
rm ~/.cache/sessions/x*
to clean the cache
4. reboot

I hope this helps
 
Old 02-16-2013, 02:59 AM   #10
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: ElementaryOS, Ubuntu LTS, Slackware
Posts: 1,504

Rep: Reputation: 697Reputation: 697Reputation: 697Reputation: 697Reputation: 697Reputation: 697
Quote:
Originally Posted by firekage View Post
As mentioned above, i have problem with Cairo dock on Slackware 13.37.


Does anybody know why it start twice at boot? In K-system settings-system start and stop in session menager i choosed start blank session at startup, also i entered below cairo-dock -o in programs excluded form session menager and with it, and without it cairo starts twice.

Help :|
I've had a similar problem with Conky starting twice on Xfce.

Xfce remembers your session and tries to restore it on the next launch. What I ended up doing was simply invoking Conky manually the first time, and then on subsequent relaunches, Xfce remembers it and restores it.

You could try this with Cairo Dock. Simply launch it manually, and don't add it explicitly to the Autostart Programs in the Session Settings.
 
Old 02-17-2013, 06:00 AM   #11
firekage
Member
 
Registered: May 2011
Location: Poland
Distribution: Slackware, Ubuntu, Arch
Posts: 272

Original Poster
Rep: Reputation: 7
Thanks. I switched to Slackware 14, and Ubuntu 12.10. I have to check this again on 13.37.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: GLX-Dock (Cairo Dock) 2.3 Beta Gets MintMenu, Cardapio Applets, Many Other Improvements LXer Syndicated Linux News 0 01-23-2011 12:41 PM
LXer: Cairo Dock 2.0.0 is Here (Linux Dock Menu)! LXer Syndicated Linux News 0 05-12-2009 01:20 AM
Why my cairo-dock no 3D plane?? LinuxNewbie999 Linux - Newbie 3 09-14-2008 03:55 AM
LXer: Cairo-Dock - Desktop dock for openSUSE Linux LXer Syndicated Linux News 0 08-07-2008 08:20 AM
cairo-dock, gnome-dock, kiba-dock?? LinuxNewbie999 *BSD 0 04-03-2008 09:16 AM


All times are GMT -5. The time now is 02:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration