LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Cairo dock starts twice (http://www.linuxquestions.org/questions/slackware-14/cairo-dock-starts-twice-912331/)

firekage 11-07-2011 08:48 AM

Cairo dock starts twice
 
As mentioned above, i have problem with Cairo dock on Slackware 13.37.


Does anybody know why it start twice at boot? In K-system settings-system start and stop in session menager i choosed start blank session at startup, also i entered below cairo-dock -o in programs excluded form session menager and with it, and without it cairo starts twice.

Help :|

fukawi1 11-08-2011 12:23 AM

I have had similar problems with FC15 XFCE and cairo dock..

The xfce application autostart configuration was set to start both cairo-dock, and GLX-Dock.

I also seem to recall the "auto start" option in cairo dock, wouldn't show up in the xfce startup app's. So if both were enabled, I would get two instances...

I dont know much about KDE so this may be irrelevant. But can you remove it from the autostart applications in KDE, and see if it starts just one instance?

firekage 11-08-2011 12:47 PM

There is something like this:

http://imageshack.us/f/259/cairodockautostart.jpg/

But i think that when i switch off it from the autostart than it won't start at all. In Cairo there is no option that is responsible for autostart.

trademark91 11-08-2011 01:17 PM

you could try manually adding the command to your .xinitrc instead of the kde autostart, so it starts with X instead of kde.

put a sleep function so kde's stuff starts first, so something like:
Code:

sleep 30 && glx-dock &

firekage 11-09-2011 09:24 AM

Quote:

Originally Posted by trademark91 (Post 4519060)
you could try manually adding the command to your .xinitrc instead of the kde autostart, so it starts with X instead of kde.

put a sleep function so kde's stuff starts first, so something like:
Code:

sleep 30 && glx-dock &

1.I don't understand. Why start X instead KDE? (i use qt-graphicssystem.sh from qt libraries for switching to Raster from default X11/Renderer.
2. If i put sleep what would it do? First would start kde stuff than kde?


BTW - as i said earlier, if i switched off Cairo from K-system settings-system start and off-session menager, than cairo doesen't start at all.

3. Where to put thing in tag code, here is my .xinitrc

Code:

#!/bin/sh
# $XConsortium: xinitrc.cpp,v 1.4 91/08/22 11:41:34 rws Exp $

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then
    xrdb -merge $sysresources
fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f $userresources ]; then
    xrdb -merge $userresources
fi

if [ -f $usermodmap ]; then
    xmodmap $usermodmap
fi

# Start the window manager:
if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
    ck-launch-session startkde
else
    startkde
fi


firekage 11-12-2011 06:03 AM

I tried several things, all of them didn't bring any solution.

When i switch off autostart from KDE settings, and log in with old session than Cairo must be run from KDE apps, and of course starts twice.

When i enable autostart in KDE, choose blank session and restart computer than Cairo starts with system...but twice.


I don't have any new ideas. I tried to delete cache, delete cairo settings from ~/.config/autostart but it didn't help at all.


It always start twice. Can Yopu help me?

R3V0LV3R 11-12-2011 08:54 AM

Don't select the option to launch Cairo Dock at startup.

If you open it and just don't quit Cairo Dock when shutting down/rebooting/logging out, it will start up automatically.... and only once.

At least that's the case here.

firekage 11-12-2011 11:20 AM

Quote:

Originally Posted by R3V0LV3R (Post 4522228)
Don't select the option to launch Cairo Dock at startup.

If you open it and just don't quit Cairo Dock when shutting down/rebooting/logging out, it will start up automatically.... and only once.

At least that's the case here.


No, it won't. If i don't select the option to launch Cairo at startup (in KDE system settings), it won't start at next reeboot even when it was actually running. At next boot i have to start up it manually (when there is no selected auto launch at startup) ...but again it starts twice.

stamvas 02-16-2013 01:42 AM

two instances of cairo dock in xubuntu 12.04
 
how I solved it in my occasion
although in settings the save session was disabled in settings editor under the category xfce4-session>general the save on exit option was =true. So it has to be disabled.
so what I did was to:
1. leave one instance of cairo dock
2. make sure that the autosave save session on (session & start) up was UNchecked
3. run in terminal
Code:

rm ~/.cache/sessions/x*
to clean the cache
4. reboot

I hope this helps

kikinovak 02-16-2013 02:59 AM

Quote:

Originally Posted by firekage (Post 4518037)
As mentioned above, i have problem with Cairo dock on Slackware 13.37.


Does anybody know why it start twice at boot? In K-system settings-system start and stop in session menager i choosed start blank session at startup, also i entered below cairo-dock -o in programs excluded form session menager and with it, and without it cairo starts twice.

Help :|

I've had a similar problem with Conky starting twice on Xfce.

Xfce remembers your session and tries to restore it on the next launch. What I ended up doing was simply invoking Conky manually the first time, and then on subsequent relaunches, Xfce remembers it and restores it.

You could try this with Cairo Dock. Simply launch it manually, and don't add it explicitly to the Autostart Programs in the Session Settings.

firekage 02-17-2013 06:00 AM

Thanks. I switched to Slackware 14, and Ubuntu 12.10. I have to check this again on 13.37.


All times are GMT -5. The time now is 01:52 PM.