Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 03-19-2014, 03:56 PM   #1
LQ Newbie
Registered: Sep 2012
Posts: 15

Rep: Reputation: Disabled
Building chromaprint and opencv requires older version libx264

Hi folks,
I'm trying to build a couple of packets as chromaprint and opencv. I've got an error that packets requires but in my system already present Making symlink to doesn't help.
My system is Slackware 86_64 14.1 with multilib from Alien Bob.
Please, help me to solve this problem.
Old 03-19-2014, 10:04 PM   #2
Senior Member
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,933

Rep: Reputation: 608Reputation: 608Reputation: 608Reputation: 608Reputation: 608Reputation: 608
i have just tested building this package with the dep stock on SBo and they all built fine
MD5SUM check for chromaprint-1.1.tar.gz ... OK
Building package chromaprint-1.1-x86_64-1_SBo.tgz ... OK
Installing package chromaprint-1.1-x86_64-1_SBo.tgz ... OK

It's not multilib, but i guess that shouldn't be an issue
Old 03-20-2014, 05:14 AM   #3
Alien Bob
Slackware Contributor
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,849

Rep: Reputation: Disabled
Originally Posted by Chelyuk View Post
I've got an error that packets requires but in my system already present
If you are getting errors like that, you are not compiling from source but instead using a binary which has been compiled in the presence of that older version of x264.
Try re-compiling your program(s) from source. That should fix the library version issue.

Old 03-24-2014, 02:45 PM   #4
LQ Newbie
Registered: Sep 2012
Posts: 15

Original Poster
Rep: Reputation: Disabled
Very strange, because x264 was installed via sbopkg from and chromaprint with opencv also from the same repository.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Problem building openCV 2.4.0 on 13.37 Z038 Slackware 14 12-24-2012 11:56 AM
firefox crash report says requires glx version older than 1.3 EDDY1 Linux - Newbie 1 07-11-2012 02:35 AM
How to find older versions of BobNutfield Slackware 16 03-21-2012 08:13 PM
Older software version requires Python 2.5 to run. cov Linux - Software 11 01-28-2012 12:01 PM
building older version of kernel on newer version machine chakradhar.nannuri Linux - Newbie 4 01-25-2011 10:46 PM

All times are GMT -5. The time now is 09:57 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration