LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Building chromaprint and opencv requires older version libx264 (http://www.linuxquestions.org/questions/slackware-14/building-chromaprint-and-opencv-requires-older-version-libx264-4175498774/)

Chelyuk 03-19-2014 03:56 PM

Building chromaprint and opencv requires older version libx264
 
Hi folks,
I'm trying to build a couple of packets as chromaprint and opencv. I've got an error that packets requires libx264.so.125 but in my system already present libx264.so.138. Making symlink to libx264.so.125 doesn't help.
My system is Slackware 86_64 14.1 with multilib from Alien Bob.
Please, help me to solve this problem.

willysr 03-19-2014 10:04 PM

i have just tested building this package with the dep stock on SBo and they all built fine
chromaprint:
MD5SUM check for chromaprint-1.1.tar.gz ... OK
Building package chromaprint-1.1-x86_64-1_SBo.tgz ... OK
Installing package chromaprint-1.1-x86_64-1_SBo.tgz ... OK

It's not multilib, but i guess that shouldn't be an issue

Alien Bob 03-20-2014 05:14 AM

Quote:

Originally Posted by Chelyuk (Post 5137612)
I've got an error that packets requires libx264.so.125 but in my system already present libx264.so.138

If you are getting errors like that, you are not compiling from source but instead using a binary which has been compiled in the presence of that older version of x264.
Try re-compiling your program(s) from source. That should fix the library version issue.

Eric

Chelyuk 03-24-2014 02:45 PM

Very strange, because x264 was installed via sbopkg from slackbuilds.org and chromaprint with opencv also from the same repository.


All times are GMT -5. The time now is 05:37 AM.