-   Slackware (
-   -   "--build" option to configure causes error in wxwidgets detection (

Ilgar 12-13-2012 05:02 PM

"--build" option to configure causes error in wxwidgets detection
Hi all,

I'm using Slackware 64 14.0 on my office computer. This is a system upgraded from 13.37. I need to use the wxwidgets-based "wxt" terminal in gnuplot. The official gnuplot Slackware package does not support it, as wxwidgets is not included in the distribution. I built and installed wxGTK from, then tried to recompile gnuplot using the official Slackbuild.

As far as I remember I didn't have trouble doing this in 13.37, but this time the configure script failed to detect wxGTK. The reason turned out to be the configure option


(which, in my case, reads "x86_64-slackware-linux", of course). I can't get configure to detect wxGTK unless I remove this option.

Could those who know the internals of these things enlighten me about what's going on in here? As I said, something appears to have changed in 14.0, as I remember doing the very same thing without such an issue. Could this be a problem with the wxwidgets scipts?

gnashley 12-14-2012 01:12 AM

The '--build' option is superfluous, so simply leave it out.

Ilgar 12-14-2012 03:13 AM

That was my impression, too, but I just wanted to understand why using it creates an error (and why this didn't happen before).

All times are GMT -5. The time now is 06:58 AM.