LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 02-14-2010, 03:25 AM   #1
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Rep: Reputation: 201Reputation: 201Reputation: 201
Build fails in current: gtkimageview-1.6.4


I can not get gtkimageview-1.6.4 to build in current. It fails with a number of errors of type:
Code:
gtkanimview.c: In function 'gtk_anim_view_get_type':
/usr/include/glib-2.0/glib/gthread.h:339: error: dereferencing pointer 'value_location.1' does break strict-aliasing rules
/usr/include/glib-2.0/glib/gthread.h:339: note: initialized from here
 
Old 02-14-2010, 06:40 AM   #2
XGizzmo
Member
 
Registered: Mar 2007
Distribution: Slackware
Posts: 264

Rep: Reputation: 68
Pulled from gentoo's ebuild apply these two seds and run autoreconf. Hope it helps.

Code:
# Prevent excessive build failures due to gcc changes
  sed -e '/CFLAGS/s/-Werror //g' -i configure.in

# Prevent excessive build failures due to glib/gtk changes
  sed '/DEPRECATED_FLAGS/d' -i configure.in
 
1 members found this post helpful.
Old 02-14-2010, 11:18 AM   #3
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Original Poster
Rep: Reputation: 201Reputation: 201Reputation: 201
That worked perfectly! Thank You.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
inkscape fails on current... imitis Slackware 6 04-07-2010 11:08 AM
What changes must be made in a slackBuild from 11.x To build for Slackware64 current? Alexvader Slackware 5 12-30-2009 02:38 PM
[SOLVED] Cannot build apcups on slack64-current tux_dude Slackware 5 12-15-2009 07:42 AM
Opera 10 QT4 build broken on -current (by qt-4.5.3) firebird Slackware 1 11-06-2009 03:16 AM
self build rpm fails with missing dependencies on build host zhjim Linux - Software 1 09-24-2009 09:47 AM


All times are GMT -5. The time now is 06:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration