LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-12-2004, 05:21 PM   #1
KingofBLASH
Member
 
Registered: Sep 2003
Distribution: Just upgraded to Slackware 10.0
Posts: 91

Rep: Reputation: 15
Bug? USB Keyboard and Mouse Stop Working


Sometimes I'll accidentally knock my USB keyboard or Mouse out of their respective ports. Usually this doesn't cause a problem if I plug them back in, but sometimes, plugging them back in will disable them altogether.

I think this is a bug because I double checked my system logs, and it seems that the USB daemon will sometimes assign them a different address then the one it originally had -- but not all the time. This is why, I assume, things stop working.

Before I report this as a bug, I was wondering if anyone has had previous experience with this, or knows how to fix it. My logs are below:

Mar 8 13:17:03 syr-24-58-10-27 kernel: usb.c: USB disconnect on device 00:07.3-2 address 3
Mar 8 13:17:03 syr-24-58-10-27 kernel: hub.c: new USB device 00:07.3-2, assigned address 4
Mar 8 13:17:13 syr-24-58-10-27 kernel: input: USB HID v1.00 Mouse [Logitech Inc. iFeel Mouse ] \
on usb1:4.0
Mar 8 13:17:13 syr-24-58-10-27 kernel: usb.c: USB disconnect on device 00:07.3-2 address 4
Mar 8 13:17:14 syr-24-58-10-27 kernel: hub.c: new USB device 00:07.3-2, assigned address 5
Mar 8 13:17:17 syr-24-58-10-27 usb.agent[27871]: missing kernel or user mode driver usbmouse
Mar 8 13:17:17 syr-24-58-10-27 usb.agent[27871]: missing kernel or user mode driver hid
Mar 8 13:17:17 syr-24-58-10-27 usb.agent[27871]: missing kernel or user mode driver mousedev
Mar 8 13:17:20 syr-24-58-10-27 kernel: hub.c: new USB device 00:07.3-2, assigned address 6
Mar 8 13:17:27 syr-24-58-10-27 kernel: hub.c: new USB device 00:07.3-2, assigned address 7
Mar 8 13:17:32 syr-24-58-10-27 kernel: hub.c: new USB device 00:07.3-2, assigned address 8
Mar 8 13:18:06 syr-24-58-10-27 kernel: hub.c: new USB device 00:07.3-2, assigned address 9
Mar 8 13:18:12 syr-24-58-10-27 kernel: usb.c: USB disconnect on device 00:07.3-1 address 2
Mar 8 13:18:12 syr-24-58-10-27 kernel: hub.c: new USB device 00:07.3-1, assigned address 10
Mar 8 13:18:17 syr-24-58-10-27 kernel: hub.c: new USB device 00:07.3-1, assigned address 11
Mar 8 13:18:43 syr-24-58-10-27 kernel: hub.c: new USB device 00:07.3-1, assigned address 12

Thanks in advance,

Dan
 
Old 03-13-2004, 11:02 PM   #2
moresun
LQ Newbie
 
Registered: Aug 2003
Location: Austira
Distribution: kubuntu 7.04
Posts: 15

Rep: Reputation: 0
You are not alone

I think there is a problem in mkd10 because more people have a simelar problem, my usb mouse is also dead since I installed mkd10.

I know this messeage doesn´t help you but, It makes bad promotion and that helps to get faster a update or patch.

moresun
 
Old 04-09-2004, 10:14 AM   #3
fanniya
LQ Newbie
 
Registered: Apr 2004
Posts: 1

Rep: Reputation: 0
hi, I am facing this problem toowith my keyboard in addition that it sometimes stuck on the last button i was using and tpying it indefinetly.

any help is appreciated.

(i have already checked for virus i am clean)
 
Old 04-09-2004, 12:04 PM   #4
KingofBLASH
Member
 
Registered: Sep 2003
Distribution: Just upgraded to Slackware 10.0
Posts: 91

Original Poster
Rep: Reputation: 15
I have come to the conclusion that there is something wrong with the way the keyboard and/or mouse are set up. I have the same exact problems on Windows if I don't install the Logitech specific drivers. I really want to know why I can't just buy a USB keyboard and just a keyboard
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard and Mouse randomly stop working link470 Linux - Hardware 3 08-03-2005 07:12 PM
USB keyboard, mouse, ethernet stop working after reinstall of FC2 lagger Fedora 0 06-14-2004 07:36 AM
keyboard and mouse suddenly stop working TexasDex Linux - Hardware 2 06-04-2004 11:26 PM
Mouse and Keyboard stop working when X loads BrigitteT Linux - General 7 04-12-2004 01:21 AM
mouse & keyboard stop working! shycalais Linux - Hardware 6 03-19-2004 07:52 AM


All times are GMT -5. The time now is 12:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration