LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Bug in hdparm 0.29 (Slackware-Current) (http://www.linuxquestions.org/questions/slackware-14/bug-in-hdparm-0-29-slackware-current-837706/)

piratesmack 10-12-2010 11:39 PM

Bug in hdparm 0.29 (Slackware-Current)
 
Hi

I upgraded from 13.1 to Current today, and now when I run:
Code:

# hdparm -B 254 /dev/sda
I get this error:
Code:

HDIO_DRV_CMD failed: input/output error
I don't know if this error message is serious or not, but upgrading hdparm to version 9.33 seems to fix it.

edit:
found this http://sourceforge.net/tracker/index...32&atid=736682

prayag_pjs 10-13-2010 12:08 AM

The SSDs pretend to be IDE HDDs but doesn't support all the features of most HDD (in this case power management).I think this is normal and wont effect anything.

piratesmack 10-13-2010 12:29 AM

Thanks, but it's not an SSD.
Also, I don't see this error if I downgrade to the hdparm from Slackware 13.1 or upgrade to the latest version.

prayag_pjs 10-13-2010 12:48 AM

try if this link has some solution

http://www.linuxquestions.org/questi...laptop-824672/

GazL 10-13-2010 04:25 AM

Thanks for posting piratesmack. I'm not hitting the problem right now, but I don't like having known issues lurking so I think I'll upgrade that package too.

GazL 10-14-2010 05:46 AM

I see 9.33 was in the current changelog today. :)

piratesmack 10-14-2010 03:03 PM

Quote:

Originally Posted by GazL (Post 4126989)
I see 9.33 was in the current changelog today. :)

Hmm weird.
Slackware64 got 9.33, but Slackware got 9.32.

The bug seems to be fixed in both, though.


All times are GMT -5. The time now is 09:25 AM.