LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-15-2009, 01:27 PM   #1
TSquaredF
Member
 
Registered: Dec 2005
Location: "The South Coast of Texas"
Distribution: Slackware64-current
Posts: 490
Blog Entries: 1

Rep: Reputation: 55
"Browser" problems in Thunderbird 3


Per this thread I installed Thunderbird 3 into my Slackware64-13 desktop box. Most things are working & I'm fairly happy with it, but for one bump. Clicking anything that should open a browser window, does precisely nothing. This includes a link within an email and pushing F1 or doing menu actions to bring up "Help". Note that installing the Thunderbrowser extension allows Thunderbird to display links, but no help there with "Help". Anyone have any ideas?
Regards,
Bill
 
Old 12-15-2009, 02:11 PM   #2
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,378

Rep: Reputation: 170Reputation: 170
The first time I clicked a link, it asked me what to do. I pointed TB to FF and selected "Always do this" or something similar, then hit ok. Links open in FF all the time now.
 
Old 12-15-2009, 02:57 PM   #3
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948
I don't know if anything's changed in v.3, but should be able to open up the "settings > advanced > config editor" (i.e. about:config), and manually set the network.protocol-handler.app.[http|https] settings to the path of your browser of choice.
 
Old 12-17-2009, 06:51 PM   #4
TSquaredF
Member
 
Registered: Dec 2005
Location: "The South Coast of Texas"
Distribution: Slackware64-current
Posts: 490
Blog Entries: 1

Original Poster
Rep: Reputation: 55
Quote:
Originally Posted by David the H. View Post
I don't know if anything's changed in v.3, but should be able to open up the "settings > advanced > config editor" (i.e. about:config), and manually set the network.protocol-handler.app.[http|https] settings to the path of your browser of choice.
Thanks. I've tried your suggestion, with no help. Also a much older thread suggested putting the same things in "prefs.js". That didn't work, either. It is all mute, however, because yesterday my wife so was very ticked at not being able to open a link in TB, that I just downgraded to the stock TB. I appreciate the efforts.
Regards,
Bill
 
Old 12-18-2009, 01:47 AM   #5
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,378

Rep: Reputation: 170Reputation: 170
Well crapola! I just upgraded to FF-3.5.6, and now I can't open links with TB. Nothing seems to work and I can't find anything to help with this either. I was using FF-3.5.5. It may have something to do with the new version.

Oh well, its been a rotten day anyhow. Time for bed!
 
Old 12-18-2009, 12:12 PM   #6
TSquaredF
Member
 
Registered: Dec 2005
Location: "The South Coast of Texas"
Distribution: Slackware64-current
Posts: 490
Blog Entries: 1

Original Poster
Rep: Reputation: 55
I'm on FF 3.5.5, maybe upgrading will help me!
Regards,
Bill
 
Old 12-18-2009, 12:27 PM   #7
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,378

Rep: Reputation: 170Reputation: 170
I just now put it all back together on TB - back to 2.0.0.23 that is. I had screwed too much with about:config in TB and hosed all my email stuff by erasing prefs.js. Thankfully, I had a backup of an old dot Thunderbird folder with a good prefs.js file. So I renamed the current .thunderbird folder, started TB and let it create a new folder, then deleted everything out of it and copied over the contents of the previous folder. Then I deleted prefs.js, and copied over the older one from last year. All is back to the beginning now. I now open links in TB to FF once again.

Now I'm going to upgrade again to TB-3x and see what happens.

I am such a glutton for punishment and torture.
 
Old 12-18-2009, 12:48 PM   #8
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,378

Rep: Reputation: 170Reputation: 170
TB-3x can can wait. After repairing the damage back to the original, I upgraded TB again. It will not open links in FF, and I did not attempt to fix it. I just "upgraded" back to 2x.
 
Old 12-18-2009, 01:42 PM   #9
Laodiceans
Member
 
Registered: Jan 2006
Distribution: Slackware
Posts: 188

Rep: Reputation: 18
I had the same problem in two diferent machines. On one the file pref.js had this entry:

Code:
user_pref("network.protocol-handler.external.ftp", "/usr/bin/firefox");
user_pref("network.protocol-handler.external.http", "/usr/bin/firefox");
and worked fine.

And on another I had this:

Code:
user_pref("network.protocol-handler.external.ftp", );
user_pref("network.protocol-handler.external.http",);
This last one never open the links. To work or delete the both lines or put the path "/usr/bin/firefox" after the comma.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba "Master Browser" problems rchapman Linux - Networking 2 12-15-2006 01:46 AM
Problems configuring "xorg.conf" with "ATI FGLRX" BlueSpirit Slackware 3 09-16-2006 02:01 PM
Common problems explained: "kernel panic - not syncing", "unable to mount..." sundialsvcs Linux - Newbie 2 03-01-2006 12:17 PM
why iam getting problems like "...too many files opened" or "segmentation fault" naren_0101bits Linux - Newbie 2 07-19-2004 12:20 PM
anging "Protocol" option to "IMPS/2" in XF86Config-4 causes problems zstingx Linux - General 2 10-27-2003 09:47 AM


All times are GMT -5. The time now is 06:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration