LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-22-2003, 01:20 PM   #1
MONA
LQ Newbie
 
Registered: Dec 2002
Location: LaSalle IL
Distribution: Red Hat
Posts: 16

Rep: Reputation: 0
Question Browser only works on root account


Hi last weekend we sucessfully installed Slackware 9.0 with the offical Slackware linux cd set .We really like the distro and we had no real problems with the install .We set-up two user account according to instructions in the Slackware linux Essentials . We configured our modem with pppsetup it works
and connects to the ISP correctly,but we have a real wierd problem .We can only use the browsers when we login as root .When we use the browsers on a user account the browsers try to acesses web pages but for some reason
they are unable to do so. We have tried every browser on the KDE desktop
but to no avail.We really like the distro but if the only way we can go on the inter-net is as root we`ll have to change distros So I hope someone can help us out there


 
Old 04-22-2003, 01:30 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,536

Rep: Reputation: 148Reputation: 148
I guess the problem is that you can only access Internet when you're root (run pppd alone or using any frontend).
A simple (but nor very safe) workaround: make pppd suid root. How to do it? You need to become root, now find pppd (usually /sbin/pppd or /usr/sbin/pppd), look into attributes of the file, find one called "et user ID on exacution" (or similar meaning) and set it.If you're using Midnight Commander, find the file, F9, File->chmod, set first option.
 
Old 04-23-2003, 01:44 PM   #3
MONA
LQ Newbie
 
Registered: Dec 2002
Location: LaSalle IL
Distribution: Red Hat
Posts: 16

Original Poster
Rep: Reputation: 0
Just got your answer to my post I will try it tomorrow and let you know how it went. Thanks again for your advice
 
Old 04-23-2003, 02:13 PM   #4
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,536

Rep: Reputation: 148Reputation: 148
No problem. Waiting for your answer. I hope you'll make it working.
 
Old 04-24-2003, 12:05 PM   #5
MONA
LQ Newbie
 
Registered: Dec 2002
Location: LaSalle IL
Distribution: Red Hat
Posts: 16

Original Poster
Rep: Reputation: 0
Well I tried your idea. I first login as root and used Kpp.(Kpp daemon died exit status 1 darkstar pppd (692) tcsetatrib) So I thought your advice was probably on the right track. I went to /usr/sbin/pppd and checked the set usr ID flag and logout and rebooted the computer. I login under a user account and used
Kpp it worked but I still can`t get the browsers to connect to the inter-net .I went to the terminal and under su got ppp-go and ppp-off to work .I then login as root and tried Kpp again and I was able to acess the inter-net on
mozilla just like before.
 
Old 04-25-2003, 04:12 PM   #6
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,536

Rep: Reputation: 148Reputation: 148
Now it's a matter of configuration. Run kppp as a user, then open a terminal, use su and then run 'route'. Look if there's line beginning with 'default' and if it has 'ppp0' in the last column (Iface). If it doesn't, add 'defaultroute' to kppp options.
 
Old 04-27-2003, 08:48 AM   #7
MONA
LQ Newbie
 
Registered: Dec 2002
Location: LaSalle IL
Distribution: Red Hat
Posts: 16

Original Poster
Rep: Reputation: 0
I tried what you told me to do. I already had the default route for ppp0 and it still dosn`t work. I`ve decided to install another distro and wait and reinstall
Slackware at a later date. I want to educate myself about Unix commands and
filesystems and Slackware in general before I try this again. I want to take this
opportunity, to thank you for taking the time to help me
 
Old 04-29-2003, 12:24 AM   #8
north49er
Member
 
Registered: Apr 2003
Location: 60.47'N lat
Distribution: fedora 15 x86_64
Posts: 156

Rep: Reputation: 18
Lightbulb

Try the following site if it helps, especially creating a kppp.allow file:

http://www.rock.lug.net/rockdocs/kppp.html
 
Old 04-30-2003, 11:03 AM   #9
MONA
LQ Newbie
 
Registered: Dec 2002
Location: LaSalle IL
Distribution: Red Hat
Posts: 16

Original Poster
Rep: Reputation: 0
Thanks alot for you suggestion.I reinstalled Slackware,made my default desktop KDE and now I appear to have no problem .The browsers all are able
to acess the inter-net. I never had a problem with acessing kppp or pppd but
if it dose come up I will check-out that web page Thank again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC4 xorg issue - 1280x1024 works for root, but not normal user account peitz11 Linux - Software 2 09-29-2005 08:40 AM
How do I retain the PATH in the root account even when I switch to root using su? thearchitect Linux - Newbie 1 08-13-2005 12:02 AM
Sound just works under root account thorax Linux - General 5 06-08-2004 02:20 PM
maestro sound only works with root account jagmandan Slackware 3 02-20-2003 10:44 AM
X works for all but my user account... needamiracle Linux - Software 3 08-07-2002 07:16 PM


All times are GMT -5. The time now is 05:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration