LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Broadcom 4310/4312 wireless problems (http://www.linuxquestions.org/questions/slackware-14/broadcom-4310-4312-wireless-problems-607954/)

KentS 12-19-2007 03:56 PM

Broadcom 4310/4312 wireless problems
 
I'm trying to get my wireless connection up and running.
The output from lspci on Ubuntu gives BCM4310 (it works here), while on Slackware it was BCM4312.
This is what I've tried:

Ndiswrapper:
Copied bcmwl5.inf and bcmwl5.sys from my windows partition.
Downloaded the latest ndiswrapper.
As root:
Code:

tar -xvzf ndiswrapper
cd ndiswrapper
make
make install

Added "blacklist bcm43xx" to /etc/modprobe.d/blacklist

Code:

ndiswrapper -i /something/bcmwl5.inf
ndiswrapper -m

ndiswrapper -l said that both driver and device was present.

reboot

Tried both "alias eth1 ndiswrapper" and "alias wlan0 ndiswrapper" (not at the same time) in /etc/modprobe.d/ndiswrapper

This didn't work.
Code:

ndiswrapper -e bcmwl5
make uninstall
make clean
make distclean

fwcutter:
Changed /etc/modprobe.d/blacklist to
Quote:

#blacklist bcm43xx
blacklist ndiswrapper
Downloaded wl_apsta-3.130.20.0.o and bcm43xx-fwcutter.
Code:

tar -jxvf bcm43xx-fwcutter.tar.bzip2 (or something like that
cd bcm43xx-fwcutter
make
make install
make installfw (gives an error: Missing file)
cd directory where the .o file is.
bcm43xx-fwcutter -w /lib/firmware wl_apsta-3.130.20.0.o

reboot

eth1 doesn't show up in any case.
Would really appreciate help with this one.

Edit:
modprobe ndiswrapper gives:
Quote:

FATAL: Module ndiswrapper not found

dan_slack 12-19-2007 05:08 PM

Read this old post of mine and it will work:
http://www.linuxquestions.org/questi...3/#post2947275

Good luck.

KentS 12-20-2007 05:43 AM

Thanks.

Apparently I was booting the wrong kernel. I needed to use the smp kernel. After that your recipe worked.


All times are GMT -5. The time now is 09:48 PM.