LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Brightness does not change in KDE after upgrade Slackware 14.1 RC2 (http://www.linuxquestions.org/questions/slackware-14/brightness-does-not-change-in-kde-after-upgrade-slackware-14-1-rc2-4175481696/)

ecoslacker 10-22-2013 01:10 AM

Brightness does not change in KDE after upgrade Slackware 14.1 RC2
 
Hi everybody, I update to Slackware 14.1 RC1 a few days ago (and to RC2 today) using slackpkg and since then there is an issue that i can't solve.
I use KDE and my energy settings do not apply, I mean the brightness of my laptop's screen (an Asus X401A) doesn't change from 100% under any condition (plugged in, low battery, etc).

It doesn't bothered me until now because I was using Windows the most of the time, but now I'm using Slackware more time at day an my eyes are burning.

I use grub and tried to edit the file /etc/default/grub to:

Code:

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=Linux acpi_backlight=vendor resume=/dev/sda9"
And then run:

Code:

grub-mkconfig -o /boot/grub/grub.cfg
But still not changing the brightness. Also my user is in the "power" group (I read in a thread that was a solution).

BTW: the Fn keys (Fn + F5 for brightness down and Fn + F6 for up) does not have any effect in the brightness.

Thanks in advance.

bartgymnast 10-22-2013 02:27 AM

Hi EcoSlacker,

you can try the following:

Xbacklight -dec 50

the 50 is percentage.

allend 10-22-2013 09:28 AM

The fundamental problem is broken hardware. The details and some other workarounds can be accessed from here. https://answers.launchpad.net/ubuntu/+question/237172

ecoslacker 10-25-2013 12:03 AM

I get nothing by running:

Code:

xbacklight -dec 50
But... I just try the solution in this page:

http://s-and-j.co.uk/wiki/index.php?...een_brightness

and edit the file
Code:

/etc/default/grub
with vim to add the option "quiet acpi_osi=":

Code:

GRUB_CMDLINE_LINUX_DEFAULT= "quiet acpi_osi="
Then run, as root:

Code:

grub-mkconfig -o /boot/grub/grub.cfg
Reboot and the brigthness changes now even with the Fn keys, but the Fn+F2 option (wifi) is now broken as expected.

Thanks!

allenlinux 11-10-2013 11:55 AM

you need to find how to put this at the booting using a script.
 
nano /sys/class/backlight/acpci_video0/brightness/

set the 8 to 4. then save.

thanks to me later | happy hacking |


All times are GMT -5. The time now is 12:47 PM.