LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-12-2009, 11:26 AM   #1
Jack128
Member
 
Registered: Feb 2009
Location: Germany
Distribution: Slackware64 Current
Posts: 90

Rep: Reputation: 22
Bootsplash Slackware 12.2 (Kernel 2.6.27.7-smp)


Good afternoon,
I trying to get Slackware 12.2 (Kernel 2.6.27.7-smp) to work with
some Bootsplash patch-files. I've found a patch-file for 2.6.27
and applied it, but after building the kernel, bootsplash won't
do anything. I've run a:
Code:
splash -s -u 0 /etc/bootsplash/themes/current/config/bootsplash-1024x768.cfg
With this error:
Code:
/proc/splash: No such file or directory
It seems that the patch wont work with this kernel, so
I tried a older patch-file but with the same success. =/

Can someone give me tutorial, or a working patch-file?
Or can someone advise my something on this topic?

Thanks in advanced!
Regards Jack.
 
Old 02-12-2009, 12:11 PM   #2
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,772

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
You have to put 'splash=silent' in your kernel boot params (lilo.conf or grub menu.lst) Be sure to re-run lilo if you are using it. You'll also need the bootsplash utils so that you can display the progress bar during bootup -you'll have to hand-edit your init scripts for that.
I think there is a HOWTO on the Slackware WIKI here at LQ.
 
Old 02-12-2009, 12:32 PM   #3
Jack128
Member
 
Registered: Feb 2009
Location: Germany
Distribution: Slackware64 Current
Posts: 90

Original Poster
Rep: Reputation: 22
Hello gnashley,

Quote:
Originally Posted by gnashley View Post
You have to put 'splash=silent' in your kernel boot params (lilo.conf or grub menu.lst) Be sure to re-run lilo if you are using it.
Yes, the parameter is set. I use grub.

Quote:
Originally Posted by gnashley View Post
You'll also need the bootsplash utils so that you can display the progress bar during bootup -you'll have to hand-edit your init scripts for that.
I compiled and installed "Bootsplash 3.1 - Utilities", and I
edited the rc.6, rc.S, rc.M files like the doc's samples.

Finally I made a initrd with:
Code:
splash -s -f /etc/bootsplash/themes/Linux/config/bootsplash-1024x768.cfg >> /boot/initrd.splash
And edited my grub menu.lst to load the initrd.
But until now no success. =( The strange thing is that I
can't run splash from terminal with:
Code:
splash -s -u 0 /etc/bootsplash/themes/current/config/bootsplash-1024x768.cfg
So I think my build kernel can't handle bootsplash.
But I patched it serval times without errors and build it.

Regards Jack.

Last edited by Jack128; 02-12-2009 at 12:33 PM.
 
Old 02-12-2009, 01:39 PM   #4
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,772

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
Oh, I see the problem now. Later 2.6 kernels need for the initrd to be a cpio archive. You need to follow the howto on the wiki as it tells how to do this. In effect, you need to create a normal initrd using mkinitrd(or manually) which contains the initrd.splash.
You can also search this forum as there are a couple of threads from a year ago, or so which tell how to do it.
Current 2.6 kernels don't work with a plain-file initrd like you have created.
 
Old 02-12-2009, 02:46 PM   #5
jong357
Senior Member
 
Registered: May 2003
Location: Columbus, OH
Distribution: DIYSlackware
Posts: 1,914

Rep: Reputation: 52
I use the splash utility to make my initrd's. Seems to work ok over here. Hate to state the obvious but a message about not finding /proc/splash usually means you didn't enable bootsplash in your kernel config. You may have patched it but you still need to select it.

http://www.jaguarlinux.com/files/3.png
2.6.28.x is even working tho I fully expect it to break any day.

Also, try starting off with verbose first just to make sure it works. Then try your hand at silent.

Last edited by jong357; 02-12-2009 at 02:49 PM.
 
Old 02-13-2009, 08:09 AM   #6
Jack128
Member
 
Registered: Feb 2009
Location: Germany
Distribution: Slackware64 Current
Posts: 90

Original Poster
Rep: Reputation: 22
Ok, I've made a cpio-archive and put the "initrd.bootsplash"
in the initrd-tree. Run a mkinitrd and I was getting a complete
initrd. So I tried that config, but the same. So, I followed
the Link from jong357 and looked around in the patches archive
from jaguarlinux, and found a patchfile too. Finally I set
the bootsplash option in the kernel-config. Then I tried that
but the same.

jong357, can you explain me a bit more specific what you have
done to get it working?

In the attachment is my kernel-config. Maybe I've
made a mistake, but I really don't believe that.

Regards Jack.

Last edited by Jack128; 12-22-2009 at 09:41 AM.
 
Old 02-13-2009, 08:26 AM   #7
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,334

Rep: Reputation: Disabled
I found this bootsplash howto, it may be of use to you: http://n00bsys0p.wordpress.com/2009/...tsplash-howto/

Eric
 
Old 02-13-2009, 09:04 AM   #8
Jack128
Member
 
Registered: Feb 2009
Location: Germany
Distribution: Slackware64 Current
Posts: 90

Original Poster
Rep: Reputation: 22
Thanks Eric, but I worked with this and other Howto's.
I'm making somewhere a mistake with
building the kernel right.

Regards Jack.
 
Old 02-13-2009, 09:08 AM   #9
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,334

Rep: Reputation: Disabled
Quote:
Originally Posted by Jack128 View Post
Thanks Eric, but I worked with this and other Howto's.
I'm making somewhere a mistake with
building the kernel right.

Regards Jack.
After applying the bootsplash patch and recompiling the kernel, did you actually copy the new kernel file to /boot , update /etc/lilo.conf (if needed) and run "lilo" so that after next reboot you are indeed running your patched kernel with splash support?
Your comment of
Code:
/proc/splash: No such file or directory
may indicate that you are not running your new, recompiled kernel.

Eric
 
Old 02-13-2009, 09:49 AM   #10
Jack128
Member
 
Registered: Feb 2009
Location: Germany
Distribution: Slackware64 Current
Posts: 90

Original Poster
Rep: Reputation: 22
Thanks for your help guy's =)
I've solved it finally! My Kernel worked fine,
but I've over redden this here:

http://www.bootsplash.org/Kernel
Quote:
You need to have a working framebuffer device with 16bit
colordepth, preferably vesafb (i.e. vga=0x317 for 1024x768)
I've allways tried it with 24bit not 16bit.

---------------------------------->

Ok here is a complete making of:

1.) Download bootsplash-3.1.tar.bz2:
> http://ftp.sh.cvut.cz/MIRRORS/rock/ROCK-2.1/b/

2.) Download the kernel-patch for your kernel:
> http://www.jaguarlinux.com/pub/patches/bootsplash/

3.) Open your kernel-source (/usr/src/linux/) in a Terminal:
> cd /usr/src/linux/

4.) Patch the kernel-source:
> patch -p1 < /path/to/bootsplash*.diff

5.) Change the settings of the config:
> make menuconfig (or) make xconfig

6.) Go to: "Device Drivers --->, Graphics support --->"
and disable "Bootup logo --->" and enable under
"Bootsplash configuration --->" the "Bootup splash screen" option.

After that check in "Device Drivers --->, Block devices --->"
the "RAM block device support". Then save the config.

7.) Build the kernel:
> make

8.) Copy the new kernel to /boot with the System.map and the
config.

9.) Go to /path/of/bootsplash-3.1/Utilities
and Build the splash utility:
> make splash

After that copy the new splash into /sbin.

10.) Go to /boot and make a new initrd-tree:
> mkinitrd -c -k 2.6.27.7-smp -m ext3 -f ext3 -r /dev/hda1

Check the mkinitrd man for the right use.

11.) Make a bootsplash initrd-file:
> splash -s -f /etc/bootsplash/themes/YOUR_THEME/config/bootsplash-1024x768.cfg >> /boot/initrd-tree/bootsplash

12.) Build the initrd-tree with mkinitrd:
> mkinitrd

You will get a brand new initrd.gz in your /boot!

13.) Edit your bootloader config to use the initrd.gz and
these kernel-paramters:

> "splash=silent vga=0x317" (or)
> "splash=verbose vga=0x317"

Thats all. If you want a other resolution look here
And keep a eye on the 16bit row!

Now you can boot, and hopefully see your bootsplash!

Regards Jack.

Last edited by Jack128; 02-13-2009 at 10:09 AM.
 
Old 02-13-2009, 11:17 AM   #11
jong357
Senior Member
 
Registered: May 2003
Location: Columbus, OH
Distribution: DIYSlackware
Posts: 1,914

Rep: Reputation: 52
Quote:
Originally Posted by Jack128 View Post
I've solved it finally!

I've allways tried it with 24bit not 16bit.
That was going to be my next question. What's your lilo or grub conf look like... Glad it's working.

Patches > 2.6.26 are just rediffed BTW.... Bootsplash is officially dead so don't get too comfortable with it.
 
Old 02-13-2009, 02:32 PM   #12
Jack128
Member
 
Registered: Feb 2009
Location: Germany
Distribution: Slackware64 Current
Posts: 90

Original Poster
Rep: Reputation: 22
Hello jong357,

Quote:
Originally Posted by jong357 View Post
That was going to be my next
question. What's your lilo or grub conf look like...
Glad it's working.
Code:
title Slackware 12.2
   kernel (hd0,5)/boot/vmlinuz root=/dev/hda6 ro splash=silent vga=0x317
   initrd (hd0,5)/boot/initrd.gz
Quote:
Originally Posted by jong357 View Post
Bootsplash is officially dead
so don't get too comfortable with it.
I know, but as long there is SuSE, than will be a
solution for this task I think.

Hope this helps.
Regards Jack.
 
  


Reply

Tags
bootsplash


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware SMP kernel on Dell PE 2850 bobmac010 Linux - Kernel 2 02-06-2007 04:15 PM
Hyperthread server goes to kernel panic with SMP kernic, boots ok with non SMP kernel abefroman Linux - Kernel 1 09-15-2006 06:43 PM
Configuring a Slackware 10.1 SMP Kernel Slack1_more Slackware 9 06-06-2005 04:02 AM
SMP Kernel Packages for Slackware ? Grunthos Slackware 15 04-03-2005 12:56 AM
Bootsplash - Slackware - Kernel 2.6.6 - NOT working pat99 Linux - Software 3 06-23-2004 01:29 PM


All times are GMT -5. The time now is 04:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration