LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 08-21-2009, 04:08 PM   #1
Bller
Member
 
Registered: Aug 2009
Location: Tulcea, Romania
Distribution: Slackware 13.0
Posts: 199

Rep: Reputation: 15
Bootloader time


Another thing i would like to ask, how do i change the wait time untill the bootloader screen loads slack?, now i have like 1minute 30 to wait for slack to start or manually press enter to start. I want to change that 1 minute 30 with like 5 10 secconds.
 
Old 08-21-2009, 04:10 PM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,773

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Edit /etc/lilo.conf and change the timeout value. Don't forget to run lilo afterwards.

Cheers
 
Old 08-21-2009, 04:15 PM   #3
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,010

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
Code:
# Timeout before the first entry boots.
# This is given in tenths of a second, so 600 for every minute:
timeout = 1200
Here's a snippet of my lilo.conf, so if I wanted my timeout to be 60 seconds, the timeout = 600.
 
Old 08-21-2009, 04:58 PM   #4
Bller
Member
 
Registered: Aug 2009
Location: Tulcea, Romania
Distribution: Slackware 13.0
Posts: 199

Original Poster
Rep: Reputation: 15
Ok so i edited it to be like this :
Code:
# Timeout before the first entry boots.
# This is given in tenths of a second, so 600 for every minute:
timeout="150" ( i wanted like 15 seconds wait time )
and at the end :
Code:
image="/boot/vmlinuz"
	root="/dev/hda2"
	label="Slackware 12.2" ( this by default was "Linux" )
I restarted my PC and it didn`t change a thing. What did i do wrong ?
 
Old 08-21-2009, 05:28 PM   #5
sahko
Senior Member
 
Registered: Sep 2008
Distribution: Slackware
Posts: 1,041

Rep: Reputation: Disabled
You have to run lilo
 
Old 08-21-2009, 05:39 PM   #6
Bller
Member
 
Registered: Aug 2009
Location: Tulcea, Romania
Distribution: Slackware 13.0
Posts: 199

Original Poster
Rep: Reputation: 15
run lilo? like how exactly?:-s
 
Old 08-21-2009, 05:46 PM   #7
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 6,702
Blog Entries: 51

Rep: Reputation: 1243Reputation: 1243Reputation: 1243Reputation: 1243Reputation: 1243Reputation: 1243Reputation: 1243Reputation: 1243Reputation: 1243
In the terminal or Konsole, as root:
lilo
 
Old 08-22-2009, 05:26 AM   #8
Bller
Member
 
Registered: Aug 2009
Location: Tulcea, Romania
Distribution: Slackware 13.0
Posts: 199

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by brianL View Post
In the terminal or Konsole, as root:
lilo
Warning: LBA32 addressing assumed
Added ShitdoesXP *
Added Slackware
One warning was issued.

Hmm what does that (
Warning: LBA32 addressing assumed ) warning mean?
 
Old 08-22-2009, 07:43 AM   #9
XGizzmo
Member
 
Registered: Mar 2007
Distribution: Slackware
Posts: 264

Rep: Reputation: 68
You can't have the space in this line -> label="Slackware 12.2"
You can try an underscore it may show up as a space in the menu but I can't recall forsure.

"Warning: LBA32 addressing assumed" means You did not tell lilo to use LBA32 but based on
your harddrive/bios you need it. About any computer made after ~2000 needs it.
 
Old 08-22-2009, 07:59 AM   #10
Bller
Member
 
Registered: Aug 2009
Location: Tulcea, Romania
Distribution: Slackware 13.0
Posts: 199

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by XGizzmo View Post
You can't have the space in this line -> label="Slackware 12.2"
You can try an underscore it may show up as a space in the menu but I can't recall forsure.

"Warning: LBA32 addressing assumed" means You did not tell lilo to use LBA32 but based on
your harddrive/bios you need it. About any computer made after ~2000 needs it.
The bootloaders looks and worked fine after a reboot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows 2000 Bootloader vs. Mandriva LILO Bootloader Dregnan Mandriva 7 12-03-2007 09:55 PM
How can I disable the grub bootloader and enable the lilo bootloader? abefroman Linux - General 1 08-06-2005 08:53 AM
Bootloader Time Limit KissDaFeetOfSean Linux - Newbie 3 06-15-2005 11:54 PM
If the bootloader doesn't work this time I'll lose my mind Mr. Hill *BSD 4 03-12-2005 07:57 PM
First time installation bootloader problems odogg Linux - Newbie 1 11-25-2003 12:48 PM


All times are GMT -5. The time now is 11:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration