LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 02-08-2008, 04:41 PM   #1
Linux~Powered
Member
 
Registered: Jan 2004
Location: /lost+found
Distribution: Slack`er-current
Posts: 845

Rep: Reputation: 31
Booting into inittab...


I'm having problems booting into X. Right now my inittab file is configured to boot into runlevel 4, but when I boot up my monitor goes blank because of incorrect video settings which prevents me from editing my xorg.config file. Is there anyway I can boot into runlevel 3 from lilo from the command prompt?
 
Old 02-08-2008, 04:44 PM   #2
mRgOBLIN
Slackware Contributor
 
Registered: Jun 2002
Location: New Zealand
Distribution: Slackware
Posts: 999

Rep: Reputation: 227Reputation: 227Reputation: 227
try CTRL+ALT+F6 from that blank screen.
 
Old 02-08-2008, 04:46 PM   #3
Linux~Powered
Member
 
Registered: Jan 2004
Location: /lost+found
Distribution: Slack`er-current
Posts: 845

Original Poster
Rep: Reputation: 31
I tried that earlier and it doesn't work. My monitor's power button goes blue to yellow like it's in some sort of power saving mode. I had X working at one point until I edited it.
 
Old 02-08-2008, 04:52 PM   #4
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,500

Rep: Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077
Grub allows you to edit the boot menu entries - if you can do that with lilo (I don't know as I don't use it), simply add a "1" to the end of the kernel line. Will get you into single user mode.
Else fix it from the slack CD - or any liveCD; got a Knoppix laying around ???.
 
Old 02-08-2008, 04:52 PM   #5
eddyvp
Member
 
Registered: Feb 2007
Location: Belgium
Distribution: Slackware
Posts: 37

Rep: Reputation: 17
Type single at the lilo prompt.
Slack will boot in runlevel 1 (no X).
 
Old 02-08-2008, 04:52 PM   #6
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,490

Rep: Reputation: Disabled
From lilo boot "KernelName 3"

Brian
 
Old 02-08-2008, 04:57 PM   #7
Uncle_Theodore
Member
 
Registered: Dec 2007
Location: Charleston WV, USA
Distribution: Slackware 12.2, Arch Linux Amd64
Posts: 896

Rep: Reputation: 60
You can certainly boot to the single user mode from the lilo prompt.
Just type at the prompt
Linux 1

From the single user mode you should be able to edit files.
I don't know if you can boot to runlevel 3 in the same way. But you might wanna try...
 
Old 02-08-2008, 05:48 PM   #8
Linux~Powered
Member
 
Registered: Jan 2004
Location: /lost+found
Distribution: Slack`er-current
Posts: 845

Original Poster
Rep: Reputation: 31
The "3" worked - thanks! I reconfigured my xorg.config file and can now use X again.
 
Old 02-09-2008, 02:28 AM   #9
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,776

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
I like using runlevel 4. But it is good idea to leave your iniiatb alone. Keep the default runlevel as 3. Then make a duplicate entry in your lilo.conf which will use runlevel 4 by putting 'init 4' in there.
 
Old 02-09-2008, 08:40 AM   #10
duryodhan
Senior Member
 
Registered: Oct 2006
Distribution: Slackware 12 Kernel 2.6.24 - probably upgraded by now
Posts: 1,054

Rep: Reputation: 46
I guess the problem is that most of the guides online recommend editing the inittab, inspite of the fact that there is such a beautiful and easy solution.
 
Old 02-09-2008, 09:17 AM   #11
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 293Reputation: 293Reputation: 293
Quote:
Originally Posted by duryodhan View Post
I guess the problem is that most of the guides online recommend editing the inittab, inspite of the fact that there is such a beautiful and easy solution.
When you are sure that your system is setup correct then there is no problem with runlevel 4. I usually change my default runlevel when installing graphic drivers or updating X, then change back when it's working.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
since we have no /etc/inittab scrupul0us Ubuntu 19 12-09-2010 05:54 PM
About /etc/inittab zaxonus Linux - General 3 06-04-2007 07:01 AM
rc[0-6] and inittab kpachopoulos Linux - General 1 08-12-2005 05:27 PM
need help booting the system - duplicate /etc/inittab entries? ksgill Linux - Newbie 1 05-10-2004 08:47 AM
Cant get out of inittab InEeDhElPlInUx Linux - Newbie 3 10-09-2003 03:13 PM


All times are GMT -5. The time now is 03:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration