LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-27-2013, 02:38 PM   #1
Divel
LQ Newbie
 
Registered: Mar 2013
Location: Madrid, Spain
Distribution: Slackware mainly
Posts: 6

Rep: Reputation: Disabled
Booting hangs indefinitely in "Mounting local filesystems non-root" (rc.S)


I have a fresh install of Slackware 14.0 and the boot stops at the line "Mounting non-root local filesystems" so I have to add noapic to the boot options. So KDE becomes very slow and useless (opening apps, system shutdown...) and this did not happen with 13.1 version. I have disabled Nepomuk and Strigi. Using mainly ReiserFS.

Where should I start?

Fstab file:

Code:
/dev/sda2        swap             swap        defaults         0   0
/dev/sda1        /                reiserfs    defaults         1   1
/dev/sda3        /home            reiserfs    defaults         1   2
#/dev/cdrom      /mnt/cdrom       auto        noauto,owner,ro,comment=x-gvfs-show 0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
tmpfs            /dev/shm         tmpfs       defaults         0   0
 
Old 03-28-2013, 08:54 AM   #2
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0/14.1
Posts: 3,482

Rep: Reputation: 533Reputation: 533Reputation: 533Reputation: 533Reputation: 533Reputation: 533
The last message you see on screen does not necessarily mean that is where the script is halting. Edit rc.S and add some temporary echo messages such as echo Test 1, echo Test 2, etc. Place the first echo message just after the mounting snippet:

...
echo "Mounting non-root local filesystems:"
sleep 3
if /bin/grep -wq devpts /proc/mounts ; then
/sbin/mount -a -v -t nonfs,nosmbfs,nocifs,noproc,nosysfs,nodevpts
else
/sbin/mount -a -v -t nonfs,nosmbfs,nocifs,noproc,nosysfs
fi
echo "Test 1"
...

If you see the "Test 1" message on screen then the stoppage is occuring after that. If you don't see the "Test 1" message then you've isolated the problem area.
 
1 members found this post helpful.
Old 04-01-2013, 06:41 AM   #3
Divel
LQ Newbie
 
Registered: Mar 2013
Location: Madrid, Spain
Distribution: Slackware mainly
Posts: 6

Original Poster
Rep: Reputation: Disabled
It was my first thought after posing the problem but I did not have access to the machine until today.

Code:
echo "Mounting non-root local filesystems:"
echo T001
sleep 3
echo T002
if /bin/grep -wq devpts /proc/mounts ; then
  echo T002A
...
The result was only T001. What?

I upgraded the sleep to 8 without apparent changes. Any idea?
 
Old 04-01-2013, 06:49 AM   #4
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,156

Rep: Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012
I'd tentatively comment out the line for /home in /etc/fstab (or use a noauto option for it) and see what happens. You should be able to mount /home manually afterwards.
 
Old 04-01-2013, 08:05 AM   #5
Divel
LQ Newbie
 
Registered: Mar 2013
Location: Madrid, Spain
Distribution: Slackware mainly
Posts: 6

Original Poster
Rep: Reputation: Disabled
I got no changes disabling /home in fstab. I have restored the BIOS to factory settings and enabled Hyper-Threading Technology, this was always off by default. There were no problems for 13.1 version. It seems that part of the problem was solved. I no longer need noapic to continue boot but the system is still very slow.

Should I activate a new feature in the system for HTT?
Code:
$ uname -a
Linux INFINITE 3.2.29-smp #2 SMP Mon Sep 17 13:16:43 CDT 2012 i686 Intel(R) Pentium(R) 4 CPU 3.06GHz GenuineIntel GNU/Linux

Last edited by Divel; 04-01-2013 at 08:30 AM.
 
Old 04-01-2013, 08:53 AM   #6
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,156

Rep: Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012
Quote:
Originally Posted by Divel View Post
Should I activate a new feature in the system for HTT?
Code:
$ uname -a
Linux INFINITE 3.2.29-smp #2 SMP Mon Sep 17 13:16:43 CDT 2012 i686 Intel(R) Pentium(R) 4 CPU 3.06GHz GenuineIntel GNU/Linux
I guess no as 3.2.29-smp kernels have CONFIG_SCHED_SMT=y already.

Following this article you could try to include :
Code:
append="acpismp=force"
to the relevant image section in /etc/lilo.conf, though this option be not documented in /usr/src/linux/Documentation/kernel-parameters.txt. (dunno if it is still usable with 2.6 kernels).

In any case, please post full output of:
Code:
cat /proc/cpuinfo

Last edited by Didier Spaier; 04-01-2013 at 09:01 AM.
 
1 members found this post helpful.
Old 04-03-2013, 04:01 AM   #7
Divel
LQ Newbie
 
Registered: Mar 2013
Location: Madrid, Spain
Distribution: Slackware mainly
Posts: 6

Original Poster
Rep: Reputation: Disabled
No apparent changes using acpismp=force.

Code:
# grep acpismp /var/log/*

messages:128487:Apr  3 10:10:39 INFINITE kernel: [    0.000000] Kernel
command line: auto BOOT_IMAGE=Linux ro root=801 vt.default_utf8=0
acpismp=force
Code:
# cat /proc/cpuinfo

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Pentium(R) 4 CPU 3.06GHz
stepping        : 9
microcode       : 0x17
cpu MHz         : 3066.654
cache size      : 512 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 1
apicid          : 0
initial apicid  : 0
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe pebs bts cid xtpr
bogomips        : 6133.30
clflush size    : 64
cache_alignment : 128
address sizes   : 36 bits physical, 32 bits virtual
power management:

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Pentium(R) 4 CPU 3.06GHz
stepping        : 9
microcode       : 0x17
cpu MHz         : 3066.654
cache size      : 512 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 1
apicid          : 1
initial apicid  : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe pebs bts cid xtpr
bogomips        : 6132.40
clflush size    : 64
cache_alignment : 128
address sizes   : 36 bits physical, 32 bits virtual
power management:
 
Old 04-03-2013, 04:42 AM   #8
Divel
LQ Newbie
 
Registered: Mar 2013
Location: Madrid, Spain
Distribution: Slackware mainly
Posts: 6

Original Poster
Rep: Reputation: Disabled
I had a previous boot problem that I solved with vga=normal. Could this be related to the current problem?

Code:
error fb: conflicting fb hw usage radeondrmfb vs VESA VGA - removing generic driver
On the other hand, should I try the huge.s kernel?

Last edited by Divel; 04-03-2013 at 06:48 AM. Reason: Added last question.
 
Old 04-03-2013, 08:13 AM   #9
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0/14.1
Posts: 3,482

Rep: Reputation: 533Reputation: 533Reputation: 533Reputation: 533Reputation: 533Reputation: 533
Quote:
Could this be related to the current problem?
Could be. I ran into a similar problem:

https://www.linuxquestions.org/quest...re-4175450593/

In Comment No. 8 I describe a black screen I sometimes saw.
 
Old 04-09-2013, 02:54 PM   #10
Divel
LQ Newbie
 
Registered: Mar 2013
Location: Madrid, Spain
Distribution: Slackware mainly
Posts: 6

Original Poster
Rep: Reputation: Disabled
I tried two solutions:

1. Set CONFIG_SHED_SMT=n in /boot/config-huge-smp-3.2.29-smp.
2. Booting with vmlinuz-huge-3.2.29 (no-SMP).

There is an appreciable improvement when using the no-SMP kernel but I do not think it worked as well as SMP in 13.1 version. I did not spend much time on the first solution. BIOS-HTT was required in both cases. Why?

Last edited by Divel; 04-10-2013 at 12:23 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] "Can't find root filesystem / error mounting /dev/root" when booting to new kernel sal_paradise42 Linux - Hardware 1 12-01-2012 04:03 PM
System hangs on boot - "Mounting root file system" fails with Via VT6410 enabled Eagleorn Linux - Hardware 3 09-21-2006 12:58 PM
Mandrake 10.1 hangs at "Checking root file system" while booting ananya Mandriva 1 03-01-2006 06:03 PM
External USB HDD"Mounting local filesystems: /dev/sdb1 is not a valid block device" manudath Linux - Hardware 3 12-13-2004 09:59 PM
System hangs when Mounting local filesystems, help please!! slopez Linux - General 3 03-05-2004 03:37 PM


All times are GMT -5. The time now is 01:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration