Go Job Hunting at the LQ Job Marketplace
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 07-26-2012, 06:08 AM   #1
LQ Newbie
Registered: May 2009
Posts: 15

Rep: Reputation: 0
Boot splash resolution

Hello all.

When the nouveau modules is loaded during system start up, the resolution changes and looks really nice. Is there a way to replicate this using the official Nvidia driver?

Old 07-26-2012, 12:22 PM   #2
Amigo developer
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,811

Rep: Reputation: 493Reputation: 493Reputation: 493Reputation: 493Reputation: 493
I'm not sure, but probably not. The feature you refer to is KMS -Kernel Mode Switching.
Old 07-26-2012, 12:32 PM   #3
Registered: Dec 2010
Location: Chilliwack, BC
Distribution: Slackware 14.1 64 Bit
Posts: 32

Rep: Reputation: 8
I'd love it to work that way unfortunately neither the fglrx driver or the nvidia driver do not work this way. Maybe now that Linus has called out Nvidia things may start to change. ATI on the other hand, i doubt it.
Old 07-26-2012, 01:24 PM   #4
Registered: Sep 2009
Distribution: Slackware
Posts: 127

Rep: Reputation: 17
I think that what you need is using vesafb with an appropriate resolution
Old 07-26-2012, 02:20 PM   #5
Senior Member
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,256

Rep: Reputation: 188Reputation: 188
You can install hwinfo over at at run it like so

hwinfo --framebuffer

If you use the nvidia driver then you have to use the vesafb for your framebuffer driver. Using the above command will tell you what resolutions your card supports using that driver, this is the output for my card.

02: None 00.0: 11001 VESA Framebuffer
[Created at bios.459]
Unique ID: rdCR.BfO5bYYtG87
Hardware Class: framebuffer
Model: "NVIDIA GF104 Board - 10410001"
Vendor: "NVIDIA Corporation"
Device: "GF104 Board - 10410001"
SubVendor: "NVIDIA"
Revision: "Chip Rev"
Memory Size: 14 MB
Memory Range: 0xd5000000-0xd5dfffff (rw)
Mode 0x0300: 640x400 (+640), 8 bits
Mode 0x0301: 640x480 (+640), 8 bits
Mode 0x0303: 800x600 (+800), 8 bits
Mode 0x0305: 1024x768 (+1024), 8 bits
Mode 0x0307: 1280x1024 (+1280), 8 bits
Mode 0x030e: 320x200 (+640), 16 bits
Mode 0x030f: 320x200 (+1280), 24 bits
Mode 0x0311: 640x480 (+1280), 16 bits
Mode 0x0312: 640x480 (+2560), 24 bits
Mode 0x0314: 800x600 (+1600), 16 bits
Mode 0x0315: 800x600 (+3200), 24 bits
Mode 0x0317: 1024x768 (+2048), 16 bits
Mode 0x0318: 1024x768 (+4096), 24 bits
Mode 0x031a: 1280x1024 (+2560), 16 bits
Mode 0x031b: 1280x1024 (+5120), 24 bits
Mode 0x0330: 320x200 (+320), 8 bits
Mode 0x0331: 320x400 (+320), 8 bits
Mode 0x0332: 320x400 (+640), 16 bits
Mode 0x0333: 320x400 (+1280), 24 bits
Mode 0x0334: 320x240 (+320), 8 bits
Mode 0x0335: 320x240 (+640), 16 bits
Mode 0x0336: 320x240 (+1280), 24 bits
Mode 0x033d: 640x400 (+1280), 16 bits
Mode 0x033e: 640x400 (+2560), 24 bits
Mode 0x0345: 1600x1200 (+1600), 8 bits
Mode 0x0346: 1600x1200 (+3200), 16 bits
Mode 0x034a: 1600x1200 (+6400), 24 bits
Mode 0x0360: 1280x800 (+1280), 8 bits
Mode 0x0361: 1280x800 (+5120), 24 bits
Config Status: cfg=new, avail=yes, need=no, active=unknown

So we can see the maximum resolution available for my card is 1600x1200. To use it I would edit /etc/lilo.conf and change the VGA line to...

VGA = 0x034a

after you edit /etc/lilo.conf rerun "lilo" as root and you should be good to go.

Last edited by Daedra; 07-26-2012 at 02:33 PM.
Old 07-26-2012, 02:49 PM   #6
LQ Newbie
Registered: Nov 2011
Location: Germany
Distribution: slackware64_current
Posts: 2

Rep: Reputation: Disabled
Or - just as an alternative:
edit /etc/lilo.conf with
vga = ask
run lilo as root, reboot and get the list of supported framebuffer without installing hwinfo
2 members found this post helpful.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Don't show boot messages during Clonezilla boot-up. Splash screen? Perd Linux - Newbie 4 07-18-2010 03:49 PM
Boot splash image with various boot loaders kumarkumar Linux - Software 4 06-10-2008 08:06 PM
Boot splash edison Slackware 8 02-03-2005 06:41 PM
Dual Boot = No Boot (hangs at bios splash screen) nedwardss Debian 4 12-03-2004 05:09 AM
Problem in splash screen resolution ahn in hosts rquin66 Fedora 2 12-04-2003 02:49 AM

All times are GMT -5. The time now is 02:32 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration