LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   boot lilo on dual bootingsystem XP & Slack (http://www.linuxquestions.org/questions/slackware-14/boot-lilo-on-dual-bootingsystem-xp-and-slack-492787/)

Jorunn 10-16-2006 05:34 AM

boot lilo on dual bootingsystem XP & Slack
 
Owke

I have winXP installed on primary partition.
I just installed Slackware 11.0 with the dvd.
I've installed it on an extended partition wich i partioned in 2 logical partitions (one for swap, one for root). Now when i'm asked for installing lilo i choose to install it at the beginning of the root partition. After that , i fdisked the partitions to set a bootable flag to my root partition.

But when i boot i don't get anything to see from lilo, just empty screen...
I think it on one hand has no lilo installed at the beginning of the root directory
Or
It has installed it somewhere else i don't know ?

So i might need to reinstall lilo, but where and who?
I saw a lot of messages about this subject but couldn't find anything sufficient to me. Maybe i looked over but i'm searching 2 day the forum now.
Does anyone can help or maybe give me another solution ?
greetz

prozac 10-16-2006 05:50 AM

i would just install it to the MBR.

Jorunn 10-16-2006 06:44 AM

but thats the thing i wont like to do...is there a solution for it without installing LILO to the MBR ?
greetz

Jorunn 10-16-2006 06:46 AM

and if not, can you say how to install lilo again but than in MBR, 'cause i don't know how. I rebooted with the slack 11 dvd and got into the setup, but i can't fire up the lilo install menu again...
greetz

prozac 10-16-2006 07:12 AM

You can create a bootdisk and use it to boot into slack or you can install lilo into mbr - in /etc/lilo.conf change your boot="something" to boot=/dev/hda and then run lilo on the shell.

onebuck 10-16-2006 07:17 AM

Quote:

Originally Posted by Jorunn
and if not, can you say how to install lilo again but than in MBR, 'cause i don't know how. I rebooted with the slack 11 dvd and got into the setup, but i can't fire up the lilo install menu again...
greetz

Hi,

You will need a boot manager be it lilo,grub or ntloader. You could install lilo to the MBR. The lilo.conf would have a stanza to boot your OS of choice. Do a search on LQ since this issue has been covered many times.

In order to get to your installed system once you boot using the boot/installcd;

Code:

mkdir /slack_repair            #make a directory for
mount /dev/hdaX /slack_repair  #mount of your device.
chroot /slack_repair          #change root to your install
cd /slack_repair/etc          #change to the etc

You can now edit the lilo.conf file for your system using vi, pico or another editor of choice. If you don't desire to edit, you could use liloconfig to create another lilo.conf. Be sure to backup the old if you desire to save it as liloconfig will write a new one.

If you go the edit route then just create the stanza(s) that you need to boot. If you do a man lilo.conf there is a good example. Once you have the desired lilo.conf just do;

Code:

lilo -v -t -b /dev/hdX        #change /dev/hdX to your device
                              #this will test the lilo.conf

lilo -v -b /dev/hdX            #write to MBR of /dev/hdX

The first command just tests the lilo.conf, with the second writes to the MBR. Do a man lilo to understand the switches.
Once you have written your lilo, just reboot.

rkrishna 10-17-2006 01:09 AM

why all this mess use the install cd
at the boot: prompt, (use the kernel u used for installation) type
Code:

bare.i root=/dev/hda6 noinitrid ro
(where i took bare.i as the kernel and /dev/hda6 as the / partition)
when u logged on to ur machine, lype liloconfig

please do check ur /etc/lilo.conf file too
u can manually edit lilo.conf and if so u must run "lilo"

littledrop 10-17-2006 03:17 AM

liloconfig will let you play with lilo.

if you dont want lilo on MBR and you have xp as well then you can boot linux with xp boot menu.

boot to linux
type this command

dd if=/dev/hdax of=/tmp/linux.bin bs=512 count=1

copy /tmp/linux.bin to c drive (/dev/hda1)

hdax is the partition where lilo is installed (read further)

open c:/boot.ini file and add this entry at the end
c:\linux.bin="Linux"

You may need to remove boot.ini attributes before you work on it.

attrib -s -r -h c:\boot.ini

Once you are done
attrib +s +r +h c:\boot.ini


Requirement: lilo must be installed on root or boot partition. You can do that with liloconfig


------------------------
if you have lilo on mbr
dd if=/dev/hda of=/tmp/linux.bin bs=512 count=1

add this to boot.ini
fdisk /mbr will remove lilo.

Please do it at your risk.

littledrop 10-17-2006 03:18 AM

read this link
http://www.geocities.com/epark/linux...w2k-HOWTO.html

Jorunn 10-17-2006 08:44 AM

So thanks for al the solutions, i tried a few, but still ended op with nothing. So i did installed lilo into the MBR
Now when I boot i get a kernel panic saying that my need to set a proper "root=" or something.
I installed kernel 2.6.18 from the dvd. Do i need to do something else, i read something about a initrd etc and followed some
instructions (installpkg kernel generic-2. ... .tgz, installpkg modules) but i didn't found the mkinitrd-10...package in the testing directory
so i didn't installed that one en just used the command, which worked i think, then made changes to lilo.conf
but still it won't work...

greetz
Jorunn

littledrop 10-17-2006 01:41 PM

Do fdisk -l and cross check root partition with entry in lilo.conf file

you can use install cd or live cd.

prozac 10-18-2006 12:02 AM

Quote:

Originally Posted by Jorunn
So thanks for al the solutions, i tried a few, but still ended op with nothing. So i did installed lilo into the MBR
Now when I boot i get a kernel panic saying that my need to set a proper "root=" or something.
I installed kernel 2.6.18 from the dvd. Do i need to do something else, i read something about a initrd etc and followed some
instructions (installpkg kernel generic-2. ... .tgz, installpkg modules) but i didn't found the mkinitrd-10...package in the testing directory
so i didn't installed that one en just used the command, which worked i think, then made changes to lilo.conf
but still it won't work...

greetz
Jorunn

use your slack cd to boot from then mount your root partition as suggested in the cd.

In the o/p of 'df -h' see where is your root ( / ) partition
Code:

# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/hda2            4.7G  2.6G  1.9G  59% /
/dev/hda1              99M  7.9M  86M  9% /boot
/dev/hda3            4.7G  158M  4.3G  4% /usr/local
..
.

then put this in your 'root=' option in /etc/lilo.conf
Code:

# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/hda2
  label = Linux
  read-only
# Linux bootable partition config ends

then re-run lilo
Code:

/sbin/lilo


All times are GMT -5. The time now is 11:29 PM.