LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   /boot: how do I change the current kernel? (http://www.linuxquestions.org/questions/slackware-14/boot-how-do-i-change-the-current-kernel-4175445060/)

stf92 01-10-2013 07:43 PM

/boot: how do I change the current kernel?
 
Slackware 14.0

Hi:
I once changed the smp kernel running in my system by another one in /boot. What I did was to relink /boot/System.map, /boot/vmlinuz and /boot/config. But I don't remember if I did something else. Would that alone be OK.

wildwizard 01-10-2013 07:50 PM

You need to rerun lilo so that it reads a new sector list to load the new kernel.

Have you considered adding both kernels into lilo.conf so you can just select the one you want at boot time?

TobiSGD 01-10-2013 07:50 PM

You also have to run lilo to make it aware of the changes.

stf92 01-10-2013 08:10 PM

ok. An according to CHANGES_AND_HINTS.txt I should make an initrd? I mean, if I use a generic kernel? That thing of the two kernels I like it. I'll do it. Another question.
Code:


                Advanced Linux Sound Architecture - Driver
                ==========================================
                            Installation guide





Quick install
=============

1) You must have full configured source for the Linux kernel which you
  want to use for the ALSA drivers. Note that ALSA drivers are part
  of the kernel, so there is necessary to resolve all symbol dependencies
  between the used kernel and ALSA driver code. Partly installed kernels
  (for example from distributor makers) can be unuseable for this action.

What is the meaning of "full configured source for the Linux kernel"?

TommyC7 01-10-2013 08:21 PM

If you use a generic kernel, yes. The generic kernel doesn't have the filesystems (ext4, ext3, btrfs, etc.) that you (might) use built-in.

stf92 01-10-2013 08:49 PM

Well then, lilo says the ram disk will be loaded above 16M, OK. But what is this token 'large-memory' that can be put in /etc/lilo.conf. I am having trouble booting with a live Linux CD, which is unobjectionable. May it be related to 'large-memory'?

TommyC7 01-10-2013 09:50 PM

I think your /etc/lilo.conf is still using the huge kernel. You can append "large-memory" to /etc/lilo.conf if you want, but I would just recommend using the smaller, generic kernel in your /etc/lilo.conf instead (and then running lilo).

stf92 01-10-2013 10:04 PM

Oh no. I have just replaced the huge by the generic, precisely. It's in /etc/lilo.conf_example where I saw 'large-memory' used. Would this command (large_memory) be obsolete?

wigry 01-11-2013 02:27 AM

I haven't used it in my lilo confs. Anyway you can always man lilo to see the meanings of config options.

stf92 01-11-2013 02:32 AM

Of course I've done that. That's why I ask. But if your machine is a modern one, as mine is too, I wound bother to further inquire. Thanks.

wigry 01-11-2013 06:05 AM

After reading this link: http://manpages.ubuntu.com/manpages/...lo.conf.5.html it appears that actually large-memory option specifies that your system is new enough to be able to handle the initrd location beyond 15Mb limit. Without it, the Initrd will be put within the first 15Mb. As I haven't had any problems with loading initrd from the first 15Mb never ever then I haven't investigated about the large-memory option. It is just one of many lilo's capabilities and there might be some special cases where it would be necessary. But usually you can live without it.

wildwizard 01-11-2013 06:14 AM

Loading the initrd after that point is required on some distros that try to do everything in it and bloat it out to the point where it's almost a distro in of itself.

Have not had such a problem with Slackware, though maybe if you forced every module to be in it you might see that problem rear its head.

TobiSGD 01-11-2013 06:39 AM

The 15MB limit was a problem back in the days of 486 CPUs, if I remember correctly, on modern machines that specific option isn't even available in the BIOS settings. Nonetheless, I only had this message when I misconfigured mkinitrd and it bloated the initrd and when I attempted to run Slackware entirely from the initrd. Usually the initrd shouldn't be that large that you get this message.
What was your command to create the initrd?

stf92 01-11-2013 07:32 AM

I must tell you I didn't got any message from lilo about the memory limit. I only read /etc/lilo.conf_example and saw that command (large_memory). I suspected it to be obsolete (not deprecated but of little use, I you explained). The command I issued was
Code:

mkinitrd -c -k 3.2.29 -m ext2
where 3.2.29 is my kernel version and ext2 the fs I use in the hard.


All times are GMT -5. The time now is 09:15 AM.