LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 09-11-2003, 02:40 PM   #1
Polaris2203
LQ Newbie
 
Registered: Sep 2003
Location: UK
Distribution: Slackware
Posts: 10

Rep: Reputation: 0
Boot failure on new installation (HD & Floppy)


Setup: Old 486 166MHz PM
New 40 Gig Hard Drive

The slackware ISO was too big to burn onto a CD, so I copied the files and dropped gnome.

Boot and root disks work fine, and the install is a dream. However, the PC will not boot from the HD or the boot disk made during the installation. Both floppy and HD boots give a "Boot fail" response. I suspect this is something to to with the way the hard drive is configured.

hda1 = 39 gig, formatted to Linux and flagged as boot, plus a 1 gig swap partition.

Any help or suggestions would be appreciated.


[EDIT]

Previous attempts had lilo boot the HD. I've just tried an installation with the boot set to MBR. This gave a new error: L40 40 40 40 40 40... followed by a system reboot, which lead to the L40 40 40 40 40 40 screen and reboot...

Last edited by Polaris2203; 09-11-2003 at 02:54 PM.
 
Old 09-11-2003, 03:20 PM   #2
djbanaan
Member
 
Registered: Aug 2003
Location: Haarlem, The Netherlands
Distribution: Slackware, FreeBSD
Posts: 178

Rep: Reputation: 30
I've also had the L404040404 thing. I used a Windows 98 (Yes Windows ) bootdisk and gave the command "fdisk /mbr" this resolved the problem. I did some googling on the subject and this was the only method I came across

As for the rest, I don't really understand what's going on, since you did mark you /dev/hda1 as bootable. But you could try re-installing lilo after fixing the MBR with the Windows disk.
 
Old 09-11-2003, 04:37 PM   #3
Polaris2203
LQ Newbie
 
Registered: Sep 2003
Location: UK
Distribution: Slackware
Posts: 10

Original Poster
Rep: Reputation: 0
I finally have Linux up and running. I went into expert mode in lilo after reinstalling and made a few lucky guesses.
 
Old 09-11-2003, 08:11 PM   #4
djbanaan
Member
 
Registered: Aug 2003
Location: Haarlem, The Netherlands
Distribution: Slackware, FreeBSD
Posts: 178

Rep: Reputation: 30
YAY
 
Old 10-05-2003, 10:27 AM   #5
code_noc
LQ Newbie
 
Registered: Sep 2003
Location: Atlanta, GA
Distribution: Slackware 9, FreeBSD 5.1
Posts: 22

Rep: Reputation: 15
a few lucky guesses? come on. You should write down what you try, so that when you get the problem solved, you can post it for others (like myself). oh well, if you can remember those lucky guesses, i would appreciate it
 
Old 10-05-2003, 11:02 AM   #6
Vulpine
LQ Newbie
 
Registered: Oct 2003
Location: Columbus OH
Distribution: stil a newb playing with slackware9.1
Posts: 2

Rep: Reputation: 0
just to let ya know

the slackware is not to big to burn to a cd, you just have to finalize it and it works fine
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
install using boot floppy & usb drive? bob5000 Linux - Newbie 1 11-24-2005 12:10 PM
Boot floppy failure - Bad EIP value DeafScribe DamnSmallLinux 0 06-13-2005 02:09 PM
Strange boot message & failure after hw install. Please help! neocookie Linux - Hardware 2 06-08-2004 01:52 PM
Can you boot the FDC2 installation from floppy? rac83 Fedora - Installation 2 05-25-2004 07:58 AM
Boot And hard disk failure on installation poussis Linux - Newbie 1 05-23-2004 06:41 AM


All times are GMT -5. The time now is 03:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration