LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 12-31-2012, 03:32 AM   #1
enorbet
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 14 is Main OpSys on Main PC, 2ndary are OpenSuSe 13 and SolydK
Posts: 736

Rep: Reputation: 345Reputation: 345Reputation: 345Reputation: 345
Bleeding Edge Asrock Z77- Works Great, 1 Problem = XResolution Intel


Greetings
Before I begin let me explain that I know there are some similar threads around but one of the difficulties of Linux is timestamping and fragmentation - It can be a mess trying to get all relevant info in a few places.

I am running many OpSys on this box but am only concerned with my Main which is Slack 13.37 upgraded to Slack14 as per Upgrade.txt and the addition of a custom 3.7.1 kernel. Yes I did make oldconfig from Huge.smp and only pared it down to 4.7MB for starters until I get it all right and can rape and pillage.

Everything runs really great with the exception of problems I'm having because of the combination of the Intel video driver (presently i915 loads and works)and an aging HiDef Wide Screen TV I've been using as a monitor for about 5 years.

The TV/Monitor data sheet says to use the VGA connector even though it has DVI and to use 1280 x 720 as the native resolution. This has worked very well for years, with some minor tweaks when using nVidia drivers and Slackware, specifically I must add

Option "UseEDIDDpi" "false"

to xorg.conf

After much work including passing append "i915.modeset=+1" in lilo both with vga=normal or hashed out altogether, no matter what I do (and I've been at this for over a week)I can not get the desktop to default to 1280x720. It demands 1152 x 864 which as you may imagine is quite unsuitable. I can force it per session with xrandr and even tried adding xrandr lines in various locations but to no avail.

FWIW this is my present xorg.conf

Code:
Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	Screen      1  "Screen1" RightOf "Screen0"
	Screen      2  "Screen2" RightOf "Screen1"
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "/usr/share/fonts/local"
	FontPath     "/usr/share/fonts/TTF"
	FontPath     "/usr/share/fonts/OTF"
	FontPath     "/usr/share/fonts/Type1"
	FontPath     "/usr/share/fonts/misc"
	FontPath     "/usr/share/fonts/CID"
	FontPath     "/usr/share/fonts/75dpi/:unscaled"
	FontPath     "/usr/share/fonts/100dpi/:unscaled"
	FontPath     "/usr/share/fonts/75dpi"
	FontPath     "/usr/share/fonts/100dpi"
	FontPath     "/usr/share/fonts/cyrillic"
EndSection

Section "Module"
	Load  "dri"
	Load  "dbe"
	Load  "record"
	Load  "dri2"
	Load  "glx"
	Load  "extmod"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
	Option       "DPMS"
        Modeline "1280x720_60.00"  74.48  1280 1336 1472 1664  720 721 724 746  -HSync +Vsync

EndSection

Section "Monitor"
	Identifier   "Monitor1"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
	Option       "DPMS"
	Modeline "1280x720_60.00"  74.48  1280 1336 1472 1664  720 721 724 746  -HSync +Vsync

EndSection

Section "Monitor"
	Identifier   "Monitor2"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
	Option       "DPMS"
	Modeline "1280x720_60.00"  74.48  1280 1336 1472 1664  720 721 724 746  -HSync +Vsync

EndSection

Section "Device"
        Identifier  "Card0"
	Driver      "intel"
	BusID       "PCI:0:2:0"
	Option      "AccelMethod"  "sna"
	Option      "UseEDIDDpi"  "false"
EndSection

Section "Device"
      	Identifier  "Card1"
	Driver      "modesetting"
	BusID       "PCI:0:2:0"
EndSection

Section "Device"
        Identifier  "Card2"
	Driver      "vesa"
	BusID       "PCI:0:2:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	DefaultDepth 24
	SubSection "Display"
		Viewport   0 0
		Depth     1
		Modes     "1280x720"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
		Modes    "1280x720"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
		Modes     "1280x720"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
		Modes    "1280x720"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "1280x720"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1280x720"
	EndSubSection
EndSection

Section "Screen"
	Identifier "Screen1"
	Device     "Card1"
	Monitor    "Monitor1"
	DefaultDepth 24
	SubSection "Display"
		Viewport   0 0
		Depth     1
		Modes   "1280x720"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
		Modes    "1280x720"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
		Modes    "1280x720"
		
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
		Modes    "1280x720"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "1280x720"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1280x720"
	EndSubSection
EndSection

Section "Screen"
	Identifier "Screen2"
	Device     "Card2"
	Monitor    "Monitor2"
	DefaultDepth 24
	SubSection "Display"
		Viewport   0 0
		Depth     1
		Modes    "1280x720"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
		Modes    "1280x720"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
		Modes    "1280x720"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
		Modes    "1280x720"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "1280x720"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1280x720"
	EndSubSection
EndSection
Bottom line - I know the Intel video can do it and the monitor demands it but I am unable to make it happen. Any help would be greatly appreciated.
-PS- Is RDEV to set resolution at kernel level a workable option?

Last edited by enorbet; 12-31-2012 at 04:08 AM.
 
Old 12-31-2012, 04:47 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,628

Rep: Reputation: 586Reputation: 586Reputation: 586Reputation: 586Reputation: 586Reputation: 586
Quote:
Option "UseEDIDDpi" "false"
You are passing that to X and then complaining that it can't set the mode. have you tried removing it, or hiding xorg.conf altogether? You hardly need it now.

Presuming you stay much as you are, in various bits of xorg.conf you can add
PreferredMode 1280x720
Virtual 1280x720

Both of these express your thinking on size. Man xorg.conf.
 
Old 12-31-2012, 01:25 PM   #3
enorbet
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 14 is Main OpSys on Main PC, 2ndary are OpenSuSe 13 and SolydK
Posts: 736

Original Poster
Rep: Reputation: 345Reputation: 345Reputation: 345Reputation: 345
Perhaps I wasn't Clear Enough

Greetz
Although I mentioned I have been at this a week and have googled and tweaked to exhaustion, I tried to keep the post short as possible, so, point by point....


Quote:
Originally Posted by business_kid View Post
You are passing that to X and then complaining that it can't set the mode. have you tried removing it, or hiding xorg.conf altogether? You hardly need it now.
1) I will try again removing the "EDIDDpi" line as I haven't done that for all iterations of trials but it has been required in the past lest I get fonts literally 3 inches tall sending everything way off screen and ridiculously unusable. Not all EDID's are fully compliant and compatible in every way. Thankfully Slack still has Ctrl-Alt-Backspace and KDM has Alt-N.

I did mention that the "EDIDDpi" line was required in the past with nVidia driver but 1280x720 worked fine afterward.

2) Of course I've tried removing xorg.conf altogether. I'm neither lazy nor an ignorant noob. The base problem seems to be that wide screen resolutions, including 1280x720, are not listed in the Intel i915 or i965 drivers and must be forced. IIRC in the past drivers the video bios had to have wide screen resolutions added or passed directly into the kernel. This is part of what I meant by timestamping. Things change and are rarely updated to reflect deprecated, so it is difficult to know for certain and we are left with guesswork and trial and error.



Quote:
Originally Posted by business_kid View Post
Presuming you stay much as you are, in various bits of xorg.conf you can add
PreferredMode 1280x720
Virtual 1280x720

Both of these express your thinking on size. Man xorg.conf.
I do have "PreferredMode 1280x720" in there already but not the "Virtual" line so I will try that. Thank you for the suggestion.

First however it appears I need to backpedal some as xrandr no longer works giving me

Code:
   xrandr --newmode "1280x720_60.00" 74.48 1280 1336 1472 1664  720 721 724 746 -HSync +Vsync
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  149 (RANDR)
  Minor opcode of failed request:  16 (RRCreateMode)
  Serial number of failed request:  38
  Current serial number in output stream:  38
Please bear with me as even though it's great that Intel is supportive of Linux it is apparently not as simple as getting the latest kernel, intel driver, mesa libs, and libva since many report all versions don't all "play well together". Why Intel would leave out widescreen resolutions in what is now almost 2013 is beyond reason as far as I can tell.

In any case thank you for responding and Happy New Year.

Last edited by enorbet; 12-31-2012 at 01:29 PM.
 
Old 12-31-2012, 03:56 PM   #4
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,628

Rep: Reputation: 586Reputation: 586Reputation: 586Reputation: 586Reputation: 586Reputation: 586
I'm sure you'll get going on 1280x800. That might lose a few lines top and bottom, but it is an available size. Rather than fight things, have you tried being Irish about it, and coming to an amicable agreement? You can always reduce the height in a tv anyhow.
 
Old 01-01-2013, 04:45 PM   #5
enorbet
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 14 is Main OpSys on Main PC, 2ndary are OpenSuSe 13 and SolydK
Posts: 736

Original Poster
Rep: Reputation: 345Reputation: 345Reputation: 345Reputation: 345
Aye There's the Rub

Quote:
Originally Posted by business_kid View Post
I'm sure you'll get going on 1280x800. That might lose a few lines top and bottom, but it is an available size. Rather than fight things, have you tried being Irish about it, and coming to an amicable agreement? You can always reduce the height in a tv anyhow.
Actually, No. There are zero widescreen resolutions shown as possible. Here is what "xrandr" reports

Code:
 bash-4.2$ xrandr
Screen 0: minimum 320 x 200, current 1152 x 864, maximum 8192 x 8192
VGA1 connected 1152x864+0+0 (normal left inverted right x axis y axis) 628mm x 3433mm
   1280x1024      75.0     60.0  
   1152x864       75.0* 
   1280x720_60.00   60.0  
   1024x768       75.1     70.1     60.0  
   1024x768i      43.5  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        87.8     70.1
Not only are both card and monitor capable but the monitor data sheet says 1280x720 is native and should be preferred and I have for years. As I said earlier I can force 1280x720 with xrandr with the "newmode" and "addmode" switches but that is on a per session basis. I want it as permanent default. I'll try 1280x800 just for giggles but I don't see "the magic" in that.

It is my understanding that the widescreen modes are not in the video bios framebuffer list. How it can be forced or why windoze driver includes them is beyond me. Maybe Intel is convinced linux geeks all use CRTs with 640x480 <sarc>
 
Old 01-02-2013, 03:44 AM   #6
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,628

Rep: Reputation: 586Reputation: 586Reputation: 586Reputation: 586Reputation: 586Reputation: 586
OK.
What I don't like about that is that some of those modes are 4:3 and others are 16:9. Have you an aspect ratio specified in xorg.conf? Is vesa in there? The standard vesa modes used all to be 4:3 although I believe others can be worked somehow. I would cut your "Display" Section to this sort of thing

Quote:
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1152x864" "1280x720"
EndSubSection
There's no need for multiple colour depths unless you need them (which nobody does these days). So, it comes up in 1152x864; you press ctrl_alt_+ and you _,might_ be in 1280x720.

If not, run startx > x.err 2>&1 from runlevel 3. sudo init 3 might get you there if you boot straight to X and then try ctrl_alt_bcksp.
 
Old 01-02-2013, 04:22 AM   #7
wigry
Member
 
Registered: Jul 2004
Distribution: slackware
Posts: 218

Rep: Reputation: 52
Just one note about DPI and displays. I have a Samsung 26" LCD TV and if I hook my linux box to it, and start XFCE, then the font is so small that it is totally unreadable. Only couple of pixels high. The problem? The TV reports that it has the physical dimensions that of 40" TV. So the guys at Samung did put the 40" data into 26" TV and X will get really confused about that. Therefore I have to override the DPI setting in X config to get the picture right.

So sometimes you need to set the DPI.
 
Old 01-02-2013, 08:38 AM   #8
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,628

Rep: Reputation: 586Reputation: 586Reputation: 586Reputation: 586Reputation: 586Reputation: 586
Agreed. Evidently, sometimes you also need the aspect ratio.
 
Old 01-03-2013, 04:24 AM   #9
enorbet
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 14 is Main OpSys on Main PC, 2ndary are OpenSuSe 13 and SolydK
Posts: 736

Original Poster
Rep: Reputation: 345Reputation: 345Reputation: 345Reputation: 345
To Be Clear...

Quote:
Originally Posted by business_kid View Post
OK.
What I don't like about that is that some of those modes are 4:3 and others are 16:9. Have you an aspect ratio specified in xorg.conf? Is vesa in there? The standard vesa modes used all to be 4:3 although I believe others can be worked somehow. I would cut your "Display" Section to this sort of thing
I think you may be confusing the xrandr output which is reporting detected resolutions and my xorg.conf which only lists just 1280x720 and even the full modeline for it. This is exactly the problem as I have seen it documented in many forums all over the web. For whatever reason(s) wide screen resolutions are not detected and can even be difficult to force, even when the video card is capable and the monitor specifies it as native!

Quote:
Originally Posted by business_kid View Post
There's no need for multiple colour depths unless you need them (which nobody does these days). So, it comes up in 1152x864; you press ctrl_alt_+ and you _,might_ be in 1280x720.

If not, run startx > x.err 2>&1 from runlevel 3. sudo init 3 might get you there if you boot straight to X and then try ctrl_alt_bcksp.
FWIW I have tried none and many xorg.conf iterations and I never boot to X. I even tweak other linuxes like Ubuntu and Suse to force booting to CLI, and problems like this are one of the many reasons why. The above quoted xorg.conf is just a modified version of what xorgsetup generated. I do agree it is a good idea to try to pare that down to just the intel driver and one color depth. I doubt that will fix it but I do love simplicity.

BTW I discovered that xrandr still works to force the mode. It's just that the two lines, one with "newmode" and the other with "addmode", are remembered and can't be repeated with the same name. Just the

Code:
 xrandr --output VGA1 --mode 1280x720_60.00
line must be repeated every session. I surely would like to make it a simple default.

PS
Also I 2nd that regarding some monitors poor EDID implementation. It does gripe me that as far as Linux has come in detecting and hardware self-setup it is still not up to par. I hate to admit that windows overcame such monitor issues when they replaced Win 98 SE.
 
Old 01-04-2013, 04:09 AM   #10
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,628

Rep: Reputation: 586Reputation: 586Reputation: 586Reputation: 586Reputation: 586Reputation: 586
Quote:
BTW I discoveredu that xrandr still works to force the mode. It's just that the two lines, one with "newmode" and the other with "addmode", are remembered and can't be repeated with the same name. Just the
If you find _where_ they are remembered, you can fix that and then script them, making that easier.
 
Old 01-11-2013, 08:36 PM   #11
enorbet
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 14 is Main OpSys on Main PC, 2ndary are OpenSuSe 13 and SolydK
Posts: 736

Original Poster
Rep: Reputation: 345Reputation: 345Reputation: 345Reputation: 345
Update

Greetz
just an FYI for any watching this thread. It is quite interesting, I think, that of 4 Linux systems on this box (2 are Slackware) only the Slack systems "remember" the "newmode" and "addmode" command settings. Studio Ubuntu and OpenSuSe do not, though all will achieve 1280x720 with the final command. Slackware only requires the last one, whereas the others require all three.

However I have yet to discover the difference as to why this is so or how it occurs. Most importantly I have yet to determine where this information is stored to effect a default 1280x720 by adding the last line.

I have all but given up attempting this and only continue now for the lesson as it will soon become moot when I add an nVidia card and cease using the onboard Intel Graphics system. Hopefully Intel will improve their Linux driver for those continuing to utilize Intel.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ASROCK Z77 Extreme 6 MEI driver for Fedora francoiss Linux - Newbie 1 07-12-2012 06:27 AM
LXer: Fedora 9: Leading edge or bleeding edge? LXer Syndicated Linux News 0 05-19-2008 06:41 PM
Being on the Bleeding edge of OSS ? Kamikazee Linux - Software 1 07-20-2005 06:03 AM
Why - bleeding edge SW Artik Debian 7 05-24-2005 12:27 PM
Bleeding-edge distros? rl5 Linux - Distributions 9 04-14-2004 01:06 AM


All times are GMT -5. The time now is 07:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration