LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-10-2006, 02:23 PM   #1
NNP
Member
 
Registered: Nov 2004
Distribution: Debian/Ubuntu
Posts: 156

Rep: Reputation: 30
Blank screen on boot after kernel recompile


Well pretty much what the title says. When i go to boot my newly compiled 2.6.16-2 kernel i get a blank screen and nothing else. I thought it might be some sort of frame buffer issue but i have all the usual stuff set
Quote:
CONFIG_INPUT=y
CONFIG_VT=y
CONFIG_VGA_CONSOLE=y
CONFIG_VT_CONSOLE=y
also, if i leave it for 5-10 mins it never gets past this stage. I've no idea what it could be. My .config file can be found here in case thats any help

http://silenthack.co.uk/nnp/config


I thought maybe the kernel was too large but its actually smaller than my 2.4 kernel so its not that.

Any ideas?

Thanks,
NNP
 
Old 04-10-2006, 03:33 PM   #2
perfect_circle
Senior Member
 
Registered: Oct 2004
Location: Athens, Greece
Distribution: Slackware, arch
Posts: 1,783

Rep: Reputation: 52
why don't you remove the vga line or put vga=normal in lilo or grub to boot without framebuffer, to see what happens?
 
Old 04-10-2006, 03:45 PM   #3
chrisortiz
Member
 
Registered: Nov 2005
Distribution: Slackware, and of course the super delux uber knoppix universal live recovery cd
Posts: 429

Rep: Reputation: 30
when i had this problem it was because i had my video driver compiled as a module and never set the module to load on startup. to fix it i just recompiled with the module built in.
Code:
CONFIG_FB=y
CONFIG_FB_CFB_FILLRECT=y
CONFIG_FB_CFB_COPYAREA=y
CONFIG_FB_CFB_IMAGEBLIT=y
CONFIG_FB_MODE_HELPERS=y
CONFIG_FB_VGA16=m
CONFIG_FB_VESA=y
CONFIG_VIDEO_SELECT=y
CONFIG_FB_CYBLA=y            #(my video driver)
i hope this helps
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Blank Screen after Suse Boot - HowTo boot from grub to command line benco420 Linux - Newbie 3 02-13-2005 05:50 AM
Blank screen on boot mothsmoke Mandriva 3 01-18-2005 06:41 PM
Blank screen even before BIOS screen on boot josce Linux - Laptop and Netbook 3 01-04-2005 08:27 AM
Keep getting blank screen on attempt yo boot into kernel 2.6.7 johncsl82 Slackware 5 07-08-2004 09:44 PM
blank screen after new kernel recompile, but system works antken Linux - General 2 07-05-2004 09:01 AM


All times are GMT -5. The time now is 11:30 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration