LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-21-2005, 04:41 AM   #1
Harkov
Member
 
Registered: May 2004
Distribution: Ubuntu 10.04.1 LTS
Posts: 38

Rep: Reputation: 15
blank screen at hotplug detection


Hi,

I just upgraded my kernel from 2.6.11 to the 2.6.12.2 from the /testing directory in slackware-current. I installed the headers, modules and source as well and did the /sbin/lilo, fixed the errors and rebooted.
After that my screen went blank at the detecting hotplug message. I can still log in so I blindly reinstalled my nvidia drivers (long shot I know), Tried to start the X server and rebooted to knoppix to read the error logs.

Here's what I got at the point in the startup process where my screen goes blank.
Code:
Jul 21 11:04:09 castalia cardmgr[1489]: no pcmcia driver in /proc/devices
Jul 21 11:04:09 castalia hal.hotplug[1561]: DEVPATH is not set
Jul 21 11:04:09 castalia hal.hotplug[1683]: DEVPATH is not set
Jul 21 11:04:09 castalia hal.hotplug[1742]: DEVPATH is not set
Jul 21 11:04:10 castalia hal.hotplug[1789]: DEVPATH is not set
Jul 21 11:04:10 castalia hal.hotplug[1833]: DEVPATH is not set
Jul 21 11:04:10 castalia hal.hotplug[1877]: DEVPATH is not set
Jul 21 11:04:10 castalia hal.hotplug[1921]: DEVPATH is not set
Jul 21 11:04:10 castalia hal.hotplug[1965]: DEVPATH is not set
Jul 21 11:04:10 castalia hal.hotplug[2009]: DEVPATH is not set
Jul 21 11:04:10 castalia hal.hotplug[2053]: DEVPATH is not set
Jul 21 11:04:10 castalia hal.hotplug[2097]: DEVPATH is not set
Jul 21 11:04:10 castalia hal.hotplug[2141]: DEVPATH is not set
Jul 21 11:04:10 castalia hal.hotplug[2185]: DEVPATH is not set
Jul 21 11:04:57 castalia smbd[3084]: [2005/07/21 11:04:57, 0] printing/print_cups.c:cups_cache_reload(85)
Some other messages, I think from during the attempt to start X:
Code:
Jul 21 11:08:13 castalia kernel: VFS: Mounted root (ext2 filesystem) readonly.
Jul 21 11:08:13 castalia kernel: Device 'i82365.0' does not have a release() function, it is broken and must be fixed.
Jul 21 11:08:13 castalia kernel: Badness in device_release at drivers/base/core.c:83
Jul 21 11:08:13 castalia kernel:  [<c0192f83>] kobject_cleanup+0x83/0x90
Jul 21 11:08:13 castalia kernel:  [<c0192f90>] kobject_release+0x0/0x10
Jul 21 11:08:13 castalia kernel:  [<c0193863>] kref_put+0x33/0x80
Jul 21 11:08:13 castalia kernel:  [<c0192fb6>] kobject_put+0x16/0x20
Jul 21 11:08:13 castalia kernel:  [<c0192f90>] kobject_release+0x0/0x10
Jul 21 11:08:13 castalia kernel:  [<e08a1268>] init_i82365+0x178/0x18f [i82365]
Jul 21 11:08:13 castalia kernel:  [<c012ef42>] sys_init_module+0x122/0x1b0
Jul 21 11:08:13 castalia kernel:  [<c0102e09>] syscall_call+0x7/0xb
Jul 21 11:08:14 castalia cardmgr[1675]: no sockets found!
Jul 21 11:08:14 castalia hal.hotplug[1754]: DEVPATH is not set
Jul 21 11:08:14 castalia kernel: ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 11
Jul 21 11:08:14 castalia kernel: PCI: setting IRQ 11 as level-triggered
Jul 21 11:08:14 castalia kernel: nvidiafb: CRTC0 not found
Jul 21 11:08:15 castalia kernel: nvidiafb: CRTC1 found
Jul 21 11:08:15 castalia kernel: nvidiafb: EDID found from BUS2
Jul 21 11:08:15 castalia kernel: nvidiafb: CRTC 0appears to have a CRT attached
Jul 21 11:08:15 castalia kernel: nvidiafb: Using CRT on CRTC 0
Jul 21 11:08:15 castalia kernel: Console: switching to colour frame buffer device 90x25
Jul 21 11:08:15 castalia kernel: ACPI: PCI Interrupt Link [LNKE] enabled at IRQ 11
Jul 21 11:08:16 castalia hal.hotplug[2106]: DEVPATH is not set
Jul 21 11:08:16 castalia kernel: ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 10
Jul 21 11:08:16 castalia kernel: PCI: setting IRQ 10 as level-triggered
Jul 21 11:08:19 castalia kernel: ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 9
Jul 21 11:08:19 castalia kernel: PCI: setting IRQ 9 as level-triggered
Jul 21 11:08:19 castalia kernel: shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5
Jul 21 11:08:19 castalia kernel: shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
Jul 21 11:08:19 castalia hal.hotplug[2412]: DEVPATH is not set
Jul 21 11:08:19 castalia kernel: shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5
Jul 21 11:08:19 castalia kernel: shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
Jul 21 11:08:19 castalia hal.hotplug[2560]: DEVPATH is not set
Jul 21 11:08:19 castalia kernel: shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5
Jul 21 11:08:19 castalia kernel: shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
Jul 21 11:08:19 castalia hal.hotplug[2686]: DEVPATH is not set
Jul 21 11:08:19 castalia kernel: shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5
Jul 21 11:08:19 castalia kernel: shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
Jul 21 11:08:19 castalia hal.hotplug[2811]: DEVPATH is not set
Jul 21 11:08:20 castalia kernel: shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5
Jul 21 11:08:20 castalia kernel: shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
Jul 21 11:08:20 castalia hal.hotplug[2936]: DEVPATH is not set
Jul 21 11:08:20 castalia kernel: shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5
Jul 21 11:08:20 castalia kernel: shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
Jul 21 11:08:20 castalia hal.hotplug[3061]: DEVPATH is not set
Jul 21 11:08:20 castalia kernel: shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5
Jul 21 11:08:20 castalia kernel: shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
Jul 21 11:08:20 castalia hal.hotplug[3186]: DEVPATH is not set
Jul 21 11:08:20 castalia kernel: shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5
Jul 21 11:08:20 castalia kernel: shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
Jul 21 11:08:20 castalia hal.hotplug[3311]: DEVPATH is not set
Jul 21 11:08:20 castalia kernel: shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5
Jul 21 11:08:20 castalia kernel: shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
Jul 21 11:08:20 castalia hal.hotplug[3436]: DEVPATH is not set
Jul 21 11:08:20 castalia kernel: shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5
Jul 21 11:08:20 castalia kernel: shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
Jul 21 11:08:20 castalia hal.hotplug[3561]: DEVPATH is not set
Jul 21 11:08:21 castalia kernel: shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5
Jul 21 11:08:21 castalia kernel: shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
Jul 21 11:08:21 castalia hal.hotplug[3686]: DEVPATH is not set
Jul 21 11:08:21 castalia kernel: shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5
Jul 21 11:08:21 castalia kernel: shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
Jul 21 11:08:21 castalia hal.hotplug[3811]: DEVPATH is not set
Jul 21 11:08:21 castalia kernel: shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5
Jul 21 11:08:21 castalia kernel: shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
Jul 21 11:08:26 castalia sshd[4156]: error: Bind to port 22 on 0.0.0.0 failed: Address already in use.
Jul 21 11:08:45 castalia smbd[4237]: [2005/07/21 11:08:45, 0] printing/print_cups.c:cups_cache_reload(85)
Jul 21 11:08:45 castalia smbd[4237]:   Unable to connect to CUPS server 192.168.1.25 - No route to host
Jul 21 11:08:48 castalia smbd[4237]: [2005/07/21 11:08:48, 0] printing/print_cups.c:cups_cache_reload(85)
Jul 21 11:08:48 castalia smbd[4237]:   Unable to connect to CUPS server 192.168.1.25 - No route to host
Jul 21 11:09:44 castalia kernel: nvidia: module license 'NVIDIA' taints kernel.
Jul 21 11:09:44 castalia kernel: NVRM: The NVIDIA probe routine was not called for 1 device(s).
Jul 21 11:09:44 castalia kernel: NVRM: This can occur when a driver such as rivafb or rivatv was
Jul 21 11:09:44 castalia kernel: NVRM: loaded and obtained ownership of the NVIDIA device(s).
Jul 21 11:09:44 castalia kernel: NVRM: Try unloading the rivafb (and/or the rivatv) kernel module
Jul 21 11:09:44 castalia kernel: NVRM: (or reconfigure your kernel without rivafb support), then
Jul 21 11:09:44 castalia kernel: NVRM: try loading the NVIDIA kernel module again.
Jul 21 11:09:44 castalia kernel: NVRM: No NVIDIA graphics adapter probed!
any clues on how to fix this?
 
Old 07-21-2005, 06:09 AM   #2
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,282

Rep: Reputation: 66
I would recompile the kernel without rivafb support and nvidiafb as suggested
or maybe put these modules in /etc/hotplug/blacklist
 
Old 07-21-2005, 06:40 AM   #3
Harkov
Member
 
Registered: May 2004
Distribution: Ubuntu 10.04.1 LTS
Posts: 38

Original Poster
Rep: Reputation: 15
thanks, blacklisting worked. Now I still don't have any sound and I'm getting weird perl warnings but at least I can see what I'm doing.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 9.0 Blank screen instead of login in screen damoncf Linux - Distributions 4 02-24-2007 08:49 PM
Blank screen even before BIOS screen on boot josce Linux - Laptop and Netbook 3 01-04-2005 08:27 AM
Blank screen after initial install screen? CRCool75 Linux - Newbie 2 11-16-2004 09:32 PM
wrong OHCI detection at hotplug Borelian Slackware 2 06-11-2004 03:24 PM
Blank screen - screen saver ??? cstehle Linux - Newbie 8 03-13-2002 09:44 PM


All times are GMT -5. The time now is 05:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration