LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 07-12-2014, 05:22 AM   #1
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 514

Rep: Reputation: Disabled
Black screen in Street View from Google Maps


Hello,

I'm currently experiencing a weird bug in Street View from Google Maps and I'm unable to solve it or work around it. Help would be very appreciated.

When dropping the little man on a street, Maps changes to Street View and everything appears to work. I can see the street view and look around. Now, the moment I try to move by clicking on the virtual ground, the street view goes black and does not display anything. Only the different overlays are shown.

I just took a screenshot: http://i.imgur.com/DExb42Q.png

This happens in any location on the map I've tried, including my local area as well as foreign big cities. Anybody with the same problem and/or anything to try?

I'm running slackware64-current with the binary NVIDIA drivers version 340.24. i3 is my window manager and the browser is maximized in a 1920x1080 screen. I've tried several things:
  • In the preferences screen, I tried many combinations of the advanced settings about autoscrolling, smooth scrolling and enabling hardware acceleration, including all of them activated and none of them activated.
  • Disabling all add-ons.
  • Disabling and enabling the flash plugin.

Thanks in advance for any help.
 
Old 07-12-2014, 05:37 AM   #2
brodo
Member
 
Registered: Jan 2004
Location: Poland, Poznan
Distribution: Slackware current
Posts: 187

Rep: Reputation: 17
I have this issue, too.

Thinkpad X220 with Intel GMA HD Integrated Graphics 3000 onboard.
Slackware current, 32-bit.
 
1 members found this post helpful.
Old 07-12-2014, 06:15 AM   #3
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 514

Original Poster
Rep: Reputation: Disabled
That would point to a bug in Firefox, or Street View. I've searched the Firefox bugzilla and it seems to match this bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=1021703

Unfortunately, it lacks comments except from the reporter.
 
Old 07-12-2014, 10:53 PM   #4
MadMaverick9
Member
 
Registered: Aug 2010
Location: Here
Distribution: Slackware 14.0
Posts: 147

Rep: Reputation: Disabled
This has nothing to do with Firefox.

I use Chromium sometimes, and google maps does not work in Chromium anymore either. I get some error message about webgl, click reload or ignore. And nothing happens. The last time I used google maps in Chromium, maybe a month or two ago, it still worked. With this same version of Chromium.

So stop blaming Firefox. It's google who broke it.

Somehow I wish that Mozilla will close this bug as "WONTFIX".

And btw - OpenStreetMap works fine.
 
Old 07-12-2014, 11:29 PM   #5
273
Senior Member
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 3,559

Rep: Reputation: 804Reputation: 804Reputation: 804Reputation: 804Reputation: 804Reputation: 804Reputation: 804
Street view probably doesn't work in Chromium any more as they dropped support fro Flash. The first thing I would do if having problems with street view would be check that Flash is the latest version.
 
1 members found this post helpful.
Old 07-13-2014, 03:54 AM   #6
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 514

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by 273 View Post
Street view probably doesn't work in Chromium any more as they dropped support fro Flash. The first thing I would do if having problems with street view would be check that Flash is the latest version.
The new Street View doesn't seem to use flash anymore, but I checked enabling and disabling the flash plugin (without asking for activation) and it didn't make a difference. It's up to date. I'm running version 11.2.202.394.
 
Old 07-13-2014, 06:44 AM   #7
MadMaverick9
Member
 
Registered: Aug 2010
Location: Here
Distribution: Slackware 14.0
Posts: 147

Rep: Reputation: Disabled
Quote:
The new Street View doesn't seem to use flash anymore
Well - there's your reason for the breakage.

Which I kinda figured after seeing the error in Chromium about webgl.

And is that the browser's fault? No! - I don't think so.

Am I gonna buy new hardware just for google so that it can use webgl? HA! - keep dreaming.

So who's bug is this? google's or the browser's? You know my answer.

Like I said before - I hope that Mozilla will close this bug as "WONTFIX".

On my machine I can see the following in Firefox's "about:support":
Quote:
WebGL Renderer - Blocked for your graphics card because of unresolved driver issues.
Go file a bug with google. Good Luck with that.

What I don't understand here also: google needs you more than you need google. Go find and use something else like OpenStreetMap.

You know - you can live without google just fine.
 
Old 07-13-2014, 07:22 AM   #8
273
Senior Member
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 3,559

Rep: Reputation: 804Reputation: 804Reputation: 804Reputation: 804Reputation: 804Reputation: 804Reputation: 804
I think on this machine at least I must still be loading the old Flash based street view. So, it could be that WebGL issue. Oddly though this EEEPC is reported as supporting WebGL and I have been able to see demo's.
 
Old 07-13-2014, 08:08 AM   #9
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 514

Original Poster
Rep: Reputation: Disabled
I disabled WebGL from about:config and checked some WebGL demos to verify it had been correctly disabled. Maps works the same (it works and it still shows the problem), so I'm not sure the issue is related to WebGL. I've discovered that enabling or disabling the developer tools (shortcut Ctrl+Shift+I), brings the image back on.

Update: It's the same with the developer toolbar (Shift+F2).

Update 2: I found https://support.mozilla.org/en-US/questions/1002684 and they mention that actually forcing webgl mode in Maps seems to work the problem around. In my case, it's true: https://www.google.com/maps/preview/?force=webgl

Last edited by rg3; 07-13-2014 at 08:21 AM.
 
Old 07-22-2014, 11:20 AM   #10
audriusk
Member
 
Registered: Mar 2011
Location: Klaipėda, Lithuania
Distribution: Slackware
Posts: 248

Rep: Reputation: 107Reputation: 107
Seems to be this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1034593 (linked from Firefox 31 release notes known issues section).
 
2 members found this post helpful.
Old 07-24-2014, 10:27 AM   #11
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 514

Original Poster
Rep: Reputation: Disabled
Nice find, thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
India: Bangalore stops Google Street View Jeebizz Linux - News 1 07-11-2011 06:04 AM
Google's UK Street View wi-fi data 'deleted' Jeebizz Linux - News 0 12-20-2010 09:37 AM
Germany opposes Google Street View switch-on Jeebizz Linux - News 0 09-20-2010 11:15 AM
Czechs halt Google Street View Jeebizz Linux - News 0 09-15-2010 12:45 PM
Spain investigates Google Street View wi-fi snooping Jeebizz Linux - News 0 08-17-2010 02:14 PM


All times are GMT -5. The time now is 01:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration