LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 01-18-2004, 10:38 PM   #1
cjdock
Member
 
Registered: Oct 2003
Distribution: slackware9.1
Posts: 44

Rep: Reputation: 15
Black screen during boot up after new 2.6.1 kernel


I run slackware9.1. I have been using swaret to upgrade my packages, including my kernel. All has been well. I decided to try kernel 2.6.1 and after installing it, when I re-boot I get a black screen but I hear the hard drive running. So I wait a minute and then log on and then startx and then X comes on, the screen lights up correctly! I do see the inital kernel choice menu, I choose the new one and then see that black screen until I log on "in the dark".
What did I do wrong?
 
Old 01-18-2004, 10:42 PM   #2
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
Framebuffer problems probably. You may have the wrong device driver in the kernel for a frame buffer.

Nvidia cards are reported to not like the frame buffers.
 
Old 01-18-2004, 11:20 PM   #3
_mu_
LQ Newbie
 
Registered: Jan 2004
Distribution: Debian, Slackware
Posts: 29

Rep: Reputation: 15
Im not totally sure but I think I read somewhere that you had to have /dev/pts enabled forthe 2.6 kernels. Just check its in the kernel and whether it has an entry in /etc/fstab. But yeh I think I have read some other post somewhere about this. Hope it works but I could be wrong so just check.

The /dev/pts is only for people with devfs so unless you have devfs dont worry about it

Last edited by _mu_; 01-19-2004 at 12:18 AM.
 
Old 01-18-2004, 11:56 PM   #4
_mu_
LQ Newbie
 
Registered: Jan 2004
Distribution: Debian, Slackware
Posts: 29

Rep: Reputation: 15
I could be way of with the /dev/pts thing check out this aswell its a good read if your going to the 2.6 kernels.

http://www.codemonkey.org.uk/post-halloween-2.5.txt.
Its under the "The known gotcha's" where there is something like your problem.
 
Old 01-19-2004, 12:31 AM   #5
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
I solved this exact problem by enabling VESA in the Console driver/Framebuffer section.
 
Old 01-19-2004, 05:12 AM   #6
dirstyGuy
Member
 
Registered: Jan 2004
Posts: 67

Rep: Reputation: 15
I've changed too much that I don't know wut responsible for that blank screen:
Previously I enabled many thing but now I even reduce them, n disabled AGP & DRI. But am not sure whether it is that that responsible for ..

Code:
# Ftape, the floppy tape device driver
#
# CONFIG_FTAPE is not set
# CONFIG_AGP is not set
# CONFIG_DRM is not set


# Graphics support
#
CONFIG_FB=y
# CONFIG_FB_CYBER2000 is not set
# CONFIG_FB_IMSTT is not set
# CONFIG_FB_VGA16 is not set
CONFIG_FB_VESA=y
CONFIG_VIDEO_SELECT=y
# CONFIG_FB_HGA is not set
# CONFIG_FB_RIVA is not set
# CONFIG_FB_MATROX is not set
# CONFIG_FB_RADEON is not set
# CONFIG_FB_ATY128 is not set
# CONFIG_FB_ATY is not set
# CONFIG_FB_SIS is not set
# CONFIG_FB_NEOMAGIC is not set
# CONFIG_FB_3DFX is not set
# CONFIG_FB_VOODOO1 is not set
# CONFIG_FB_TRIDENT is not set
CONFIG_FB_VIRTUAL=y

#
# Console display driver support
#
CONFIG_VGA_CONSOLE=y
# CONFIG_MDA_CONSOLE is not set
CONFIG_DUMMY_CONSOLE=y
CONFIG_FRAMEBUFFER_CONSOLE=y
CONFIG_PCI_CONSOLE=y
CONFIG_FONTS=y
CONFIG_FONT_8x8=y
CONFIG_FONT_8x16=y
# CONFIG_FONT_6x11 is not set
# CONFIG_FONT_PEARL_8x8 is not set
# CONFIG_FONT_ACORN_8x8 is not set
# CONFIG_FONT_MINI_4x6 is not set
# CONFIG_FONT_SUN8x16 is not set
# CONFIG_FONT_SUN12x22 is not set

#
# Logo configuration
#
# CONFIG_LOGO is not set
 
Old 01-19-2004, 06:53 AM   #7
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
Well, I can only guess by telling you to select a video card under CONFIG_VIDEO_SELECT, even if you module them all. Maybe that will help. I also think you can disable the CONFIG_FB_VIRTUAL.
Then just enable your logo so you get to see the little linux penguin and hopefully you'll be ready.....
Do you know what video card you have?
 
Old 01-19-2004, 10:13 AM   #8
cjdock
Member
 
Registered: Oct 2003
Distribution: slackware9.1
Posts: 44

Original Poster
Rep: Reputation: 15
The VESA vga graphic was already checked so I checked another box that said intel 810/815 support (experimental), that ran make, su -s "modules_install", and make install and it worked!!!Thanks!
 
Old 01-19-2004, 12:01 PM   #9
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
Penguins Rule!

I hope that when you get time you'll go back and give the little 256 penguin a shot at the top! What would linux be without the penguin???
Congrats on the display! Gotta have some hardware to use. Hope I was of some help.
 
Old 01-21-2004, 09:11 AM   #10
Alinuxnoob
Member
 
Registered: Feb 2002
Location: Van city
Distribution: Ubuntu
Posts: 204

Rep: Reputation: 30
I have the same problem and I have an Nvidia Card. So what do you do to fix this problem?
 
Old 01-21-2004, 10:31 AM   #11
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
go through the video and console graphics sections very carefully, and read the help section for anything other than modules you don't need. and definitely find out exactly what module you need for your card so there's no guessing involved. make sure you enable VESA and read the several posts around here about it. lots of other people were in the same situation, including me!
if you can't get it, come back and we'll help you more.
 
Old 01-21-2004, 11:41 AM   #12
Alinuxnoob
Member
 
Registered: Feb 2002
Location: Van city
Distribution: Ubuntu
Posts: 204

Rep: Reputation: 30
Ok when you mean go through the video and console graphics section you mean rerunning menuconfig? and compiling it with the new settings. I mean I'm able to boot into slackware using the 2.6.1 kernel but I just don't see anything before I logg in. and another thing is when I boot using the 2.6.1 kernel my mouse doesn't work. I have a USB mouse but kernel setting didn't give me an option for USB mouse....
 
Old 01-21-2004, 11:53 AM   #13
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
You do get an option in USB for a mouse so make sure you find it. You'll have to do menuconfig again, yes.
make mrproper
make menuconfig
make
make modules_install
make install
before you exit, after you're done, save your settings to a separate file in your home directory by typing the full path. You can look through it and post parts of it here for troubleshooting.
 
Old 01-21-2004, 04:50 PM   #14
brandonloserkid
Member
 
Registered: Jan 2004
Location: Tampa, FL
Distribution: Ubuntu (feisty fawn)
Posts: 70

Rep: Reputation: 15
i have the same problem with 2.6.0 but i cant even "ghost login"

i read the codemonkey document, and i have:

CONFIG_INPUT=y
CONFIG_VT=y
CONFIG_VGA_CONSOLE=y
CONFIG_VT_CONSOLE=y

any other suggestions?
 
Old 01-21-2004, 09:10 PM   #15
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
Well if you can't do the 'ghost login' then you're getting a kernel panic probably and you'll have to sort that out first. Check your filesystems setup in the menuconfig. Post if here if you want everyone to check it out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I messed with the screen resolution and now Redhat will boot into a black screen! Mr. Hill Linux - Newbie 29 05-04-2009 12:52 PM
Black screen on boot Michael Davont Linux - Newbie 10 01-25-2005 04:35 PM
Slackware 9.1 new kernel compile displays black screen on boot. Krenn Slackware 3 03-29-2004 03:33 PM
Black Screen At Boot Obscure Slackware 12 12-21-2003 01:03 AM
Black Screen after Boot HitmanIP7 Linux - Software 44 05-30-2003 02:38 PM


All times are GMT -5. The time now is 04:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration