LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-14-2004, 08:43 AM   #1
Obscure
Member
 
Registered: Apr 2003
Location: Milan
Distribution: Slackware 10 / FreeBSD 5.3
Posts: 175

Rep: Reputation: 32
Question Black Screen After Kernel Compiling


Hi!

I've compiled 2.4.24 kernel on my slack 9.0 and rebooting the screen still black...

I think is a console problem
Here from my config file:
Code:
... 
#
# Console drivers
#
CONFIG_VGA_CONSOLE=y
CONFIG_VIDEO_SELECT=y
 
#
# Sound
#
...
Selecting only VGA console the screen works with low resolution console!

What can I do to use frame buffer??

TnxVeryMuch
 
Old 02-14-2004, 09:57 AM   #2
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,469

Rep: Reputation: 154Reputation: 154
"What can I do to use frame buffer??"

Here is how I configured frame buffer support in 2.4.22.

Console drivers
Support for frame buffer devices: y
VESA VGA graphics console: y
Advanced low level driver options: y
8 bpp packed pixels support: y
16 bpp packed pixels support: y
24 bpp packed pixels support: y
32 bpp packed pixels support: y


___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
Old 02-14-2004, 12:35 PM   #3
Obscure
Member
 
Registered: Apr 2003
Location: Milan
Distribution: Slackware 10 / FreeBSD 5.3
Posts: 175

Original Poster
Rep: Reputation: 32
Tnx for yr reply!!
There's no selectable voices under "console drivers menu" except "VGA text console" and "Video mode selection support"!
There's also "MDA text console (Dual-Headed)(Experimental)" and sub-menu "frame buffer" but are unselectable...

Tnx
0bscure
 
Old 02-15-2004, 04:50 AM   #4
Obscure
Member
 
Registered: Apr 2003
Location: Milan
Distribution: Slackware 10 / FreeBSD 5.3
Posts: 175

Original Poster
Rep: Reputation: 32
Maybe someone should post the "console drivers" part of his .config file??
This could help me...
Tnx VM

Last edited by Obscure; 02-15-2004 at 05:32 AM.
 
Old 02-15-2004, 10:47 AM   #5
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,469

Rep: Reputation: 154Reputation: 154
"Maybe someone should post the "console drivers" part of his .config file??
This could help me..."

This is my Console drivers and Frame-buffer support for 2.4.22


# Console drivers
#
CONFIG_VGA_CONSOLE=y
CONFIG_VIDEO_SELECT=y
# CONFIG_MDA_CONSOLE is not set

#
# Frame-buffer support
#
CONFIG_FB=y
CONFIG_DUMMY_CONSOLE=y
# CONFIG_FB_RIVA is not set
# CONFIG_FB_CLGEN is not set
# CONFIG_FB_PM2 is not set
# CONFIG_FB_PM3 is not set
# CONFIG_FB_CYBER2000 is not set
CONFIG_FB_VESA=y
# CONFIG_FB_VGA16 is not set
# CONFIG_FB_HGA is not set
CONFIG_VIDEO_SELECT=y
# CONFIG_FB_MATROX is not set
# CONFIG_FB_ATY is not set
# CONFIG_FB_RADEON is not set
# CONFIG_FB_ATY128 is not set
# CONFIG_FB_INTEL is not set
# CONFIG_FB_SIS is not set
# CONFIG_FB_NEOMAGIC is not set
# CONFIG_FB_3DFX is not set
# CONFIG_FB_VOODOO1 is not set
# CONFIG_FB_TRIDENT is not set
# CONFIG_FB_VIRTUAL is not set
CONFIG_FBCON_ADVANCED=y
# CONFIG_FBCON_MFB is not set
# CONFIG_FBCON_CFB2 is not set
# CONFIG_FBCON_CFB4 is not set
CONFIG_FBCON_CFB8=y
CONFIG_FBCON_CFB16=y
CONFIG_FBCON_CFB24=y
CONFIG_FBCON_CFB32=y
# CONFIG_FBCON_AFB is not set
# CONFIG_FBCON_ILBM is not set
# CONFIG_FBCON_IPLAN2P2 is not set
# CONFIG_FBCON_IPLAN2P4 is not set
# CONFIG_FBCON_IPLAN2P8 is not set
# CONFIG_FBCON_MAC is not set
# CONFIG_FBCON_VGA_PLANES is not set
# CONFIG_FBCON_VGA is not set
# CONFIG_FBCON_HGA is not set
# CONFIG_FBCON_FONTWIDTH8_ONLY is not set
# CONFIG_FBCON_FONTS is not set
CONFIG_FONT_8x8=y
CONFIG_FONT_8x16=y

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
Old 02-15-2004, 05:14 PM   #6
Obscure
Member
 
Registered: Apr 2003
Location: Milan
Distribution: Slackware 10 / FreeBSD 5.3
Posts: 175

Original Poster
Rep: Reputation: 32
Tnx VVVM jailbait!!!
This is what I need...
Now I gonna try it....
 
Old 02-18-2004, 03:25 AM   #7
Obscure
Member
 
Registered: Apr 2003
Location: Milan
Distribution: Slackware 10 / FreeBSD 5.3
Posts: 175

Original Poster
Rep: Reputation: 32
Mmmhhh

Adding

#
# Frame-buffer support
#
CONFIG_FB=y

To my .config file still remain unselectable (grey) on xconfig menu....

 
Old 02-20-2004, 08:45 PM   #8
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,469

Rep: Reputation: 154Reputation: 154
"CONFIG_FB=y

To my .config file still remain unselectable (grey) on xconfig menu...."

Near the beginning of the xconfig menu there is an option to allow experimental options to be used. Change that to yes and you can then use CONFIG_FB=y.

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
Old 02-23-2004, 04:14 AM   #9
Obscure
Member
 
Registered: Apr 2003
Location: Milan
Distribution: Slackware 10 / FreeBSD 5.3
Posts: 175

Original Poster
Rep: Reputation: 32
Quote:
Originally posted by jailbait

Near the beginning of the xconfig menu there is an option to allow experimental options to be used. Change that to yes and you can then use CONFIG_FB=y.
Tnx jailbait
This was my problem
Now all works correctly
Tnx VM
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Black Screen after new kernel Haniblectre Slackware 4 09-06-2004 05:12 PM
compiling 2.6.3 i went to tldp and got a kernal how to no screen is black at boot citrus Slackware 1 03-04-2004 02:49 AM
Black screen during boot up after new 2.6.1 kernel cjdock Slackware 17 02-01-2004 03:36 PM
black screen ocurred during install of 2.6.1 kernel brandonloserkid Slackware 2 01-21-2004 10:15 AM
black screen after kernel compile .... purpleburple Linux - General 7 03-27-2003 01:09 PM


All times are GMT -5. The time now is 03:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration