LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 08-31-2009, 01:21 AM   #1
quanta
Member
 
Registered: Aug 2007
Location: Vietnam
Distribution: RedHat based, Debian based, Slackware, Gentoo
Posts: 724

Rep: Reputation: 100Reputation: 100
/bin/login: error while loading shared libraries: libpam.so.0?


Hi all,

I am using Slackware 12.2 at runlevel 4. I cannot login when switch to runlevel 1 or runlevel 3. After typing username and password, the following error appear:
Quote:
login[2996]: segfault at ... ip ... sp ... error 6 in login
(I don't remember the above blanks because I didn't take note)

and login prompt appear again.

Looking at /var/log/secure:
Quote:
Aug 31 09:44:43 localhost login: PAM unable to dlopen(/lib/security/pam_cracklib.so): /lib/security/pam_cracklib.so: cannot open shared object file: No such file or directory
Aug 31 09:44:43 localhost login: PAM adding faulty module: /lib/security/pam_cracklib.so
The reason is I installed Linux-PAM before and lack of pam_cracklib.so (don't know why). Uninstall it (Linux-PAM) and try switch to runlevel 1 with "telinit 1" again but I still cannot login. After type the username I got:
Quote:
/bin/login: error while loading shared libraries: libpam.so.0: cannot open shared object file: No such file or directory
and login prompt appear again.

How do I completely uninstall PAM on Slack and be able login to single-user mode (or runlevel 3)?

Thanks in advance.
 
Old 08-31-2009, 01:41 AM   #2
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,974

Rep: Reputation: Disabled
You just learned an important lesson. :-)

You'll need to boot the installer, mount it to /cdrom, mount the installed system to /mnt, and then do this:
Code:
ROOT=/mnt upgradepkg /cdrom/.../shadow-4.0.3-*.t?z
 
Old 08-31-2009, 02:13 AM   #3
quanta
Member
 
Registered: Aug 2007
Location: Vietnam
Distribution: RedHat based, Debian based, Slackware, Gentoo
Posts: 724

Original Poster
Rep: Reputation: 100Reputation: 100
Quote:
Originally Posted by rworkman View Post
You just learned an important lesson. :-)

You'll need to boot the installer, mount it to /cdrom, mount the installed system to /mnt, and then do this:
Code:
ROOT=/mnt upgradepkg /cdrom/.../shadow-4.0.3-*.t?z
I understand what you mean but notice that I am still able to login to runlevel 4 (GUI) normally.

-----------------------------------------------------------------------------------------
Edited: Thank you. I tried upgrading shadow package with --reinstall option from CD-ROM and now I am able to login single-user mode.

But, I don't understand the differences in shadow package's effects when running at runlevel 4 and runlevel 1?

Last edited by quanta; 08-31-2009 at 02:45 AM.
 
Old 08-31-2009, 09:48 AM   #4
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,974

Rep: Reputation: Disabled
The graphical desktop managers don't use /bin/login directly.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gxine: error while loading shared libraries: libmozjs.so: cannot open shared object.. empcrono Slackware 10 11-10-2008 08:33 PM
error while loading shared libraries: libstdc++.so.5: cannot open shared object file PaulyWally Debian 2 10-18-2008 06:59 PM
error while loading shared libraries: libgvc.so.3: cannot open shared object file coolrock Slackware 6 01-17-2007 06:10 PM
xmule-bin: error while loading shared libraries: libpangocairo-1.0.so.0: cannot... exit3219 Debian 2 11-09-2005 09:33 AM
error while loading shared libraries: libdb-4.1.so: cannot open shared object file putquery8581 Linux - Software 1 10-01-2004 08:03 AM


All times are GMT -5. The time now is 01:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration