LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-09-2006, 05:42 AM   #16
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Rep: Reputation: 55

I get this error when I try to compile on a partition mounted from fstab with "user" option. I found this on the LFS FAQ page that explains the issue and the solution:

Quote:
You're most likely getting this while building binutils in Chapter 5 of the LFS Book. The problem is most likely your mount options. You probably have a line in /etc/fstab like:
/dev/hda10 /mnt/lfs ext2 user 1 2
'user' is the mount flag, and it's the problem. To quote from the mount man page:
user: Allow an ordinary user to mount the file system. This option implies the options noexec, nosuid, and nodev (unless overridden by subsequent options, as in the option line user,exec,dev,suid).
So change the line in /etc/fstab like this:
/dev/hda10 /mnt/lfs ext2 defaults 1 2
Your statement:

Quote:
The directory is just my storage hdd
suggests that this directory is mounted from fstab - perhaps with the offending options.

Another option would be to try to ./configure from /home/user or /tmp.

HTH
 
Old 08-09-2006, 11:16 AM   #17
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
The error you are getting is the same you would get when you try to run a script that is not executable. This is where you should probably focus your efforts. Can you run just a plain test script on the same drive? same directory? Does it make a diffrence when you run 'sh script' or './script'? Try to narrow down the problem as much as possible.

regards,
...drkstr
 
Old 08-09-2006, 03:06 PM   #18
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Original Poster
Rep: Reputation: 65
I had to rerun my x setup this AM on that box (due to reinstalling /a), and I had to use 'sh NVID...' on the box, not just './NVID...'. I cannot run anytype of configure script on that machine, no matter where it came from...
 
Old 08-09-2006, 04:01 PM   #19
liquidtenmilion
Member
 
Registered: May 2004
Location: South Carolina
Distribution: Slackware 11.0
Posts: 606

Rep: Reputation: 31
This sounds like an error with sh.

What does

Code:
ls -la /bin/sh
Say? It looks like it could be a permission error.
 
Old 08-09-2006, 05:06 PM   #20
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Original Poster
Rep: Reputation: 65
Quote:
Originally Posted by Franklin
I get this error when I try to compile on a partition mounted from fstab with "user" option. I found this on the LFS FAQ page that explains the issue and the solution:



Your statement:



suggests that this directory is mounted from fstab - perhaps with the offending options.

Another option would be to try to ./configure from /home/user or /tmp.

HTH
That fixed it. You were dead on right. Removed the 'user' option in fstab, and BAM! configuring as we speak.

Thanks again, Franklin.
 
Old 08-10-2006, 12:51 AM   #21
introuble
Member
 
Registered: Apr 2004
Distribution: Debian -unstable
Posts: 700

Rep: Reputation: 31
Is the partition you're issuing the configure script on mounted noexec? [make sure]

Edit: Never mind, didn't notice the 2nd page of comments.

Last edited by introuble; 08-10-2006 at 12:52 AM.
 
Old 08-10-2006, 12:57 AM   #22
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Original Poster
Rep: Reputation: 65
lol.

Let me see...

Yep, it was!!

lol
 
Old 01-14-2007, 07:42 AM   #23
Randux
Senior Member
 
Registered: Feb 2006
Location: Siberia
Distribution: Slackware & Slamd64. What else is there?
Posts: 1,705

Rep: Reputation: 54
I run my /tmp noexec as a security measure. I outsmarted myself today and when I realized what I did I came here to post a warning to anybody else who might have this problem- but I see my buddy CW already did it on a different mountpoint
 
Old 01-14-2007, 08:46 AM   #24
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Original Poster
Rep: Reputation: 65
Wow, i forogot about this thread, but not the lesson it taught....lol
 
Old 01-20-2007, 03:38 PM   #25
m_shroom
Member
 
Registered: Oct 2004
Location: Queen Charlotte B. C. Canada
Distribution: openSUSE 11.1
Posts: 42

Rep: Reputation: 15
My Solution

Bash can have a problem running scripts that are not on the same partition as "/bin/bash".

I found a solution and have posted it @ http://opensuse.us/viewtopic.php?t=1534
 
Old 02-25-2007, 07:29 PM   #26
daniel.santos
LQ Newbie
 
Registered: Jun 2006
Location: Dallas, TX, USA
Distribution: Gentoo
Posts: 9

Rep: Reputation: 0
Haha!

Thanks man! I did the same goddam thing and I was like, WTF? I couldn't imagine having gotten a configure file that was cr/lf format, but checked it anyway -- and I have had problems with bash, when called as /bin/sh, screwing up on script files that have CR/LF (I dont remember which version however). Yea, I'm recycling some quick build-a-gentoo scripts I made last year and I forgot that I set my tmpfs mounts to noexec!

Thanks for this thread

edit: actually, I'm thinking this problem was a busybox ash shell, I can't remember which (might have been HP-UX crap too)

Daniel

Last edited by daniel.santos; 02-25-2007 at 07:30 PM.
 
Old 11-12-2010, 01:11 PM   #27
leiphasw
LQ Newbie
 
Registered: Oct 2010
Location: Morgantown, Pennsylvania, USA
Distribution: Angstrom
Posts: 16

Rep: Reputation: 0
I just had the same problem but had nothing to do with bash, etc. I was going to rebuild my machine from Ubuntu 10.4 to 10.10 and copied my home folder to an external NTFS hard drive to back it up. After loading 10.10, I copied everything back to my new home folder. In this process, all my executable ./configure files had their "executable" flag reset to not be executable. When I edited the properties of the ./configure file and clicked "Allow executing..." it worked again.

Apparently symbolic links AND executable script attributes don't pass through Windows file format successfully.
 
Old 12-25-2010, 04:11 AM   #28
FaithHeart
LQ Newbie
 
Registered: Dec 2010
Posts: 2

Rep: Reputation: 0
Wink Exec Permission

Partition does not have exec permission
 
Old 12-25-2010, 04:11 AM   #29
FaithHeart
LQ Newbie
 
Registered: Dec 2010
Posts: 2

Rep: Reputation: 0
Ubuntu 10.10 changed the default mount options for ntfs filesystems.

Some people make that http://waystop.blogspot.com/2010/12/...k-meerkat.html

All the best...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/bin/sh: bad interpreter: Permission denied njbrain Slackware 10 04-26-2010 11:46 AM
/bin/bash: bad interpreter: Permission denied cap_ahab Linux - General 4 01-17-2006 08:11 AM
/bin/sh: bad interpreter: Permission denied itsaso Linux - Newbie 6 05-18-2005 10:00 AM
Selinux, ./INSTALL: /bin/sh: bad interpreter: Permission denied TomF Linux - Security 2 12-08-2004 11:36 AM
/bin/sh: bad interpreter: Permission denied linmix Linux - Software 12 08-16-2004 06:40 AM


All times are GMT -5. The time now is 12:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration