LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   bad dmesg output when using ide-scsi boot parameter for IDE CD/DVD-ROM (http://www.linuxquestions.org/questions/slackware-14/bad-dmesg-output-when-using-ide-scsi-boot-parameter-for-ide-cd-dvd-rom-93891/)

Locura 09-17-2003 03:12 PM

bad dmesg output when using ide-scsi boot parameter for IDE CD/DVD-ROM
 
When I use "hdc=ide-scsi" in my lilo.conf to try to make my CD/DVD-ROM drive use SCSI emulation, the drive works fine, but I get this error over and over again when I run dmesg, and no other info would appear, just the error.

SCSI cdrom error : host 0 channel 0 id 0 lun 0 return code = 28000000

followed by something about what sector it is testing or something like that. Sorry I don't have the whole error, I have since removed that parameter from my lilo.conf and reinstalled lilo so I would stop getting that error, and since then output from dmesg has returned to normal. I'll get the full error later today and post it.

Anways, I'm wondering if there is something else I need to do to get it to work 100% properly with with SCSI emulation. I did a search and found something about using hdparm ro set parameters for the drive, but I don't know if the problem applies to what is going on with my computer, and I am not really experienced with hdparm and don't want to screw up my system by using it.

Locura 09-18-2003 08:39 PM

OK, I got the full error. It appears that dmesg actually was printing out meaningful data before the error, running dmesg >out.txt and opening the text file revealed that. Here is the data for my CDROM drives:
Code:

scsi0 : SCSI host adapter emulation for IDE ATAPI devices
  Vendor: TOSHIBA  Model: DVD-ROM SD-M1502  Rev: 1008
  Type:  CD-ROM                            ANSI SCSI revision: 02
  Vendor: CREATIVE  Model: CD-RW RW121032E  Rev: 1.02
  Type:  CD-ROM                            ANSI SCSI revision: 02
Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
Attached scsi CD-ROM sr1 at scsi0, channel 0, id 1, lun 0
sr0: scsi3-mmc drive: 48x/48x cd/rw xa/form2 cdda tray
Uniform CD-ROM driver Revision: 3.12
sr1: scsi3-mmc drive: 32x/32x writer cd/rw xa/form2 cdda tray


Locura 09-18-2003 08:41 PM

and here is the long error I am getting for my CD/DVD-ROM drive:
Code:

SCSI cdrom error : host 0 channel 0 id 0 lun 0 return code = 28000000
ILI Current sd0b:00: sns = 70 25
ASC=64 ASCQ= 0
Raw sense data:0x70 0x00 0x25 0x00 0x00 0x00 0x00 0x0a 0x00 0x00 0x00 0x00 0x64 0x00 0x00 0x00 0x00 0x00
 I/O error: dev 0b:00, sector 0
SCSI cdrom error : host 0 channel 0 id 0 lun 0 return code = 28000000
ILI Current sd0b:00: sns = 70 25
ASC=64 ASCQ= 0
Raw sense data:0x70 0x00 0x25 0x00 0x00 0x00 0x00 0x0a 0x00 0x00 0x00 0x00 0x64 0x00 0x00 0x00 0x00 0x00
 I/O error: dev 0b:00, sector 4
SCSI cdrom error : host 0 channel 0 id 0 lun 0 return code = 28000000
ILI Current sd0b:00: sns = 70 25
ASC=64 ASCQ= 0
Raw sense data:0x70 0x00 0x25 0x00 0x00 0x00 0x00 0x0a 0x00 0x00 0x00 0x00 0x64 0x00 0x00 0x00 0x00 0x00
 I/O error: dev 0b:00, sector 8

This error repeats for sector number after sector number, until it reaches sector 28.

Locura 09-21-2003 08:26 AM

Does anyone know how to fix this?

spurious 09-27-2003 08:14 PM

Heh, I had the exact same problem today (well, my ASC and ASCQ values were different, probably because my CD-RW is an HP-9100+) with Slackware 9.0.

I googled, searched and hacked all day, much to the consternation of my wife, and the answer is: turn scsi emulation off!

This thread helped:
http://www.linuxquestions.org/questi...n&pagenumber=2

I guess this is a Slackware quirk, because scsi emulation works fine on my Knoppix box and my previous RedHat 7.3 box. Thank goodness I read the above thread, which saved me from recompiling my kernel (as other threads have suggested).

However, I haven't tried writing to a CD-R yet; but, according to the above thread, cdrecord should work with an ATAPI device.

spurious 09-27-2003 11:23 PM

Just burned a CD-R, successfully, with:

cdrecord -v speed=8 -overburn driveropts=burnfree dev=ATAPI:0,0 -pad -data foobar.iso

(check your dev parameter with cdrecord dev=ATAPI -scanbus. A dev of 0,0,0 gives you dev=ATAPI:0,0)

Also see this thread: http://www.linuxquestions.org/questi...DATAPI+scanbus

Locura 09-28-2003 08:12 AM

That's all well and good, guys, but there is no problem with my CD-RW drive. I can burn CDs without a hitch. The problem I'm having is getting my DVD-ROM to not display all that junk when I run dmesg. It seems to work fine, I can play DVDs on it and all, but I know that dmesg output is not normal.

Cerbere 09-29-2003 02:36 AM

Well, if you follow the solution from the other thread, then you won't be dealing with scsi emulation. No scsi emulation should mean no scsi errors.

Enjoy!
--- Cerbere


All times are GMT -5. The time now is 03:32 PM.