LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Automounting fails on xfce (http://www.linuxquestions.org/questions/slackware-14/automounting-fails-on-xfce-694160/)

esters 12-31-2008 08:15 PM

Automounting fails on xfce
 
Running Slackware 12.2 with Xfce 4.4.3. For device mounting I have dbus, hal, thunar-volman and pmount. Neither do USB devices or CD/DVD discs are autmounted.

/etc/fstab

Code:

/dev/sda2        swap            swap        defaults        0  0
/dev/sda1        /                ext3        defaults        1  1
/dev/sda3        /home            ext3        defaults        1  2
#/dev/cdrom      /mnt/cdrom      auto        noauto,owner,ro  0  0
#/dev/fd0        /mnt/floppy      auto        noauto,owner    0  0
devpts          /dev/pts        devpts      gid=5,mode=620  0  0
proc            /proc            proc        defaults        0  0
tmpfs            /dev/shm        tmpfs      defaults        0  0

/etc/group

Code:

cat /etc/group | grep esters
lp:!:7:lp,esters
audio:x:17:root,esters
video:x:18:root,esters
cdrom:x:19:root,esters
plugdev:x:83:root,esters
power:!:84:esters
users:!:100:esters

When I plug in an ipod, lshal -m says
Code:

Start monitoring devicelist:
-------------------------------------------------
04:10:10.757: usb_device_5ac_1260_000A270019A4A4F8 added
04:10:10.928: usb_device_5ac_1260_000A270019A4A4F8_if0 added
04:10:10.936: usb_device_5ac_1260_000A270019A4A4F8_usbraw added
04:10:10.949: usb_device_5ac_1260_000A270019A4A4F8_if0_scsi_host added
04:10:15.757: usb_device_5ac_1260_000A270019A4A4F8_if0_scsi_host_0 added
04:10:15.764: usb_device_5ac_1260_000A270019A4A4F8_if0_scsi_host_0_scsi_device_lun0 added
04:10:15.832: usb_device_5ac_1260_000A270019A4A4F8_if0_scsi_host_0_scsi_device_lun0_scsi_generic added

And in the mean time thunar-volman gives this
Code:

thunar-volman: No property info.capabilities on device with id /org/freedesktop/hal/devices/usb_device_5ac_1260_000A270019A4A4F8
I'm running hal and dbus with stock config files. Thanks.

BCarey 12-31-2008 11:18 PM

Try xfce4-mount-plugin from slackbuilds.org. xfce4-volstatus-icon is useful as well.

Brian

esters 01-01-2009 06:09 AM

Thanks for the suggestions BCarey but none of them work :( I get the thunar-volman No property info.capabilities on device with id message every time I plug in an removable USB device.

wadsworth 01-01-2009 07:10 AM

Have you listed the devices you want pmount to handle in pmount.allow?

There's a note on the slackbuilds.org page for pmount:
Quote:

NOTE: It seems that detection of removable devices via hal no longer
works correctly, and pmount also seems unmaintained as of right now.
You should be able to populate /etc/pmount.allow with a list of your
removable devices to work around it; see pmount's man page for more
detailed information.

esters 01-01-2009 07:40 AM

Thanks for the tip wadsworth, but it doesn't work :<

dmesg

Code:

usb 1-2: new high speed USB device using ehci_hcd and address 6
usb 1-2: configuration #1 chosen from 1 choice
scsi4 : SCSI emulation for USB Mass Storage devices
usb 1-2: New USB device found, idVendor=13fe, idProduct=1f00
usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-2: Product: DataTraveler 2.0
usb 1-2: Manufacturer: Kingston
usb 1-2: SerialNumber: 5B871100013B
usb-storage: device found at 6
usb-storage: waiting for device to settle before scanning

fdisk -l

Code:

Disk /dev/sdd: 1000 MB, 1000341504 bytes
16 heads, 32 sectors/track, 3816 cylinders
Units = cylinders of 512 * 512 = 262144 bytes
Disk identifier: 0x00000000

  Device Boot      Start        End      Blocks  Id  System
/dev/sdd1              1        3816      976880    e  W95 FAT16 (LBA)

pmount -d /dev/sdd1

Code:

resolved /dev/sdd1 to device /dev/sdd1
Checking for device '/dev/sdd1' in '/etc/fstab'
mount point to be used: /media/sdd1
no iocharset given, current locale encoding is UTF-8
locale encoding uses UTF-8, setting iocharset to 'utf8'
Cleaning lock directory /var/lock/pmount_dev_sdd1
Checking for device '/dev/sdd1' in '/etc/mtab'
Checking for device '/dev/sdd1' in '/proc/mounts'
device_whitelist: checking /etc/pmount.allow...
device_whitlisted(): nothing matched, returning 0
find_sysfs_device: looking for sysfs directory for device 8:49
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/ram0 (1:0)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/ram1 (1:1)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/ram2 (1:2)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/ram3 (1:3)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/ram4 (1:4)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/ram5 (1:5)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/ram6 (1:6)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/ram7 (1:7)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/ram8 (1:8)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/ram9 (1:9)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/ram10 (1:10)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/ram11 (1:11)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/ram12 (1:12)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/ram13 (1:13)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/ram14 (1:14)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/ram15 (1:15)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/loop0 (7:0)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/loop1 (7:1)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/loop2 (7:2)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/loop3 (7:3)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/loop4 (7:4)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/loop5 (7:5)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/loop6 (7:6)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/loop7 (7:7)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/hda (3:0)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/hdb (3:64)
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/sda (8:0)
find_sysfs_device: major device numbers match
find_sysfs_device: minor device numbers do not match, checking partitions...
find_sysfs_device: checking whether device /dev/sdd1 matches partition 8:0
find_sysfs_device: checking whether device /dev/sdd1 matches partition 8:1
find_sysfs_device: checking whether device /dev/sdd1 matches partition 8:2
find_sysfs_device: checking whether device /dev/sdd1 matches partition 8:3
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/sdb (8:16)
find_sysfs_device: major device numbers match
find_sysfs_device: minor device numbers do not match, checking partitions...
find_sysfs_device: checking whether device /dev/sdd1 matches partition 8:16
find_sysfs_device: checking whether device /dev/sdd1 matches partition 8:17
find_sysfs_device: checking whether device /dev/sdd1 matches partition 8:18
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/sdc (8:32)
find_sysfs_device: major device numbers match
find_sysfs_device: minor device numbers do not match, checking partitions...
find_sysfs_device: checking whether device /dev/sdd1 matches partition 8:32
find_sysfs_device: checking whether device /dev/sdd1 matches partition 8:33
find_sysfs_device: checking whether /dev/sdd1 is on /sys/block/sdd (8:48)
find_sysfs_device: major device numbers match
find_sysfs_device: minor device numbers do not match, checking partitions...
find_sysfs_device: checking whether device /dev/sdd1 matches partition 8:48
find_sysfs_device: checking whether device /dev/sdd1 matches partition 8:49
find_sysfs_device: -> partition matches, belongs to block device /sys/block/sdd
device_removable: could not find a sysfs device for /dev/sdd1
Error: device /dev/sdd1 is not removable
policy check failed


BCarey 01-01-2009 08:45 AM

Could there be a problem with the physical drive itself? Could you try a different USB key?

Brian

esters 01-01-2009 08:56 AM

No, because I plugged the key into a laptop and it worked without problems.

Ilgar 01-01-2009 09:16 AM

Is your user in the plugdev gorup?

esters 01-01-2009 09:17 AM

Quote:

Originally Posted by Ilgar (Post 3393464)
Is your user in the plugdev gorup?

Yes

groups esters
esters : users lp audio video cdrom plugdev power

Ilgar 01-02-2009 03:14 PM

Do you see any files in the subdirectories of /etc/hal/fdi/ ? Any rules that disable polling?

SqdnGuns 01-02-2009 03:35 PM

From the pmount SBo README:

Code:

NOTE: It seems that detection of removable devices via hal no longer
works correctly, and pmount also seems unmaintained as of right now.
You should be able to populate /etc/pmount.allow with a list of your
removable devices to work around it; see pmount's man page for more
detailed information.

http://slackbuilds.org/slackbuilds/1.../pmount/README

BCarey 01-02-2009 05:27 PM

Have you enabled the automounting in thunar Preferences? Also, pmount shouldn't be necessary to do this, anyway. Maybe you should remove it.

Brian

Eternal_Newbie 01-03-2009 02:42 AM

If I remember correctly, for thunar itself to handle automounting you need to autostart it with XFCE. Create a .desktop file for thunar to ~/.config/autostart/ and call it thunar.desktop (BTW most filemanagers have an annoying habit of hiding the .desktop extension on a properly formed .desktop file).

This is the contents of mine:
Code:

[Desktop Entry]
Type=Application
Name=thunar
Comment=Needed for automounting
Exec=thunar --daemon
StartupNotify=false
Terminal=false
Hidden=false

Edit: copying the thunar.desktop file there and changing the command to thunar --daemon should work too.

Ilgar 01-03-2009 07:56 AM

I'm using XFCE, but automounting works without starting Thunar at login. Just install the Thunar-volman-plugin and from Thunar preferences->Advanced, enable volume management (and configure the options). No other software is needed.

esters 01-03-2009 04:34 PM

Thanks for the advice, but I ditched Slackware.


All times are GMT -5. The time now is 05:29 PM.