LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Automount of audio CD and play not working Slackware 13.37 64, XFCE and KDE (http://www.linuxquestions.org/questions/slackware-14/automount-of-audio-cd-and-play-not-working-slackware-13-37-64-xfce-and-kde-933484/)

saycheese 03-08-2012 03:27 PM

Automount of audio CD and play not working Slackware 13.37 64, XFCE and KDE
 
Hi all,

Recently installed Slackware64 13.37. Besides the nouveau driver fail issue (common across all distros unfortunately) everything installed fine. My system is updated with all the fixes from the repos as well.

When I put an audio CD in, nothing happened. When I manually opened Amarok, it see's the disc but won't play it. None of the other players wanted to work either. One of them did play after a while but only because it ripped the CD which isn't what I wanted. I first tried in XFCE and than I tried in KDE and neither worked. Nothing else is installed besides the standard stuff and the updates.

Is this feature just left out? Am I doing something wrong?

onebuck 03-08-2012 08:09 PM

Member response
 
Hi,

What groups do you have the user in;
Code:

users floppy audio video cdrom plugdev power netdev burning
EDIT: Welcome to LQ!

saycheese 03-09-2012 12:16 AM

Quote:

Originally Posted by onebuck (Post 4622353)
EDIT: Welcome to LQ!

Thank you! :)

I used the default groups when adding a new user:
Quote:

users floppy audio video cdrom plugdev power netdev scanner
All of them are the same as the ones you posted except at the end you have burning and I have scanner. Does it work for you? If so what program?

edit: I don't have a burning group.

onebuck 03-09-2012 08:45 AM

Member response
 
Hi,

'burning' group is used by 'k3b' and must be created. You add the user to that group when using the default 'k3b'.

You should check through 'dmesg' to see how the media devices are recognized.

saycheese 03-09-2012 10:58 PM

As a follow up in case anybody else bumps into this thread with the same problem...
My googlefu turned up no clear fix to get autoplay audio cd's working. There are a couple settings in KDE that lead you to believe the functionality is there though.

Found a lot of good information here: http://www.linuxquestions.org/questi...-2-4-a-791192/

Basically, if you pop an audio CD in ignore the KDE popup if you want to listen to it. Open up audacious and find the "Play CD" in the plugins menu. I tried adding a command to the KDE popup menu but that didn't do anything, had to be done manually. MPlayer worked on the command line too. Couldn't get Amarok to work with audio cds whatsoever.

mrclisdue 03-09-2012 11:41 PM

You mention in the thread title that you tried in xfce. Did you check the settings in Thunar for volume management and configure the behaviour?

cheers,

saycheese 03-10-2012 12:24 AM

Quote:

Originally Posted by mrclisdue (Post 4623170)
You mention in the thread title that you tried in xfce. Did you check the settings in Thunar for volume management and configure the behaviour?

I gave it a try. All the settings are checked under the storage tab and multimedia tab. The multimedia tab makes reference to a program called totem which isn't installed on slackware from what I can tell, so I've changed it to amarok, no luck. No matter what the CD never shows anywhere in the file system in XFCE.

Alien Bob 03-10-2012 06:55 AM

Quote:

Originally Posted by saycheese (Post 4623190)
No matter what the CD never shows anywhere in the file system in XFCE.

Audio CD's do not have a file system, so you will not be able to mount such a CD at all.

Eric


All times are GMT -5. The time now is 11:12 PM.