LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 08-09-2013, 08:33 AM   #1
Sefid par
Member
 
Registered: Jul 2013
Location: Iran, Tehran
Distribution: Slackware Current
Posts: 59

Rep: Reputation: Disabled
automake does not recognized by Glib


I have installed automake 1.14 and linux recognizes it.
But When I try to install Glib 2.36.3 it sais:
Code:
WARNING: 'automake-1.13' is missing on your system.
         You should only need it if you modified 'Makefile.am' or
         'configure.ac' or m4 files included by 'configure.ac'.
I think it acured because I didn't remove previous installed automake.
I thought that It would be needed to install the newer version of automake.

Do you have any idea?
 
Old 08-09-2013, 08:59 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,285

Rep: Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664
A warning is an informative text, not an error.

And : Glib 2.36.3 comes with a "configure" file.
The warning is about things to do when you have no configure file,
or want to generate a new `configure`, etc.
I.e. the warnings can be ignored.
 
Old 08-09-2013, 10:11 AM   #3
Sefid par
Member
 
Registered: Jul 2013
Location: Iran, Tehran
Distribution: Slackware Current
Posts: 59

Original Poster
Rep: Reputation: Disabled
- Is it fault to remove previous automake and install new one? Do I need previous version for compiling newer vresion?

- The entire error is this:
Code:
WARNING: 'automake-1.13' is missing on your system.
         You should only need it if you modified 'Makefile.am' or
         'configure.ac' or m4 files included by 'configure.ac'.
         The 'automake' program is part of the GNU Automake package:
         <http://www.gnu.org/software/automake>
         It also requires GNU Autoconf, GNU m4 and Perl in order to run:
         <http://www.gnu.org/software/autoconf>
         <http://www.gnu.org/software/m4/>
         <http://www.perl.org/>
make[4]: *** [Makefile.in] Error 127
make[4]: Leaving directory `/root/Softwares/glib-2.36.3/docs/reference/glib'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/root/Softwares/glib-2.36.3/docs/reference'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/Softwares/glib-2.36.3/docs'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/Softwares/glib-2.36.3'
make: *** [all] Error 2
 
Old 08-09-2013, 10:48 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,285

Rep: Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664
You are right, the glib autotools files must be processed
to use your version of automake, autoconf, etc.

Easily done with :
$ libtoolize && aclocal && autoheader && automake --add-missing && autoconf

.. And then please reconfigure : $ ./configure
 
1 members found this post helpful.
  


Reply

Tags
automake, glib


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Scribus installation problem, sez I need automake 1.6 when automake 1.9 is istalled Rockgod2099 Linux - Software 13 11-14-2004 07:37 PM
glib wont be recognized pasalacqua128 Linux - Software 3 06-02-2004 02:25 PM
glib-2.3.3 not recognized by ./configure tektone Linux - Software 1 03-01-2004 06:16 PM
slackware 9 asking for automake 1.6 while i have automake 1.7 gtgoku Slackware 1 10-19-2003 09:59 AM
help - glib-2.0 not recognized?! mjk Linux - Newbie 2 10-07-2003 02:51 PM


All times are GMT -5. The time now is 03:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration